English Amiga Board


Go Back   English Amiga Board > Support > support.OtherUAE

 
 
Thread Tools
Old 26 April 2022, 01:12   #1
Noob-tech-ninja
Registered User

Noob-tech-ninja's Avatar
 
Join Date: Nov 2020
Location: UK
Posts: 46
Question Amiberry > Auto-Fire, making games unplayable >

Hi there guys.

I was hoping that you could help me with an issue that I've been experiencing recently.

Background:
I've had a real urge to play some old skool shooters recently
(Uridium 2, R-Type, SWIV, Xenon 2, etc, etc)


Issue:
When playing these games on a Raspberry Pi 4, (using an X-box 360 pad)
If I use auto-fire the game becomes unplayable (Slows down / lag / jittery to unbelievably bad levels).

However if I use the fire buttons as normal (no auto-fire selected or in use),
then these games work fine.

I also have quite bad RSI (Repetitive Strain Injury) in my hands / wrists
So playing games can be very painful at times. So I try to limit my
time playing games (Hence the need for some help with the auto-fire)


Troubleshooting:
1. Tried using the different versions of auto-fire -
On / toggle / permanent.
= They all have same issue - (Slows down / lag / jittery)

2. Different joystick / gamepad types (E.G. Joystick emulation, CD-32 pad).
= Issue remains


Questions:
1. Is there anything that I can do, that will allow me to use the auto-fire
without rendering these games unplayable ?

2. Is this perhaps linked to the refresh rate (and the difference between
the old 50Hz / 60Hz that the Amiga is expecting), and the modern HDMI standard ?

2.1. Again (if so) Is there anyting that I can do about it ?


Useful details:
TV: Sony Bravia KDL-40CX523 / 40" LCD 1080p
Device: Raspberry Pi 4 (4 GB)
OS: Amiberry beta (2021-01-23)
Gamepad: X-Box 360

TIA for any help or advice.
Noob-tech-ninja is offline  
Old 03 May 2022, 20:22   #2
Noob-tech-ninja
Registered User

Noob-tech-ninja's Avatar
 
Join Date: Nov 2020
Location: UK
Posts: 46
3. I've just tested the auto fire function on FS-UAE (V.3.0.5)
with R-Type 1 & 2, and Xeon 2
And the games work brilliantly without any slow down or lag.

So this "appears" to be an Amiberry issue (so far)

The only (slight) problem, is that it's all or nothing
E.G. When auto fire is selcted, I cannot switch it off (to use a build up weapon)
on R-Type 1 or 2

But hey at least I can play the game without detstoying my hands/fingers/wrists
Noob-tech-ninja is offline  
Old 18 May 2022, 09:48   #3
midwan
Registered User

 
Join Date: Dec 2014
Location: Gothenburg, Sweden
Posts: 103
Have you tested this on the latest Amiberry version?
The January version you mentioned is quite old now, please try with 5.1 and if it's still an issue, feel free to open a bug case on Github so we can track it further.
midwan is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
auto fire - no joystick. UKShark support.Hardware 3 09 July 2019 15:46
Auto-Fire mapping for 2nd button Retro-Nerd support.FS-UAE 1 05 July 2016 06:24
Auto-fire Detection/Disabling? SunChild support.Games 3 12 September 2013 18:51
Auto auto fire? john4p request.UAE Wishlist 6 22 January 2010 08:50
Auto-fire Tim Janssen support.WinUAE 2 02 May 2002 08:42

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:15.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.06409 seconds with 14 queries