English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 07 September 2020, 07:10   #21
AC/DC HACKER!
Registered User

AC/DC HACKER!'s Avatar
 
Join Date: Aug 2016
Location: SCC-NAC-dC-iNT
Posts: 798
Hi White,

Nothing is truly random. I changed composite in the GUI.. Looked good for a bit, with real hardware and WinUAE but still...DSI hits happened. Much less, but still happen. Almost everything has a Cause and Effect...the "almost" details left out...I won't go into here. I appreciate your attention to detail... Which wrecks randomness.

I'm using UAEGfx screen modes exclusively for now. Which helps. More tests as I'm able...
AC/DC HACKER! is offline  
Old 07 September 2020, 09:11   #22
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,051
@AC/DC HACKER!
Here I made another test entirely dedicated to 3D then with wazp3D (warp3D) microbe3D etc.
4-5 wazp3D applications work simultaneously and I also use amiAMP.
I could also see the videos and do other operations but the resource seems busy somehow, who knows if there is a method of "assign-allocation process management to divide SDL calls for example" to make everything work.
The system remains stable no crash occurs.
Currently the 3D part is not supported, so the result looks good to me.
Precisely for this reason I always ask if other people use 4.1FE because surely more could be done.
In this case the stability of the system is excellent
here the test for any suggestions:
[ Show youtube player ]
White is offline  
Old 16 September 2020, 06:52   #23
AC/DC HACKER!
Registered User

AC/DC HACKER!'s Avatar
 
Join Date: Aug 2016
Location: SCC-NAC-dC-iNT
Posts: 798
I wasn't looking as closely as I should have. PFS3AIO has an affect. I'm slowly gathering info...for Toni. As able..
AC/DC HACKER! is offline  
Old 16 September 2020, 11:20   #24
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,051
@AC/DC HACKER!
this thread dates back to 2017 I used AIO to try but the results were lower in terms of performance, plus other disadvantages, maybe it can be useful to you.
https://eab.abime.net/showthread.php?t=86336
But I don't understand the use of AIO, sfs / 02 works very well.

If it helps, I can move everything to a .hdf
I currently use a real hard drive
White is offline  
Old 16 September 2020, 14:06   #25
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,051
@AC/DC HACKER!
I moved everything to .hdf (30gigabyte) hosted size.
No errors occur.
The actual hard drive feels more responsive but is not important for stability purposes.
I had also moved everything to SSD but the performance hadn't improved, indeed it seems that the mechanical hard-disk is synchronized in reading and writing better than the SSD.
While with the SSD the copying of the files seems not to be synchronized well.
If the SSD had any advantages I would definitely use it.
It is probably a question of configuration in emulation.
I have no real hardware and can't speak on that.
On the other hand, if at the time I would not have bought the 4.1FE I probably would never have emulated it since the 3.xx works perfectly.
The processor I use is at 4.2ghz I have also brought it to 4.4ghz but there is no difference regarding the resolution for example in the execution of Odyssey.
So I guess for a real speed boost the architecture of the new processors with bigger ram caches etc. is important.
But this I cannot know in practice.
I am very happy, however, the change of the processor would serve to increase the resolutions of the applications dedicated to the internet as well as a clearly faster program execution.
I use it because it works otherwise I wouldn't waste time.
All this time I've been looking for a setup that goes with everything.
I don't like having ten configurations for each different application.

The reason I use this configuration is because it works but I have no way of comparing it to anyone currently.
White is offline  
Old 17 September 2020, 22:15   #26
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,051
Some time ago I saw this video of an X5000 with amigaos 4.1 I simply tried to reproduce what was seen in this video:
[ Show youtube player ]

but I couldn't, today I finally managed to reproduce the promotion of some screens by modifying the RTG table like this:
8bit *
15 / 16bit
24bit
R8G8B8A8

everything works perfectly now the applications that allow it open on a proprietary screen (at least I think)
I have tried many other solutions but this RTG table is the only one to keep the operating system without problems of wrong colors etc. etc.
I hope it is useful and receive some suggestions
[ Show youtube player ]
White is offline  
Old 18 September 2020, 02:10   #27
AC/DC HACKER!
Registered User

AC/DC HACKER!'s Avatar
 
Join Date: Aug 2016
Location: SCC-NAC-dC-iNT
Posts: 798
Quote:
Originally Posted by AC/DC HACKER! View Post
I wasn't looking as closely as I should have. PFS3AIO has an affect. I'm slowly gathering info...for Toni. As able..

I'm using WinUAE 4.4.0 with my HardFile that's copied from my true Amiga 4000 Cyberstorm PPC's SD Card. There are several partitions. Most are setup for OS 3.5 using PFS3-AIO.. OS 4 has been setup to use that as well. I haven't been using OS 4 with A4000...much.


Due to wildfires here in Oregon, I've packed my A4000 hardware to be ready to leave. I made another backup and I've been using that with WinUAE before packing my Hardware. I was jusssssst starting to look at OS 4 a bit more with SDI when the major news broke...and we start to see the smoke in the skies.


Now, I'm using WinUAE exclusive other than my X5000.


My PFS3-AIO partitions are are causing problems in some ways with OS 4. Now I'm starting to understand WHY. Double emulation. Makes sense. Since Salem is cleared, but still dealing with a lot of smoke..and I'm staying inside, I'm getting read to make a new HF with only my OS 4.


I've already made a new partition on the SD Card HF...of OS 4, then changed the original OS 4 partition to SFS/00. Then copied OS 4 back to where it was. Yes, improvements in speed...due to removing an emulation (PFS3).


So....next is to copy OS 4 to it's own HardFile and go from there. Something I was going to do a looooong time ago...but many other things happened. I'll comment more soon.
AC/DC HACKER! is offline  
Old 18 September 2020, 23:19   #28
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,051
@AC/DC HACKER!
I followed the news on TV, I'm sorry I hope everything can be resolved quickly, these calamities are out of the ordinary and life is already difficult.
I hope all of this passes quickly.
White is offline  
Old 19 September 2020, 02:51   #29
AC/DC HACKER!
Registered User

AC/DC HACKER!'s Avatar
 
Join Date: Aug 2016
Location: SCC-NAC-dC-iNT
Posts: 798
We had much needed rain, lots of it, so where I am looks beautiful now. Smoke is gone, homes are clearing. Nahhh, these are ordinary for the Planet. It has been through many, many changes even before we were brought genetically into existence. Ancients before us talk about some events also. The are some of the events that happens when the Earth Axis changes..and when Beings make changes to the planet to knock it a bit out of balance.

As for Amiga OS 4, I got the single HF made and OS copied and cloned. Now that PSF3 isn't in play, I was noticing zero DSI hits until I ran Ranger with UAEGfx running. I switched back to Picasso 4 and that's gone. So far, now zero hits.
AC/DC HACKER! is offline  
Old 19 September 2020, 10:40   #30
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,051
Ranger is normal to crash, both the version included in 4.1FE and the A-EON version crash with the use of UAEGFX.
The only version that does not crash is the version attached to 4.1 Classic to be clear the one with updates 1-6 with (that version does not crash with UAEGFX)

separate note:
yes the earth's axis a few years ago 'shifted three degrees with the tsunami in japan it is as if the earth had made a leap of about 300 years into the future at least as regards the passing of time forward obviously a beat of eyelashes for the earth's geological age.
As for the ancients, history is fascinating in many ways our life 80 years on average is nothing compared to history I like these topics :-)
White is offline  
Old 19 September 2020, 19:35   #31
AC/DC HACKER!
Registered User

AC/DC HACKER!'s Avatar
 
Join Date: Aug 2016
Location: SCC-NAC-dC-iNT
Posts: 798
Quote:
Originally Posted by White View Post
Ranger is normal to crash, both the version included in 4.1FE and the A-EON version crash with the use of UAEGFX.
The only version that does not crash is the version attached to 4.1 Classic to be clear the one with updates 1-6 with (that version does not crash with UAEGFX)

Riiiight. I got that after the first note there. I hadn't delved deep enough into the versions (yet). I might get that version over.


Quote:
separate note:
yes the earth's axis a few years ago 'shifted three degrees with the tsunami in japan it is as if the earth had made a leap of about 300 years into the future at least as regards the passing of time forward obviously a beat of eyelashes for the earth's geological age.
As for the ancients, history is fascinating in many ways our life 80 years on average is nothing compared to history I like these topics :-)

Heh, first time I've read or heard anyone explain "In the blind of an eye." differently like that. The Earth has been around well, well, well, well over 10,000 years. All organized religions have gotten so much incorrect. People have the ability to live at least 500+ years on this planet but there are ingredients to understand it, eating, mental awareness, as well as intuition awareness (not instincts). I'm a huge buff into very ancient history also..don't enjoy "common religions" at all...they are too limiting and mentally stifling for me. Hence my avatar. So much to learn from history while living Now.
I adored the clearing of the air around the world when Covid became mainstream knowledge. Which also fits with my funny, warped, twisted sense of humor, haha! I was keenly watching the atmosphere changing when we stopped polluting. Animals started returning..and checking stuff. People are not a plague, as some "Conspiracy Guessers" say, I disagree completely with that..we can surely do a lot better and hopefully we'll start seeing Electric Vehicles rather than our current "gas" stuff. Anyway, the Ancients understood about anti-gravity..Tesla was on the right idea...next to what the Pyramids were for. I think it's absolutely fascinating that in Cuneiform..the start of Humanity and civilizations are explained in great details.


Back to Amiga OS 4... I thought I'd play around a little bit, so I renamed the Picasso 4 driver like can be done with Picasso96 68K but alas, it failed. Logic suggested it would but..EEEhhhh...gave it an attempt. I don't need Ranger..it's cool and fun to run like SysInfo 3/4 but not something I'd use often so a hit wouldn't be a big deal.
Adding Z3 RAM with 2 slots of 256MB with WinUAE sure help keeps it speedy. Odyssey is still a little slow with YouTube with my Ryzen. I played Rush's Tom Sawyer and some other songs by them and there are chops here and there...or lags. That should be related to X-Surf 100 using 68K Ethernet driver. Not any way around that...that I currently know of. I don't know of a PPC driver to use. But the hits are gone...so far, it's totally clean.


I've also done several (7+ in a row) "Reboot fast" and it's rebooting without coming across any errors as it did when PFS3 was part of the mix. I'm going to check my X5000 some, seems I might need to make some changes there also. This doesn't confirm a total solve..as I'd have to do at least 50 in a row, I think, to be much more sure about it. For now, it's doing a lot better.


Emulation..don't use PFS3 with WinUAE when also using a PPC partition. Real hardware, not such a big deal. Only notes, not conclusions.
AC/DC HACKER! is offline  
Old 19 September 2020, 21:02   #32
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,051
@AC/DC HACKER!
Yes Ranger is not important the solution currently is the one suggested above.
For Odyssey you should use this version:

http://kas1e.mikendezign.com/aos4/od...3r5_beta07.lha

It has a spoffing function for the user agent you are free to choose which one you prefer, but I recommend this:
Mozilla / 5.0 (BB10; Touch) AppleWebKit / 537.10 + (KHTML, like Gecko) Version / 10.0.9.2372 Mobile Safari / 537.10 +
you can see the speed so there is no limit in the resolution and you can also use the full screen to watch a video (the only limit is the processor in use)
as a network card you can use rtl8029-pci, however, even the x-surf is fine just to try
with this user-agent you can login on youtube gmail etc. and also upload videos for security reasons I do not advise you to do so.
Besides having no problems playing videos

For the video driver I have attached what I use is nothing special but it works so you can do your tests.
If Odyssey works, whatever you intend to use within winuae's current limits will work for you :-)
For the ram, 512mb is enough to try
for uaegfx 128mb it is enough.
I wanted to remake a video for a good 4.1FE configuration but I saw that it is not used much so I don't think it's urgent to do.


separate note:
for history and human progress, we are still very primitive and still far from being intelligent as a society.
Individually someone has "noble" thoughts but unfortunately they are not enough.
Perhaps over time we will learn as a society but it is not today's and not even with the next generations anything will change.
The earth is a world at war where race-related problems still reign.
It will take a long time.
I understand your speech but as long as all resources are used to abuse other peoples we remain primitive.
I have never heard anyone in my short life rise to power and talk about peace.

whereas, since I was a child, I have always liked to deepen the topics and understand how things work, including those listed by you. :-)
White is offline  
Old 20 September 2020, 00:42   #33
AC/DC HACKER!
Registered User

AC/DC HACKER!'s Avatar
 
Join Date: Aug 2016
Location: SCC-NAC-dC-iNT
Posts: 798
Quote:
Originally Posted by White View Post
@AC/DC HACKER!
Yes Ranger is not important the solution currently is the one suggested above.
For Odyssey you should use this version:

http://kas1e.mikendezign.com/aos4/od...3r5_beta07.lha

It has a spoffing function for the user agent you are free to choose which one you prefer, but I recommend this:
Mozilla / 5.0 (BB10; Touch) AppleWebKit / 537.10 + (KHTML, like Gecko) Version / 10.0.9.2372 Mobile Safari / 537.10 +
you can see the speed so there is no limit in the resolution and you can also use the full screen to watch a video (the only limit is the processor in use)
as a network card you can use rtl8029-pci, however, even the x-surf is fine just to try
with this user-agent you can login on youtube gmail etc. and also upload videos for security reasons I do not advise you to do so.
Besides having no problems playing videos

For the video driver I have attached what I use is nothing special but it works so you can do your tests.
If Odyssey works, whatever you intend to use within winuae's current limits will work for you :-)
For the ram, 512mb is enough to try
for uaegfx 128mb it is enough.
I wanted to remake a video for a good 4.1FE configuration but I saw that it is not used much so I don't think it's urgent to do.

Well, look at that...they have been progressing with it. Sweet!! It's still slightly choppy with caches, but I'll check into it more soon.


Quote:
separate note:
for history and human progress, we are still very primitive and still far from being intelligent as a society.

Not able to agree with that. There are a very high amount of smart and intelligent, as well as intuition aware people around - aside from the Netflix Binge Watching people...whom could fit that statement.



Quote:
Individually someone has "noble" thoughts but unfortunately they are not enough.
Perhaps over time we will learn as a society but it is not today's and not even with the next generations anything will change.

That's a bit jaded. Generations of armageddon talk and doom-sayers have all shown to be incorrect. We're still here. The Planet is also. It will remain.

Quote:
The earth is a world at war where race-related problems still reign.
It will take a long time.

The Long time has already been. Resolutions are already being made. But you stated it, people control of people continue on. There has already been outside influences other than us at Missile Silos stopping them.



Quote:
I understand your speech but as long as all resources are used to abuse other peoples we remain primitive.
I have never heard anyone in my short life rise to power and talk about peace.
I've been around for a while and I've heard a lot of talks of peace, and the other candidate than Mr. "Goofy" we have in Office in the States now is talking a lot about it. The BLM movement was pretty big. Anyway, I want to stay away from political stuff here. The World population will never have 100% peace that sustains forever. You have to have contrast to have Life. With all the "Think only Positive Thoughts" moment that's been happening all over, they're missing the power of Both negative and positive. Negative also creates the way for positive, and visa versa. It's that way on all planets.



Quote:
whereas, since I was a child, I have always liked to deepen the topics and understand how things work, including those listed by you. :-)

I'm with that but this forum is retro geared. So, for those chats to go deeper it has to be in PM or other fora for such depth. I also want to be sure to keep everything peaceful and respectful. These topics, for some people, can become inflamed. I have zero desires for that. Smiling.


Back to Odyssey Beta.. I'll have to check with more of the user-agents. The one you provided is doing a good job, once I got the string to enter correctly. Hmm..is the Picasso 4 and VRAM slowing things that much?? Going to check with UAEGFx again. I'm also not overclocking my Ryzen 3600. I thought something was broken a few days ago when I noticed YouTube's icons weren't looking colorful. A lot of grey blobs...then I realized it had to do with spoofing. I picked iPad before and the one worked. So, shall examine more. Appreciate the link to the beta! So far, still not any hits.
AC/DC HACKER! is offline  
Old 20 September 2020, 03:58   #34
AC/DC HACKER!
Registered User

AC/DC HACKER!'s Avatar
 
Join Date: Aug 2016
Location: SCC-NAC-dC-iNT
Posts: 798
After a several hours I've also "confirmed" with WinUAE, anyway, the Beta UAE buried back a bit from the archive you shared hasn't locked or caused an DSI hit. Now I'm going to check with my X5000 soon. Copying data from host to Emulator and visa versa. That is a bit deal. Might be very different with X5000. More soon.
AC/DC HACKER! is offline  
Old 20 September 2020, 11:12   #35
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,051
@AC/DC HACKER!
Well the uaegfx driver then it means somehow it works, thanks again for your testing and your patience.
I understand it's boring, that's why I really appreciate it :-)

Do you have a video capture program that works with winuae?
like this?
[ Show youtube player ]

eventually i can make a very fast video with freshly installed amigaos4.1FE without additional programs and just install Odyssey to make things easier for using winuae.
With basic configuration for peripherals such as pci video card network driver etc.
It would be a good idea?

separate note:
As far as the story is concerned, I agree with you.
it was just a way to exchange some opinions :-)
White is offline  
Old 20 September 2020, 13:45   #36
Hypex
Registered User

 
Join Date: May 2015
Location: Australia
Posts: 86
Quote:
Originally Posted by AC/DC HACKER! View Post
I get DSI hits if I run E-UAE ( http://os4depot.net/?function=showfi...uae-amigfx.lha ), Directory Opus 4 or 5..at times. Choose to Ignore the hit and let the emulator finish. With the file managers...the current task, then reset machine/emulation. Usually DOpus doesn't cause it... There are bugs in OS 4.1.1, and the programs. Definitely with E-UAE's copying a file FROM E-UAE emulation to host Amiga. I haven't noticed any data damage from it..when I choose to ignore.

What sort of bugs in OS 4.1.1 in particular?


As to E-UAE crashing, with file copying to host, that is a very old bug I have only seen on OS4. I have not seen it on x86 or any other ports. The OS4 port of UAE is doing something very wrong. I suspect it is calling a DOS function that frees some handle, but the guy who wrote it missed some small detail in the API, that has the result of taking down the whole system. I've done it myself, thought I had followed the autodoc, only to find on OS4 it crashed hard and I was left to pick up the pieces. I've been wondering where in the code it crashes for years so I can fix it!


These things would go unnoticed on 68K because illegal writes or not following an API was allowed on the hardware. Zero page was chip ram so didn't bring the system to a halt. Unfortunately this means a lot of 68K software is trashing memory but it went past unchecked. You pass a null pointer to an OS3 function that doesn't check for a valid pointer and it whizzes by, but do so on OS4 that also doesn't check, and it can bring the down hard, despite doing so because of memory protection.


DOpus 4 and 5 should be solid. At least PPC native. Never had any major problems on version 4.

Last edited by Hypex; 20 September 2020 at 13:54.
Hypex is offline  
Old 20 September 2020, 22:32   #37
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,051
@AC/DC HACKER!
I forgot to tell you that if you use beta 07 you have to delete the old odyssey folder and don't overwrite it otherwise you won't be able to view youtube correctly.
and then unpack the 07 in your path then delete all existing cookies.

also update amissl to version 4.6 you can find it on osdepot
I hope it is useful :-)

what resolution do you currently use in the amigaos desktop?
White is offline  
Old 20 September 2020, 23:49   #38
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 1,051
@AC/DC HACKER!
There are some real hardware functions that cannot be replicated with winuae using odyssey.
I managed somehow to make these functions compatible using MUI the following video is at the resolution of 1024x768 you don't have to pay attention to the black bands it is the capture program that shrinks the screen when I use this function with odyssey in reality the bands are not seen if I don't use the video capture program.

Are your videos you're rehearsing with Odyssey similar to this in speed?
[ Show youtube player ]
White is offline  
Old 21 September 2020, 01:44   #39
AC/DC HACKER!
Registered User

AC/DC HACKER!'s Avatar
 
Join Date: Aug 2016
Location: SCC-NAC-dC-iNT
Posts: 798
Greetings Hypex,



Quote:
Originally Posted by Hypex View Post
What sort of bugs in OS 4.1.1 in particular?

I dismissed a lot of stuff many months ago..and didn't make notes except in mind. You've seemed to cover them below, though. I also haven't checked for an Update to DOpus 4 or 5 in many months. I have been more focused on my A4000 and SCSI2SD hardware and firmware, and then other stuff.. I put my X5000 away for a bit. Hehe.


Since I've made a new HardFile for OS 4 and now it's using native SmartFileSystem SFS/00 it's doing very well. I've run, and exited DOpus 5 (with my config from the 90's..) over 20 time and so far not 2 DSI hit. More to check on that to confim. Same with my X5000...more running and exiting to do. Usually there Were crashes before loading all the way. Exit...I don't recall any crashes.
Opus 4...I still don't run much..and still using my original config. I haven't noticed that crash at all.


UAE, I'm now running (after backup of previous old version) the new one I recently found where Alt+Return switches window/full screen. OOOOhhh, that's really helpful!! I didn't notice Any problems with copying a zip file, or LZX file to and from, and from and to UAE to X5000 host. So, that SEEEEEeeeeems to be fixed. Whew! Haaaahaa! I'll check that more soon, such as extracting. Which is what I noticed through WinUAE also.

I decided for the fun of it, with X5K only...to run Payback 68K and that caused a DSI hit, which I suspected it would because of what you outlined, seeking hardware. More checking soon.


Quote:
As to E-UAE crashing, with file copying to host, that is a very old bug I have only seen on OS4. I have not seen it on x86 or any other ports. The OS4 port of UAE is doing something very wrong. I suspect it is calling a DOS function that frees some handle, but the guy who wrote it missed some small detail in the API, that has the result of taking down the whole system. I've done it myself, thought I had followed the autodoc, only to find on OS4 it crashed hard and I was left to pick up the pieces. I've been wondering where in the code it crashes for years so I can fix it!

These things would go unnoticed on 68K because illegal writes or not following an API was allowed on the hardware. Zero page was chip ram so didn't bring the system to a halt. Unfortunately this means a lot of 68K software is trashing memory but it went past unchecked. You pass a null pointer to an OS3 function that doesn't check for a valid pointer and it whizzes by, but do so on OS4 that also doesn't check, and it can bring the down hard, despite doing so because of memory protection.

DOpus 4 and 5 should be solid. At least PPC native. Never had any major problems on version 4.

I have experienced a complete OS 4 lock a few times as you have with OS4Depot version, but usually reset button gets things going again. I haven't noticed any data loss. I'd type crossing fingers but luck is a superstition I don't buy into. Hehe. An event will happen or not. I'm glad to know there is still fixing happening with UAE. I'm curious, to you or anyone else part of it.. Any plans to bring current WinUAE to OS 4? Or update it some from WinUAE updates/forks? Maybe have CyberstormPPC function through UAE?? Not any harm in asking even if I might be laughed at. Grinning.

Oops..update, I don't do it often, but sometimes I start a new DOpus 5 and it's already running. Click on Cancel vs Run Again and DSI hit.

Last edited by AC/DC HACKER!; 21 September 2020 at 02:14. Reason: Update
AC/DC HACKER! is offline  
Old 22 September 2020, 07:52   #40
Hypex
Registered User

 
Join Date: May 2015
Location: Australia
Posts: 86
Quote:
Originally Posted by AC/DC HACKER! View Post
Greetings Hypex,

Thank you and greetings also.


Did you really hack AC/DC?


Quote:
I dismissed a lot of stuff many months ago..and didn't make notes except in mind. You've seemed to cover them below, though. I also haven't checked for an Update to DOpus 4 or 5 in many months. I have been more focused on my A4000 and SCSI2SD hardware and firmware, and then other stuff.. I put my X5000 away for a bit. Hehe.
I'm a fairly seasoned OS4 user. Having been one since the AmigaOne XE times. Migrating myself from my main A1200/030 system to the XE. Then purchased an X1000. Despite being better hardware than the XE, CFE put me off and I ended up storing that away for a while as my XE booted faster than the X1000!


At some time I acquired an A4000 a friend help me set up with a decent 060 configuration. For a time it was used more than my X1000. Until hardware issues with the XE caused me to bite the bullet and setup the X1000 as my main OS4 machine. Now I use the A4000 less, but I always take it Amiga meetings, when we could have meetings.



Quote:
Since I've made a new HardFile for OS 4 and now it's using native SmartFileSystem SFS/00 it's doing very well. I've run, and exited DOpus 5 (with my config from the 90's..) over 20 time and so far not 2 DSI hit. More to check on that to confim. Same with my X5000...more running and exiting to do. Usually there Were crashes before loading all the way. Exit...I don't recall any crashes.
Opus 4...I still don't run much..and still using my original config. I haven't noticed that crash at all.

I use SFS now on my OS4 partitions. People like to use SFS2 as it's 64 bit, but without recovery tools I can't run the risk. I wonder if an old config in a newer DOpus would trip it up? Well, I would have done that at first. Then found things missing that broke it. LOL. Saving it out should fix any incompatibility issues.



I must admit I've only tested DOpus4. I'm used to the latest, then get annoyed when I find the DOpus4 on my A4000 lacks features, and I always forget to update it. My Amiga club had a DOpus5 discount I bought into back in the day, with full box with manual, it was a good deal. But I couldn't get used to the interface. The split from twin to multi folders was one thing but the gadgets were another. I just wanted plain text telling me what things are, not a pirate head I had to press, to delete. So it just put me off and I went back to DOpus4. Yes it would have been configurable but I didn't bother going deep into it.



Quote:
UAE, I'm now running (after backup of previous old version) the new one I recently found where Alt+Return switches window/full screen. OOOOhhh, that's really helpful!! I didn't notice Any problems with copying a zip file, or LZX file to and from, and from and to UAE to X5000 host. So, that SEEEEEeeeeems to be fixed. Whew! Haaaahaa! I'll check that more soon, such as extracting. Which is what I noticed through WinUAE also.

I know about the Ctrl-Alt R for reset and Crtl-Alt Q for quit but this screen combo sounds useful.



I'm currently using the X1000 EUAE JIT version. I need to use the X1000 version as the others crash. Though the one included with RunInUAE works fine. But my P96 modes have gone missing. It was bad enough on the real thing but I cannot deal with an AGA only Workbench in the modern age.



I found an old Hyperion thread where I detailed the problem. Okay so writing a small file to host causes it. MaxTransfer issue lol? I use MultiView as a test as it's a ~20KB file that does it. Just ignore the posts where I was misunderstood. Did I say my FFS was invalid and crashed?



https://forum.hyperion-entertainment...=2211&start=10



Quote:
I decided for the fun of it, with X5K only...to run Payback 68K and that caused a DSI hit, which I suspected it would because of what you outlined, seeking hardware. More checking soon.
Payback used to work on my XE fine. I don't recall it crashing. I found it stable enough. Need to test it on my X1000. But I used to run the PPC version which ran really well in 3d. Unfortunately it had no sound. The Mac version looked exactly alike and with sound!

Quote:
I have experienced a complete OS 4 lock a few times as you have with OS4Depot version, but usually reset button gets things going again. I haven't noticed any data loss. I'd type crossing fingers but luck is a superstition I don't buy into. Hehe. An event will happen or not. I'm glad to know there is still fixing happening with UAE. I'm curious, to you or anyone else part of it.. Any plans to bring current WinUAE to OS 4? Or update it some from WinUAE updates/forks? Maybe have CyberstormPPC function through UAE?? Not any harm in asking even if I might be laughed at. Grinning.

I'm not aware of any updates like that. When I look it's still based on some old EUAE version that was a fork of some older UAE version with some newer patches. Be good to get it up to date. Linux had EuaE as well on PPC. I've actually thought about how to integrate PPC myself. Running native on PPC would be good but not all PPCs are equal so CyberStormPPC code will crash on Sam/X1000/X5000. This is comparing with Heretic II WOS (I think it was), that works fine on my XE but will crash a Sam flex. The G3/4 is quite compatible but the Sam and the rest are different ISA models, especially the embedded PPC models, which will break more easily.

They could adopt the QEMU method W-UAE uses but it would be inefficient. Still it would work. But using WarpOSEmu would be better. Or some kind of PPC VM.


I'm sure the EUAE crash is due to misuse of a DOS function. Some DOS functions do things like freeing locks when giving a file handle from a lock. And if you missed the detail your code will be dangerous. I found this out myself, when I wrote my own file loading routine that opened a file from a lock. On OS4 it crashed. I eventually went through my code and found I had missed a small detail that has a big effect. Now, it easy to blame OS4 for freezing and go on about the bugs and how lame it is because the same thing works fine on OS3. But the fact is, a lot of 68K code was dirty, and OS4 brought the truth out. OS4 just reacts very badly to bad code.



I tend to think the OS and APIs should check all pointers and throw an alert. That would be better than the OS claiming ignorance and trusting everything because it's the Amiga way then leaving it up to you to figure out why the system just locked up. It's more frustrating when you are writing a program, that suddenly freezes the whole system and you need to get your serial cable and spend two weeks viewing live crash logs, that still give no clue what is going wrong. Only to find in the end that a null buffer was sent in a device call. Well it could have just told me!!!



Okay rant over.



Quote:
Oops..update, I don't do it often, but sometimes I start a new DOpus 5 and it's already running. Click on Cancel vs Run Again and DSI hit.

Ah, you found a bug, good one. Is kas1e on here? He was maintaining it.

Last edited by Hypex; 22 September 2020 at 08:09.
Hypex is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blitter interrupt during VERTB interrupt phx Coders. Asm / Hardware 32 03 December 2017 12:34
How to pass data to interrupt handler with VBCC? strim Coders. System 3 18 January 2016 15:38
Interrupt 7 BigT support.WinUAE 2 07 September 2013 23:25
OSCAR / TROLLS for DSI plasmatron Retrogaming General Discussion 0 05 September 2009 19:31
The easiest way to transfer data between Amiga and PC using a mass storage Another World support.Other 15 07 January 2009 05:51

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.11401 seconds with 14 queries