English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 13 November 2020, 10:19   #1
Pheonix
Registered User
 
Join Date: Aug 2009
Location: Waco USA
Posts: 253
OS 3.1.4 & Default Icons

Is there, anywhere, a list of the def_????.info names for available default icons in OS 3.1.4? I know some of them (listing below.) But would like to find a more complete listing. More specifically, would love to get the MFS options to work correctly, and separate Icons for CD & CDDA disks, etc...

The ones I know:
def_disk.info - default for a disk that doesn't have a more specific one set up
def_<DEV>.info - <DEV> is CD0, DF0, DH0, etc... Will mark a disk in that sepific mounted drive (def_CD0.info for CD0:, etc...)
def_project.info
def_tool.info
def_trashcan.info
def_drawer.info

Most of the others don't do anything that I can discover def_drive.info is supposed to be for a hard drive, but it will use either def_<DEV>.info (with the specific device name - DH0, DH1, etc...) or def_disk.info. I've tried installing DefIcons44 from aminet (and a couple of the others as well,) but they don't work. DefIcons44 may work, if I had some way of running the preferences program.
Pheonix is offline  
Old 13 November 2020, 10:49   #2
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 5,111
Yeah, DefIcons would probably solve the issue for you, because 3.1.4, 3.1, 3.0 and 2.x only support the ones you list IIRC. DefIcons is intended for use with OS 3.5, and is a part of 3.9, and the preferences program uses ReAction because of this. It should be possible to copy the ReAction parts necessary from OS3.9 to get the preferences program working.

DefIcons is one of the big things I miss from OS 3.9 when moving to OS 3.1.4, but I believe it is to be re-included in OS 3.2.
Daedalus is offline  
Old 14 November 2020, 02:42   #3
Pheonix
Registered User
 
Join Date: Aug 2009
Location: Waco USA
Posts: 253
What are the ReAction parts? I've tried copying everything I can think of without much success

EDIT: OK, figured it out. I wasn't copying the "Images" directory contents. Everything I was finding specified the "Gadgets" directory, but nothing mentioned the "Images" directory

Last edited by Pheonix; 14 November 2020 at 03:24.
Pheonix is offline  
Old 14 November 2020, 20:08   #4
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,425
To activate ReAction and use OS 3.9 ReAction applications you need at least:

Gadgets:
button.gadget
checkbox.gadget
chooser.gadget
clicktab.gadget
datebrowser.gadget
getfile.gadget
getfont.gadget
integer.gadget
layout.gadget
listbrowser.gadget
palette.gadget
radiobutton.gadget
scroller.gadget
slider.gadget
space.gadget
speedbar.gadget
string.gadget

Images:
bevel.image
bitmap.image
drawlist.image
glyph.image
label.image
penmap.image

Libs:
resource.library

Classes:
window.class

Fonts:
RAfallback
RAfallback.font

Env-Archive:
deficons.prefs

Last edited by AMIGASYSTEM; 14 November 2020 at 20:19.
AMIGASYSTEM is offline  
Old 15 November 2020, 12:26   #5
Minuous
Coder/webmaster/gamer
Minuous's Avatar
 
Join Date: Oct 2001
Location: Canberra/Australia
Posts: 2,210
That may be enough for the application in question but will not be enough to run all ReAction applications. Eg. some require texteditor.gadget.
Minuous is offline  
Old 15 November 2020, 13:25   #6
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,425
Quote:
Originally Posted by Minuous View Post
That may be enough for the application in question but will not be enough to run all ReAction applications. Eg. some require texteditor.gadget.

You will probably also need a few more .gadgets and some more .images, you could copy all the missing gadgets, class and images
I have tested only all the applications in the "Prefs" folder where they all work well.
The only strange thing I found is that the "deficons" application opens on a strange low resolution screen Pal

Last edited by AMIGASYSTEM; 15 November 2020 at 13:41.
AMIGASYSTEM is offline  
Old 20 November 2020, 23:00   #7
AmiClassic
Registered User

AmiClassic's Avatar
 
Join Date: Feb 2020
Location: PL
Posts: 26
Quote:
Originally Posted by Pheonix View Post
I've tried installing DefIcons44 from aminet (and a couple of the others as well,) but they don't work.
DefIcons44 works in OS 3.1.4 without problem, not work only DefIconPrefs (but there's not much to 'rummage' there, possibly you can edit them in 3.5 or 3.9 and move preferences file to 3.1.4). They even work in OS 3.1 (with SetPatch and workbench.library from OS 3.9).

Last edited by AmiClassic; 20 November 2020 at 23:23.
AmiClassic is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with default icons in OS 3.9 VoltureX support.Apps 8 06 September 2013 22:15
Change default disk icons in ClassicWB 3.9 Vegas project.ClassicWB 5 09 June 2010 14:55
default icons to double height rare_j request.Apps 1 29 December 2009 15:28
WinUAE default icons - how to change them Magno Boots support.Other 1 18 June 2007 22:05
How to change default system folder icons digital support.Apps 3 16 March 2003 09:54

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:57.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.07985 seconds with 15 queries