English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 28 June 2019, 18:22   #1
dirkwhoffmann
Dirk Hoffmann
dirkwhoffmann's Avatar
 
Join Date: Jun 2019
Location: Karlsruhe
Posts: 14
Question Sprite clipping question (OCS Amigas)

Hi there,

I have a (possibly stupid) question which I can't answer myself. First, here is a picture of how my emulator (vAmiga) draws the WB screen at the moment:

https://github.com/dirkwhoffmann/vAmiga/issues/74

The mouse pointer is not drawn correctly yet. In UAE, the first horizontal sprite line (the black line) is clipped, but I don’t understand why. I checked the DIWSTRT value which is set to 5 (vertically), so the line is inside the display window.

Can somebody tell me why the sprite is clipped in this line? How are the exact clipping rules for sprites on OCS Amigas?

Any help is highly appreciated!
dirkwhoffmann is offline  
Old 28 June 2019, 19:10   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 23,959
No bitplanes enabled?

Sprites don't exactly work like documented, there are lots of unexpected surprises..

- scan line's bitplane logic must be active = sprites can't be horizontally visible until first BPL1DAT write.
- inside display window (*). Except 1 lores pixel before first bitplane pixel.. As documented in HRM, first bitplane pixel is delayed by 1 lores pixel. But sprites are not delayed..
- *) sprites ignore horizontal end!

And more..
Toni Wilen is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
List of WHDLoad games that (potentially or actually) work on OCS Amigas A500 project.WHDLoad 19 09 April 2020 11:05
Yoomp! game on OCS Amigas. Toni Galvez Coders. Asm / Hardware 42 20 February 2020 15:53
Alien Breed: Tower Assault HDD package (+CDXL intros for AGA/OCS Amigas) earok Amiga scene 5 05 November 2016 00:03
Sprite Channel Question LuMan Coders. Blitz Basic 2 17 March 2016 16:51
Sprite corruption with OCS Agnus, ECS Denise, Kickstart 3.1 mark_k support.WinUAE 18 08 January 2015 15:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:37.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.05996 seconds with 13 queries