English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 15 May 2010, 12:27   #1
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
WinUAE 2.2.0 beta series

You better read this: http://eab.abime.net/showthread.php?t=26715 before posting anything. Offtopic = delete-button.

2.2.0 beta series. Lots of thing can be broken.
Toni Wilen is online now  
AdSense AdSense  
Old 15 May 2010, 12:30   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
http://www.winuae.net/files/b/winuae_2200b1.zip

Beta 1: Too much stuff. Including always requested easy game ports remapping.

- less hacky cue/iso selection priority handling inside archives
- autoscaled top border was incorrectly positioned if program had always-on bitplane DMA and first background color change was later than vertical bitplane DMA start position (Shadow of the Beast)
- do not enable OpenAL or PortAudio support by default (there are some bad OpenAL drivers that crash when enumerating devices...)
- save also rom checksum to configuration files, configuration file checksum is now used to find rom path from rom scanner data if path stored in config file does not exist
- removed Windows 2000 compatibility code (mainly RTG guard page stuff)
- D3D mode is more compatible with crappy Intel integrated GPUs that have hardware pixel shader but only software vertex shader support (scanlines and shader filters should work now)
- WASAPI and PortAudio sound volume control supported
- 7zip support moved to static link lib, updated to latest LZMA SDK, PPMD supported (no XZ because currently only plain XZ (de)compression appears to be supported in SDK)
- static png and zlib libraries updated to latest versions
- virtual directory drive fake block device geometry and block size set to non-zero values to fix sys:system/format division by zero crash when started from WB
- cycle exact custom cpu frequency calculation fixed
- remove non-existing paths in disk history when selected (not automatic because they might point to non-existing network shares = "unexplained" slowdown at startup possible)
- 68030 instruction and data cache "cycle exact" emulation code added, (68020 and 68030 caches are slightly different 68020's cache is 64*1 longs, 68030's cache is 16*4 longs). Data cache can only cache fast ram and rom. (MMU is normally used to prevent IO and chip ram data caching) Because native expansion code (bsdsocket etc..) bypasses the cache, if there is emulated cache hit, data in memory is compared with data in cache and real
memory data is used instead of stale data in cache. (test read is direct access, it does not mess up timing). This also means you will have problems if you use old "68030 cycle exact" configurations, this mode was never supported. Not that this new mode isn't any better..
- made 68020 "CE" NOP slightly slower (move.w to somewhere followed by NOP: write must be complete before NOP finishes, Roots 2.0 / Sanity globe effect)
- Roots 2.0 / Sanity "flower zoomer" part gaps fixed (BPLCON4 color change has 1 lores pixel delay compared to direct color register write. AGA-only feature)
- sprite emulation change, removed few lines of code that was not needed anymore (I hope..), this fixes missing bottom part on Roots 2.0 / Sanity "flower zoomer" part
- directory filesystem uses now indirect memory access (read&write is still direct, no performance loss + cache flush if in CE030 mode), better compatibility with dcache and MMU (other modules will follow)
- 68020 "CE" mode movem and some other instructions used direct memory accesses instead of cycle exact fetch modes (=was too fast if accessing chip ram)
- power led fade hack emulation improved
- -disableharddrivesafetycheck command line parameter disabled, it is not needed anymore (it was made when there was no "is drive mounted in Windows" test) This parameter has also become THE FIX for every, even totally unrelated possible, HD/CF related problem...
- toggle between fullwindow and fullscreen if started in fullwindow mode
- fixed data coruption in input parsing if mapped key did not exist (different keyboard)
- transparent archive support updates and handle leak fix
- small filter panel GUI changes
- single/double/triple buffering option added to Display panel, also affects D3D now mode now
- enabling any "raw" input device disables all "super" devices if they have same device class (and vice versa) For example "Windows mouse" enabled, enable "raw mouse" -> "Windows mouse" gets disabled.
- GUI treeview and listview "hot underline" mode enabled
- missing input keyboard name and status lines added to configuration file
- Game Ports panel settings does not use special case handling anymore, input panel slot #4 is now "Game Ports" configuration slot, all gameports panel settings are always converted to this slot. (slot #4 because I didn't want add new slots and slot #4 is most likely to be free)
- slot mentioned above is used to store new easy to use new game ports input mapping
- added "Test" and "Remap" buttons to Input panel, both temporarily enables all input devices, disables GUI and waits for any input, when input event is received, input device and event type gets selected automatically. "Remap" exists immediately when any event arrives, "Test" stays active until F12 is presed. (or if GUI window becomes inactive) Only "raw" devices detected (for example "super mouse" and "raw mouse" don't really play well together)
- GUI listviews remember old cursor positions
- default caps lock key input configuration was incorrectly saved to configuration
- easy joystick remapping support finally implemented.
- autofire checkboxes added to gameports, sets/disables fire button/CD32 red button autofire, autofire rate modified, it is much faster now (test games and report)

Quick instructions for new Game Ports panel remapping function:
- First select type of Amiga side device (mouse/joystick/analog joystick etc..).
- "Default" device type = mouse in port 0, joystick in port 1.
- Click Remap and the rest is near automatic
- Click Test to check and test current device type mapping (both built-in and remapped).
- F12 = exit, F11 = skip current event (jump to next event without mapping)

NOTE:NOTE:NOTE: Answer is still the usual: "Use Input Panel" if you want something more complex. This is the QUICK and EASY solution for most commonly needed joystick remapping.
Toni Wilen is online now  
Old 15 May 2010, 13:15   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
Note: filesystem does not currently work in 68000 cycle-exact mode.

Edit: it is design flaw (time to fetch the brown paper bag) in indirect filesystem, it is threaded, you should not call any cycle-exact memory functions from other threads.. Filesystem structures in chip ram in cycle exact mode: bad things will happen. Will be fixed soon.

Last edited by Toni Wilen; 15 May 2010 at 13:29.
Toni Wilen is online now  
Old 15 May 2010, 14:24   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
http://www.winuae.net/files/b/winuae_2200b2.zip

Beta 2: (fixes above major problem)

- reverted filesystem indirect memory change, it can't ever work because filesystem is running in a separate thread
- rawkeyboard extended key fix (Pause-key)
Toni Wilen is online now  
Old 15 May 2010, 14:25   #5
NewDeli
Banned
 
Join Date: Oct 2007
Location: Paris / FRANCE
Age: 44
Posts: 1,248
Send a message via ICQ to NewDeli
Quote:
Originally Posted by Toni Wilen View Post
toggle between fullwindow and fullscreen if started in fullwindow mode
How are we supposed to test this, please ? I didn't see any option to toggle fullwindow / fullscreen in the input target list.
NewDeli is offline  
Old 15 May 2010, 14:34   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
Quote:
Originally Posted by NewDeli View Post
How are we supposed to test this, please ? I didn't see any option to toggle fullwindow / fullscreen in the input target list.
This is not related to your request (I don't have good enough solution for that). It does just make it says: if emulation was started in fullwindow mode, toggle between fullwindow and fullscreen (instead of switching to regular window and toggle between fullscreen and windowed)
Toni Wilen is online now  
Old 15 May 2010, 15:43   #7
Cosmos
Banned
 
Join Date: Jan 2007
Location: France
Posts: 655
Good ! This version seems to run faster : compiled with VS 2010 ?
Cosmos is offline  
Old 15 May 2010, 16:19   #8
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
Quote:
Originally Posted by Cosmos View Post
Good ! This version seems to run faster : compiled with VS 2010 ?
2.1 was already 2010 compiled, there should not be any measurable differences..

zlib (zip), 7zip was updated to latest versions and recompiled with 2010. (zlib also includes highly optimized x86 asm decompression)
Toni Wilen is online now  
Old 16 May 2010, 13:47   #9
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
Forgot to mention that new Gameport panel also supports different built-in CD32 keyboard layouts.

Currently layout B and C use layout A numpad for CD32 extra buttons. Any ideas for real B and C CD32 layouts? They are completely separate from standard keyboard joystick layouts, direction keys can also be different than joystick keys.
Toni Wilen is online now  
Old 19 May 2010, 04:02   #10
NewDeli
Banned
 
Join Date: Oct 2007
Location: Paris / FRANCE
Age: 44
Posts: 1,248
Send a message via ICQ to NewDeli
Quote:
Originally Posted by Toni Wilen View Post
GUI treeview and listview "hot underline" mode enabled
That corresponds to the setting I use in Vista : Underline underneath icon text at the cursor's hovering !
NewDeli is offline  
Old 19 May 2010, 13:01   #11
NewDeli
Banned
 
Join Date: Oct 2007
Location: Paris / FRANCE
Age: 44
Posts: 1,248
Send a message via ICQ to NewDeli
Quote:
Originally Posted by Toni Wilen View Post
Single/double/triple buffering option added to Display panel, also affects D3D now mode now
Did you mean No buffering/Double/Triple buffering ?
NewDeli is offline  
Old 19 May 2010, 17:58   #12
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
Quote:
Originally Posted by NewDeli View Post
Did you mean No buffering/Double/Triple buffering ?
Same thing.
Toni Wilen is online now  
Old 19 May 2010, 17:59   #13
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
http://www.winuae.net/files/b/winuae_2200b3.zip

Beta 3:

- added XZ compressed file support
- Paths panel "Reset to defaults" was unreliable if more than 3 choices was available
- mouse horizontal wheel (HWheel) works in raw mouse mode, it is now always listed because for some unknown reason RID_DEVICE_INFO_MOUSE.fHasHorizontalWheel is always false, even when mouse has working horizontal scroll wheel
- fixed unreliable device switching in input test/remap mode
- fixed CD32 extra buttons not automatically getting enabled when joystick/pad was in "default" mode
- "default" was changed to "joystick" or "mouse" when switching between device types
- CD32 default button change, Red and Blue buttons are automatically read as a fire and second button if pad is read in standard 2-button mode (previously they did nothing in normal mode, required fire and 2nd button mapped)
- CD32 2-button mode 2nd button (CD32 Blue button as 2nd button) fixed, never worked previously
- Game Ports Test mode now shows mappings that have multiple input targets
- added "toggle" autofire mode to ports panel
- D3D "none" filter allows again all filter setting adjustments
Toni Wilen is online now  
Old 20 May 2010, 07:19   #14
kkgarbod
The Human/Gray Hybrid

kkgarbod's Avatar
 
Join Date: Dec 2009
Location: The Elizabeth Arkham Asylum for the Criminally Insane
Posts: 321
Hi. I've got this bug

In 2.2.0 Beta 3, when you accidentally press the win(left or right) key, Emu gets minimized above the start button. When you return to emu, the keyboard no longer function. Pressing F12 nothing. If you set joypad to keyboard layout B, it doesn't function . Mouse and USB Joystick works OK.

one can especially see it while playing games using Keyboard Layout B. Both WHDLoad or floppy. Other layouts: Mouse and USB Joystick no problem.

Tested with 2.1.0 and the bug is not present.

Specs HW: Win XP sp3. P4 3ghz. 1.25 GB Ram.

Edit:
Added Log files and added some info
Attached Files
File Type: zip winuae.zip (21.8 KB, 201 views)

Last edited by kkgarbod; 20 May 2010 at 08:12.
kkgarbod is offline  
Old 20 May 2010, 20:44   #15
Romanujan
Registered User
 
Join Date: Dec 2007
Location: Szczecin/Poland
Posts: 237
Hi,

I have serious problems with all three betas (2.1.0 works fine) - my Workbench installation on the attached hi-end configuration works incredibly slowly, it's unusable. I am running OS 3.9 BB 2 with AfA and tons of patches (even a custom made 3.9 Kickstart) - when I have some more spare time I am going to try to isolate the one that causes this slowdown.

HW/SW spec: Vista SP2 Home Premium 64-bit, Phenom II X4, 8GB RAM, GeForce 9600GT with driver 196.21
Attached Files
File Type: 7z Logs-and-Config.7z (11.1 KB, 186 views)
Romanujan is offline  
Old 20 May 2010, 20:57   #16
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
Quote:
Originally Posted by kkgarbod View Post
Hi. I've got this bug
Actually this is old bug (or Windows feature), 2.2 versions are using RAWINPUT keyboard devices now and DirectInput keyboard + RAWINPUT keyboard + Fullscreen (weird, isn't it?): raw keyboard stops working..

I guess it is time to get rid of directinput keyboard completely..

Quote:
Originally Posted by Romanujan View Post
I have serious problems with all three betas (2.1.0 works fine) - my Workbench installation on the attached hi-end configuration works incredibly slowly, it's unusable. I am running OS 3.9 BB 2 with AfA and tons of patches (even a custom made 3.9 Kickstart) - when I have some more spare time I am going to try to isolate the one that causes this slowdown.
Your configuration is strange (why is CD32 enabled?), first switch "Chipset Extra" to Generic or A1200 or A4000 (whatever your KS is based on) and try again.

("It worked previously" isn't acceptable answer. I am not interested in debugging configurations that no one can test using real hardware..)

Try also (temporarily) without RTG. EDIT: also quick standard ROM test might help to find the problem.
Toni Wilen is online now  
Old 20 May 2010, 21:32   #17
Romanujan
Registered User
 
Join Date: Dec 2007
Location: Szczecin/Poland
Posts: 237
I have played a little with configuration - Chipset Extra was set to generic, sound disabled, network (bsdsocket and uaenet) disabled, but it didn't help. Disabling RTG is not an option on a system with AfA, PNG icons only, and all this true-color goodies

I am going to take some time to find a minimal WinUAE/guest OS configuration that causes a problem - but this will take a little time.
Romanujan is offline  
Old 20 May 2010, 21:36   #18
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,393
Quote:
Originally Posted by Romanujan View Post
I have played a little with configuration - Chipset Extra was set to generic
Really? Akiko stuff in logs still points to weird chipset extra. Go to Advanced chipset and make sure "Compatible settings" is ticked. (Probably nothing to do with slowdown but it can cause issues someday)

CPU slowdown or filesystem slowdown or "everything slowdown"? CPU% showing stupid values?
Toni Wilen is online now  
Old 20 May 2010, 22:37   #19
Romanujan
Registered User
 
Join Date: Dec 2007
Location: Szczecin/Poland
Posts: 237
Logs are from the configuration I have uploaded (I have only ticked extra logging in Misc tab).

The slowdown seems to be either CPU or GFX related, I still need to check it somehow...

OK, I have found something interesting: when I boot my 'state-of-the-art' configuration, it is sluggish, etc. it is enough to press F12 to bring WinUAE configuration window and press cancel - and the speed goes back to normal (at least it feels normal) ALT+TAB and switch back to WinUAE also helps (but the second trick causes WinUAE to stop reacting to keyboard at all - typing into Amiga shell does not work, F12 and ALT+F4 does not work either). All this tested on Beta 3. Hmm...

I attach the logs (configuration as in previous attachment + ticked 'crate log file') from short Beta 3 session when I performed the F12 trick to bring emulation speed to normal level.

OK, I've got several things still to check: try clean OS 3.9 (or OS 3.9 with Picasso), clean AmiKit install, try to run DirectX 9 Web Update, try to upgrade NVidia drivers to the latest ones (which will probably clutter icons on my desktop again), etc. But certainly not today, I need to get up early tomorrow...
Attached Files
File Type: 7z logs-F12-trick.7z (8.7 KB, 193 views)
Romanujan is offline  
Old 22 May 2010, 17:36   #20
NewDeli
Banned
 
Join Date: Oct 2007
Location: Paris / FRANCE
Age: 44
Posts: 1,248
Send a message via ICQ to NewDeli
Are you aware of the possible issues with the new input panel & game ports, or do I need to report them ?
When I try to remap my gamepad controls, any press on the directional pad amounts to 2 keys mapped (gamepad not a USB gamepad) instead of one.

Also, I don't know exactly how to tell the input panel not to use Game Ports panel as default (other than unticking, then ticking again Configuration #1). I wouldn't mind using it as default, but Game Ports doesn't seem to allow assigning buttons to some events. Mouse cursor is stuck until I change the device in Game Ports.

Last, I have to click OK twice to confirm changes in the configuration during emulation (happens randomly).
Attached Files
File Type: zip winuaelog.new.input.p.zip (6.9 KB, 180 views)
NewDeli is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 2.5.1 beta series Toni Wilen support.WinUAE 69 22 December 2012 10:22
WinUAE 2.3.3 beta series Toni Wilen support.WinUAE 124 17 September 2011 15:48
WinUAE 2.3.2 beta series Toni Wilen support.WinUAE 79 31 May 2011 19:39
WinUAE 2.3.0 beta series (was 2.2.1) Toni Wilen support.WinUAE 229 22 September 2010 19:20

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:52.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.09374 seconds with 14 queries