English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 15 June 2020, 12:31   #121
Weaselrama
Registered Voter

Weaselrama's Avatar
 
Join Date: Oct 2019
Location: Neunkirchen aP, DE
Age: 59
Posts: 573
Quote:
Originally Posted by PeterK View Post
...
If $AfA EQ ON
Wait 2 ; wait for Eastern
RemLib >NIL: icon.library
KeepPlanarImages
EndIf
EndCli
[/CODE]
Is there a reason for me to use this with the OS 4.1 icons, @PeterK? Right now, I got my icons back and everything with AfA add-on is working very well.

2nd question: Is there a command (or app) which allows the user to view/manipulate the hidden def_icons in SYS:Prefs/Env-Archive/sys which are sent to RAM: on startup? I can see them, of course, in DOPUS, but can I unhide them in icon view? Thanks!
Weaselrama is offline  
Old 15 June 2020, 15:08   #122
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,851
Ok, this is all a bit off-topic for a MUI5 thread, but the problem with the invisible OS4 icons on AFA can only occur after you have saved them with my library and when it has replaced planar images by smaller ones. The icon_lib.exe of AfA uses by mistake the size of the planar images to decode the TrueColor images, and that will fail if both don't have the same size anymore. You can avoid that with "KeepPlanarImages" or by only using one of both icon.libraries for ever, but be warned, many OS4 icons that have been saved by icon_lib.exe can't be used on OS4 anymore, because AfA writes crap.

2.) Of course you can open Prefs/Env-Archive:sys or ENV:sys on the desktop and make the icons visible, but not those of the type "disk" or "volume". They are only visible as "disk.info" in a root directory or you have to change their type with a tool to drawer or tool.
PeterK is offline  
Old 15 June 2020, 15:42   #123
Weaselrama
Registered Voter

Weaselrama's Avatar
 
Join Date: Oct 2019
Location: Neunkirchen aP, DE
Age: 59
Posts: 573
Quote:
Originally Posted by PeterK View Post
Ok, this is all a bit off-topic for a MUI5 thread, but the problem with the invisible OS4 icons on AFA can only occur after you have saved them with my library and when it has replaced planar images by smaller ones. The icon_lib.exe of AfA uses by mistake the size of the planar images to decode the TrueColor images, and that will fail if both don't have the same size anymore. You can avoid that with "KeepPlanarImages" or by only using one of both icon.libraries for ever, but be warned, many OS4 icons that have been saved by icon_lib.exe can't be used on OS4 anymore, because AfA writes crap.

2.) Of course you can open Prefs/Env-Archive:sys or ENV:sys on the desktop and make the icons visible, but not those of the type "disk" or "volume". They are only visible as "disk.info" in a root directory or you have to change their type with a tool to drawer or tool.
Yeah, I upgraded the visible def_icons ages ago. Someday, I need to sit down and learn how to add types in deficons because there are some filetypes post-OS3.9 I want. I've only used deficons once, and that was because I screwed up the PNG datatype and all my .png icons were replaced by the default blank icon. I finally figured it out - the PNG datatype I used added an extra line in deficons. I got rid of it and all was well.

Just a note: One of the cooler aspects of OS3.9 is that you can bring up the icon information from the Workbench menu, right-click on the icon, and change types (tools, drawer, project, etc.) from there.

Ok - I'll add that line above to startup-sequence. Everything is good, I got all my icons back. I do like what AfA offers but your comment on its icon library is noted. Thanks for all your help, Peter!

Mods: I'm taking the rest of this conversation out of this thread to private messages. My thanks for your indulgence.
Weaselrama is offline  
Old 15 June 2020, 16:40   #124
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,412
Quote:
Originally Posted by Weaselrama View Post
Mods: I'm taking the rest of this conversation out of this thread to private messages. My thanks for your indulgence.
Yes we went very OT, eventually open a new discussion on the suitable tools to change the icon type on the disk icons, or on other requests.

@Peter
KeepPlanarImages I don't use it because I misunderstood the yours message, anyway it's strange that you don't use RemLib from user-startup, it works fine for me, I use a lot of user-startups for the various tests this saves me from making changes (we can discuss your thread)

Also Peter doesn't use the waiting "Wait 2" and Eastern still works (of course for good quality I should rename picture_datatype.exe)

Last edited by AMIGASYSTEM; 29 June 2020 at 20:07.
AMIGASYSTEM is offline  
Old 16 June 2020, 17:58   #125
James
Registered User

 
Join Date: Mar 2010
Location: Beckenham/England
Posts: 672
Quote:
Originally Posted by AMIGASYSTEM View Post
MUI-5.0-2020-06-10 r6560 update, link Download front page
Please note that this is a nightly build, and includes debug code that makes it much larger (slower?) than the release packages. There is now a 12/6/20 nightly build available. But the current release build is from 2/1/20 (2019R4).
James is offline  
Old 16 June 2020, 21:23   #126
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,412
Yes it is true but it is very stable and I would say also fast, compared to 2019R4 has some improvements, already this rewards its use, probably soon will come also the standard version.
AMIGASYSTEM is offline  
Old 01 July 2020, 21:50   #127
James
Registered User

 
Join Date: Mar 2010
Location: Beckenham/England
Posts: 672
2020R1 now available.

https://muidev.de/
James is offline  
Old 01 July 2020, 22:21   #128
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 38
Posts: 966
Downloaded and installed
indigolemon is offline  
Old 21 December 2020, 17:52   #129
James
Registered User

 
Join Date: Mar 2010
Location: Beckenham/England
Posts: 672
2020R3 now available.

https://muidev.de/
James is offline  
Old 21 January 2021, 01:39   #130
Flux
Registered User

 
Join Date: Jan 2020
Location: UK
Posts: 7
The downloads aren't currently available from https://muidev.de/ as MUI seems to be moving to GitHub, see https://github.com/amiga-mui/muidev/issues/324

However, the nightly builds are still at http://nightly.muidev.de/

Update: I've just found out the latest nightly build expires tomorrow, 22nd Jan. So, that isn't really an option.

Last edited by Flux; 21 January 2021 at 02:16.
Flux is offline  
Old 24 January 2021, 02:28   #131
mateusz_s
Registered User

 
Join Date: Jan 2020
Location: Poland
Posts: 31
is it worth installing on 68k 060/080 RTG? I am still using the old 3.8 (or 3.9 can't remember)
mateusz_s is offline  
Old 24 January 2021, 10:53   #132
Rotzloeffel
Registered User
 
Join Date: Oct 2012
Location: Wolfach / Germany
Posts: 80
Quote:
Originally Posted by mateusz_s View Post
is it worth installing on 68k 060/080 RTG? I am still using the old 3.8 (or 3.9 can't remember)

no... feel happy with 3.8
Rotzloeffel is offline  
Old 25 January 2021, 22:50   #133
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,412
Quote:
Originally Posted by mateusz_s View Post
is it worth installing on 68k 060/080 RTG? I am still using the old 3.8 (or 3.9 can't remember)
If you use an updated operating system with new applications MUI 5 is necessary, more features and better graphics quality, MUI 3.8 is obsolete
AMIGASYSTEM is offline  
Old 25 January 2021, 22:53   #134
duga
Registered User
 
Join Date: Nov 2010
Location: Sweden
Posts: 471
Quote:
Originally Posted by AMIGASYSTEM View Post
If you use an updated operating system with new applications MUI 5 is necessary, more features and better graphics quality, MUI 3.8 is obsolete
Just as obsolete as 68k you mean?

I've been trying 3.9 and 5.0 on 020 ECS and 030 AGA a couple of times, after a while I went back to 3.8 again.

5.0 is clearly targeted against RTG and PowerPC.
duga is offline  
Old 26 January 2021, 10:55   #135
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,412
Yes of course if you have an Amiga little expanded and without a MUI5 graphics card is not really indicated!
AMIGASYSTEM is offline  
Old 26 January 2021, 18:21   #136
Rotzloeffel
Registered User
 
Join Date: Oct 2012
Location: Wolfach / Germany
Posts: 80
Quote:
Originally Posted by AMIGASYSTEM View Post
If you use an updated operating system with new applications MUI 5 is necessary, more features and better graphics quality, MUI 3.8 is obsolete
There are no applications for mui higher 3.8 on m68k
Rotzloeffel is offline  
Old 26 January 2021, 19:09   #137
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,412
Yes, but in some cases on new generation applications to have a better looking GUI it is better to use a more updated MUI version.

If versions 4 and 5 have been developed there must be a reason, don't you think?
AMIGASYSTEM is offline  
Old 26 January 2021, 19:40   #138
James
Registered User

 
Join Date: Mar 2010
Location: Beckenham/England
Posts: 672
Quote:
Originally Posted by Rotzloeffel View Post
There are no applications for mui higher 3.8 on m68k
Several apps state that they need greater than 3.8 in their requirements.
A few examples:

http://aminet.net/package/comm/tcp/dizzytorrent2
http://aminet.net/package/util/misc/PassPocket
http://aminet.net/package/comm/misc/twittAmiga

There are also apps that will lose functionality e.g. Strange can't use tabs under 3.8. and some apps will have graphical problems.
James is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
MUI-OWB for OS4.1fe no longer available? White support.Apps 8 06 November 2017 23:22
AmigaAMP 3.18 (68k/OS3.9-PPC/OS4) released AMIGASYSTEM News 24 27 November 2016 12:44
OS3.9 progs on OS4.1 kkhard support.WinUAE 13 14 September 2014 03:17
HivelyTracker 1.2 for OS4 and OS3.x out now! spoUP News 5 08 January 2007 05:18
Fun of Computing: Jens Langner to present OS4, MUI & YAM Paul News 0 13 September 2004 16:46

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:38.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.10093 seconds with 14 queries