English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 01 August 2020, 15:14   #1
Greyspirit
Registered User

 
Join Date: Jun 2014
Location: Groton / USA
Posts: 25
4.4 Random Crashing

Been running 4.4 for a bit now. Same BBS I've been running for 2 years which routinely had 200-350 hour uptime between restarts. Drop in replacement of 4.4 exe. Ran well for a while. All of a sudden, I'm getting random crash dumps. Can't correlate to any BBS activity. Haven't changed anything.

Attached is dmp file.
Attached Files
File Type: dmp winuae_x64_4.4.0_R_2020.08.01_07.47.43.dmp (143.4 KB, 8 views)
Greyspirit is offline  
Old 01 August 2020, 18:16   #2
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,767
I also had some random crashes with 4.4 (don't remember anymore where), but they were gone after just saving my old WinUAE configuration with 4.4 again.
PeterK is offline  
Old 01 August 2020, 19:47   #3
DamienD
disengaged
DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 43
Posts: 17,757
I'm not going to lie; I've found some strange things with 4.4.0.

Hard to remember now, all intermittent but:
  • Issue sometimes when changing options that used to work "on the fly" e.g. setting "Fastest possible" and back again.
  • Issue sometimes when changing resolutions e.g. today changed from 720x576 --> 640x480 in Fullscreen. All was good. Changed back to 720x576 but was still in 640x480 until a reset. This happened today.
  • Issue when created a new .ADF over an old one, but the size left still kept the old one's. This happened today.
  • One or two other things that I've forgotten.
I really should have noted these down / the exact circumstances at the time
DamienD is offline  
Old 02 August 2020, 05:56   #4
Greyspirit
Registered User

 
Join Date: Jun 2014
Location: Groton / USA
Posts: 25
Just rolled back from 4.4 to 4.3 to re-verify it's not anything my bbs is doing.
Greyspirit is offline  
Old 02 August 2020, 09:49   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 23,968
Quote:
Originally Posted by Greyspirit View Post
Been running 4.4 for a bit now. Same BBS I've been running for 2 years which routinely had 200-350 hour uptime between restarts. Drop in replacement of 4.4 exe. Ran well for a while. All of a sudden, I'm getting random crash dumps. Can't correlate to any BBS activity. Haven't changed anything.

Attached is dmp file.
Sorry, usual answer: if JIT is enabled, crash dump is useless.

Most common reason for random crashes is too small stack (even if appears to work with some versions).

EDIT: Also check if memory usage (both Amiga and PC) does not slowly rise.
Toni Wilen is offline  
Old 02 August 2020, 20:32   #6
Greyspirit
Registered User

 
Join Date: Jun 2014
Location: Groton / USA
Posts: 25
think I tracked it down to issue with Amibinkd. something I had forgotten was adding in "try 3" to the amibinkd cfg files when 2 of the hubs were down causing it to loop trying to connect. Removed those and it's been 7 hours. Suspecting possible software bug with that. Source is apparently lost to history so have to find other option :/

suppose at 24-36 hour uptime I'll shift back to 4.4 and monitor further.

notes: Neither Amiga or PC side were showing ram creeping. with CPU and ram usage, the host machine should theoretically be able to run ~30 copies of WinUAE simultaneously so I doubt there is an issue there. Haven't pushed that since I've been too lazy to go in and modify Genesis IP on that many copies.
Greyspirit is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Random Collection sTe Collections 32 02 December 2019 10:12
Some games are not random anymore Harry support.FS-UAE 0 10 September 2018 00:15
Random question 251Mario project.EAB 1 16 May 2013 02:19
Random crashes ami_stuff support.WinUAE 8 06 February 2009 16:51
savestates random problems PiCiJi support.WinUAE 4 13 December 2006 17:52

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.07076 seconds with 16 queries