English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 04 September 2019, 22:23   #3321
trixster
Guru Meditating

 
Join Date: Jun 2014
Location: England
Posts: 1,500
Quote:
Originally Posted by deling View Post
where are they ?
They are probably off enjoying a game of quake. but in seriousness, two have replied to you in this thread alone, I know of at least 3 others, and there are video example on YouTube if you care to do a search. Plus there is anecdotal evidence from other people in the sonnet thread. I should probably keep my advice to myself from now on, but I don’t think there is much merit in pointing fingers at the powerpc.library which has been proven to work. Given the many different variable which go into a successful mediator + warp3d + ppc system, a conflict with something either software or hardware related isn’t to be unexpected...
trixster is offline  
Old 04 September 2019, 22:36   #3322
drluking
Registered User

 
Join Date: Sep 2016
Location: Italy
Posts: 205
Quote:
Originally Posted by trixster View Post
Well, there are plenty of people using k1/m1 successfully. I would be happy to test your k1 and m1 boards if you would like an independent check that they are working ok?

thanks trixter, but They are new cards (not used) and I have tested them in a my PC as ethernet cards
They work perfectly in the PC computer, so these two cards are OK
drluking is offline  
Old 04 September 2019, 22:38   #3323
drluking
Registered User

 
Join Date: Sep 2016
Location: Italy
Posts: 205
Quote:
Originally Posted by amigoun View Post
@drluking: have you changed the voltage regulator on Mediator?
no, the mediator is new one
I use it correctly with AmigaOS 3.9 in 68k, the only problems I have are with PPC cards
drluking is offline  
Old 04 September 2019, 22:45   #3324
drluking
Registered User

 
Join Date: Sep 2016
Location: Italy
Posts: 205
Quote:
Originally Posted by trixster View Post
Given the many different variable which go into a successful mediator + warp3d + ppc system, a conflict with something either software or hardware related isn’t to be unexpected...
I have OS3.9 base BB2, P96, Warp3d, MMULib, powerpc.library , no other ... I think It's a basic system (and I use no patches)

now I prepare a full dir list with all file and size in SYS: (so libs: , c: , prefs: so if there is something of non correct It'll be easy to verify it)

thanks
drluking is offline  
Old 05 September 2019, 00:34   #3325
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,961
Dr Lu, did you update the the Killer NICs while in the PC? I'm not saying that's good or bad, I just don't know whether others have done the same.
If I have time tonight I'll swap in the K1 and the Voodoo and test on my tower which is pretty similar to yours.
grelbfarlk is offline  
Old 05 September 2019, 01:37   #3326
drluking
Registered User

 
Join Date: Sep 2016
Location: Italy
Posts: 205
Quote:
Originally Posted by grelbfarlk View Post
Dr Lu, did you update the the Killer NICs while in the PC? I'm not saying that's good or bad, I just don't know whether others have done the same.

no, I have not update them (K1 and M1), and sure none have update them becouse they are new ; if It's important to update them, I can do it

In my K1 and M1 I see 59Mb of ram in showconfig and 512kb page table size in getinfo

(in this video It's 1024kb why ? [ Show youtube player ]

and in this video is 512kb [ Show youtube player ] )

Quote:
If I have time tonight I'll swap in the K1 and the Voodoo and test on my tower which is pretty similar to yours.
ok thanks
drluking is offline  
Old 05 September 2019, 01:50   #3327
drluking
Registered User

 
Join Date: Sep 2016
Location: Italy
Posts: 205
I want to try to reinstall P96 driver, but I need your help

first tell me please which exact version of the P96 drivers I have to install, because as you know there are several versions (I have them all: 2.1b , 2.1c , 2.1d, 2.1e , but tell me which is the best version I have to install of them) thanks

and I need to know from whom uses the K1 or M1 PPC cards which are exactly all the values entered in the Enviroment variables (ENVARC:Picasso96) and in the Tooltypes (tooltypes in DEVS:monitors/Voodoo3)

and if used as default in OS3.9 a resolution LE or BE (for exemple 800x600 16bit PC or 800x600 16bit)

thanks a lot guys
drluking is offline  
Old 05 September 2019, 01:57   #3328
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,961
Use LE (PC) modes unless you have a reason not to, like running specific applications which require BE.
I use P96 2.1e. Trixster uses 2.1b. The new version 2.3 seems to work ok, but it's not really recommended yet.

I failed at installing a K1 and Voodoo together in this tower tonight. Not because of power, drivers or ROM modules. The K1 does not physically sit in the slot evenly or if it does it has a poor connection to the PCI slot. Same with the Voodoo just below it. The PPC and Video cards that were working in it earlier have longer PCI pin pads than these two cards and the backplates do not physically restrict them from sitting fully flush in the PCI slots. This warped case is just not fitting those cards currently and I can briefly make it more stable by removing the backplates and either holding the cards in place or secure them without the backplanes where the PCI connection pads on the cards are not visible.

Last edited by grelbfarlk; 05 September 2019 at 05:11.
grelbfarlk is offline  
Old 05 September 2019, 05:49   #3329
deling
Registered User

 
Join Date: Sep 2017
Location: Moon
Posts: 91
Quote:
Originally Posted by grelbfarlk View Post
Use LE (PC) modes unless you have a reason not to, like running specific applications which require BE.
I use P96 2.1e. Trixster uses 2.1b. The new version 2.3 seems to work ok, but it's not really recommended yet.

I failed at installing a K1 and Voodoo together in this tower tonight. Not because of power, drivers or ROM modules. The K1 does not physically sit in the slot evenly or if it does it has a poor connection to the PCI slot. Same with the Voodoo just below it. The PPC and Video cards that were working in it earlier have longer PCI pin pads than these two cards and the backplates do not physically restrict them from sitting fully flush in the PCI slots. This warped case is just not fitting those cards currently and I can briefly make it more stable by removing the backplates and either holding the cards in place or secure them without the backplanes where the PCI connection pads on the cards are not visible.
Thats true but I remove backplate long ago and doesnt Help
deling is offline  
Old 05 September 2019, 14:05   #3330
drluking
Registered User

 
Join Date: Sep 2016
Location: Italy
Posts: 205
Quote:
Originally Posted by grelbfarlk View Post
Use LE (PC) modes unless you have a reason not to, like running specific applications which require BE.
I use P96 2.1e. Trixster uses 2.1b. The new version 2.3 seems to work ok, but it's not really recommended yet.
ok (I'm using 640x480 PC LE in OS3.9 bb2 to test)

ok, but better to use with K1 M1 P96 2.1e or 2.1b or it doesn't matter ?

Can you grab screenshot your PVS (P96) with all correct ENVS and Tooltypes to use with K1 M1 ?

Quote:
I failed at installing a K1 and Voodoo together in this tower tonight. Not because of power, drivers or ROM modules. The K1 does not physically sit in the slot evenly or if it does it has a poor connection to the PCI slot. Same with the Voodoo just below it. The PPC and Video cards that were working in it earlier have longer PCI pin pads than these two cards and the backplates do not physically restrict them from sitting fully flush in the PCI slots. This warped case is just not fitting those cards currently and I can briefly make it more stable by removing the backplates and either holding the cards in place or secure them without the backplanes where the PCI connection pads on the cards are not visible.
ok, do you think you will have time these days to check ?

have you find the blitzquake gl 6.0 stable ?

About the firmware update of the K1 and M1 cards I found only this on the internet https://www.helpjet.net/Fs-14647997-...0-extract.html
drluking is offline  
Old 05 September 2019, 14:48   #3331
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 597
Quote:
blitzquake gl 6.0 stable?
Don't bother with it. The upgraded versions are done for a reason: This one, if i'm correct, had some memory problems with networking just at closing the game when Sonnet hardware was used (and Hedeon fixed).

None of the ancient versions would solve the problems mentioned here when even the old warp3d test programs or the soft-render QuakeWOS fails.
Cowcat is offline  
Old 05 September 2019, 15:19   #3332
deling
Registered User

 
Join Date: Sep 2017
Location: Moon
Posts: 91
Quote:
Originally Posted by drluking View Post
ok (I'm using 640x480 PC LE in OS3.9 bb2 to test)

ok, but better to use with K1 M1 P96 2.1e or 2.1b or it doesn't matter ?

Can you grab screenshot your PVS (P96) with all correct ENVS and Tooltypes to use with K1 M1 ?



ok, do you think you will have time these days to check ?

have you find the blitzquake gl 6.0 stable ?

About the firmware update of the K1 and M1 cards I found only this on the internet https://www.helpjet.net/Fs-14647997-...0-extract.html
I tested with new firmware and remember same problem like before update

Last edited by deling; 05 September 2019 at 16:56.
deling is offline  
Old 05 September 2019, 15:57   #3333
Hedeon
PPC Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 1,129
Quote:
Originally Posted by Cowcat View Post
None of the ancient versions would solve the problems mentioned here when even the old warp3d test programs or the soft-render QuakeWOS fails.
Where was it mentioned about tests with QuakeWOS? I asked twice but I thought I hadn't received an answer. Maybe I missed it.
Hedeon is offline  
Old 05 September 2019, 23:41   #3334
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 597
#3316 ..... I assumed he tested QWOS after all.
Cowcat is offline  
Old 06 September 2019, 03:14   #3335
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,961
Night 2 with the K1 recertification project.
Last episode I had tried to do what I had suggested numerous times and failed to make it work.
Tonight I modified the backplate so it would sit as deep in the socket as it could. Tried this order, which I said five times would work:
5) Nothing
4) K1
3) Voodoo
2) Nothing
1) Nothing
It did not work. QuakeGL or Amigenerator would start for a few seconds and crash. Bogomips and Syspeed, basically brief blips and not intensive would run. System would hard reboot, did not see a last alert, and was not fast enough to move the monitor cable if there was a guru. There probably was a guru.

Tried various things and could not make this configuration work.
Then moved the K1 with this card order:
5) K1
4) Nothing
3) Voodoo
2) Nothing
1) Nothing
Basically the same, would start Amigenerator or QuakeGL possibly for a few seconds and hard reboot.
So tried this:
5) Nothing
4) Nothing
3) Voodoo
2) K1
1) Nothing
Even worse, Voodoo was starting and system would hang with a black screen. Might have been the K1 hanging as it starts right after. After many reboots eventually got the system started, GLQuake hard reboot the system just before the display came up.

This however worked:
5) 100MB NIC
4) Nothing
3) Voodoo
2) K1
1) Nothing
GLQuake running now, Amigenerator running for a few minutes. Ran GLQuake for 1 hour, then exited cleanly and ran Amigenerator, has been running for 20 minutes or so.
Measuring about 4.82V on the Mediator Bridge Crystal. 4.98V on one of the HDD power cables after 3x fan adapters and a floppy drive power adapter.
No idea what is going on other than maybe the K1 does not like to be the bus terminator?

I finally got something to not work. Not work alert level was raised to 1, after running Cowcat's GLQuake 6.1 for 1 hour, Amigenerator for 30 minutes, then running a timedemo of Cowcat's VBCC old Quake2 (I had to remove the stack 1000000 from the launch script, otherwise it ran out of memory), then tried to run Dosbox but it complained it didn't have enough memory... so whatever, then tried to run ScummVM WOS 1.8 r15, launched COMI and it sort of hung. PPC is still running but ScummVM 1.8 r15 WOS is just sitting on a black screen, can Amiga-M back to Workbench and run other PPC stuff-I think the sloppy author of this port has some problem with their lousy test release-or memory was too fragmented, probably the former. So then I ran Devilution-X which launched, after I mounted CF0 and it's sitting next to the crone that sells magic items.

So yes K1 works to run Cowcat's GLQuake 6.1 for 1 hour, Amigenerator for 30 minutes, one timedemo of Cowcat's VBCC old Quake2, and then you can look at the ScummVM gui and try to launch COMI, then that freezes but Devilution-Xnewsdl is will run but without sound (because maybe Dosbox didn't close the SDL_Sound device when it failed to launch) before your good time ends.
Specs:
WarpEngine 060/66MHz
Mediator Black 4000D (Towerized A4000D) with 3.3V VRM
K1
Voodoo3-2000
100MB NIC
A4000 RevB with 64MB Mod
PIO2 Mod
Warp DTs
Some drives

And screenshot after quitting Devilution, back to Workbench:


Tomorrow I will put the Ragnarok back in the machine, if you want me to test something else before I restore the system to back the way it was let me know.

Last edited by grelbfarlk; 07 September 2019 at 04:21.
grelbfarlk is offline  
Old 06 September 2019, 19:30   #3336
drluking
Registered User

 
Join Date: Sep 2016
Location: Italy
Posts: 205
tested now in this way:

5) 100MB NIC RTL 8100C
4) Nothing
3) Voodoo3 2000
2) K1
1) Nothing

tested "gear ppc" demo , about 10 or more minutes and crash / reboot
+4.97V on the Mediator Bridge Crystal (two iniect +5V, on PCI and Zorro slot)

damn ...

can you grab a screenshot of all your variables ENVARC and Tooltypes Picasso 96 used ?

which version of powerpc.library are using exactly ?

which OS are you using ? (3.9bb2, 3.9bb1, 3.1, ...)

which 100MB nic ethernet model are you using ?

Are you sure It's always full stable your system with this configuration ?
5) 100MB
4) Nothing
3) Voodoo
2) K1
1) Nothing

Last edited by drluking; 06 September 2019 at 19:39.
drluking is offline  
Old 06 September 2019, 21:03   #3337
Wrangler
Registered User

 
Join Date: Sep 2015
Location: London, UK
Posts: 299
@drluking

I've never used a K1/M1 but I have set up Sonnet, Rapture and Ragnarok systems. In my experience, there are only 3 things that make systems unstable with the library now that it's very mature:

1. Incorrect software install or corrupted binaries
2. Bad volts to the cpu card
3. CPU overheating

That's it. There is a slight chance of an issue with PCI termination if the last slot isn't filled but I've never encountered that myself (it's a topic discussed about a 150 pages back in this thread somewhere).

If your system is running software properly for more than about 10 seconds we can almost certainly discount 1.

Sounds like the volts are fine if you have working power injectors near to the card.

So I call out overheating, especially as your failures are after running for a while. Open the case and get a big desk fan blowing on the CPU area at full speed and see if that makes a difference. Should be relatively quick to assess whether heat is an issue.
Wrangler is offline  
Old 07 September 2019, 00:23   #3338
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,961
Day 3 K1 Recertification project.
Started up the K1 and started GLQuake. Seems fine. Will gather the exact versions after I find the CF I was using to pull data off this machine.

It's ClassicWB 3.9 with BB2 Kickstart plus a dash of 3 and 4 for flavor. Running sonnetlib build 426 from the Git/Jenkins.

More system info:
PCI
Code:
Pci Device 1:
   VendorID: $1957
   VendorName: Persephone-Team
   DeviceID: $86
   DeviceName: LittleWeenie K1
   ClassCode: $b2000
   RevisionID: $30
   InterruptPin: 2
   SubsystemVendorID: $1a56
   SubsystemID: $201
   MemSpace0: $60000000 - $600fffff
   MemSpace1: $68000000 - $6bffffff

Pci Device 2:
   VendorID: $121a
   VendorName: 3dfx Interactive Inc
   DeviceID: $5
   DeviceName: Voodoo3 All Voodoo3 chips, 3000
   ClassCode: $30000
   RevisionID: $1
   InterruptPin: 3
   SubsystemVendorID: $121a
   SubsystemID: $36
   MemSpace0: $62000000 - $63ffffff
   MemSpace1: $64000000 - $65ffffff
   IOSpace2: $41c06000 - $41c060ff
   RomSpace: $60100000 - $6010ffff

Pci Device 3:
   VendorID: $10ec
   VendorName: Realtek Semiconductor
   DeviceID: $8139
   DeviceName: RTL-8139/8139C/8139C+ 10/100 Mbps Fast Ethernet NIC
   ClassCode: $20000
   RevisionID: $10
   InterruptPin: 1
   SubsystemVendorID: $10ec
   SubsystemID: $8139
   IOSpace0: $41c06100 - $41c061ff
   MemSpace1: $60200000 - $602000ff
Libs:
Code:
  Address   Pri  OpenC   RPC Name & Version

 $08219230    0      1    37 68060.library 46.2 68k
 $08D1E82C    0      2    14 asl.library 45.4 68k
 $08CB7790    0     11     8 bevel.image 45.7 68k
 $08CB97B8    0      2     5 button.gadget 45.6 68k
 $08967AA8  -30      0    12 cgxvideo.library 41.6 68k
 $08F0D388    0      1     5 checkbox.gadget 45.3 68k
 $08D18D6C    0      3    11 chooser.gadget 45.7 68k
 $08D18ED8    0      1     9 clicktab.gadget 45.3 68k
 $08CAC624    0      8    39 commodities.library 44.18 68k
 $089659B8  -30      8    40 cybergraphics.library 41.4 68k
 $0892A8A0    0      0    53 datatypes.library 44.47 68k
 $08A29C0C    0      0    11 diskfont.library 45.7 68k
 $0803677C    0     81   174 dos.library 42.2 68k
 $08CB79B0    0      2     5 drawlist.image 45.0 68k
 $089280AC  -30      1    55 emulation.library 40.389 68k
 $080008BC -100      1   150 exec.library 45.20 68k
 $000046CC  -20      8    27 expansion.library 40.2 68k
 $089283E0    0     15    29 gadtools.library 40.4 68k
 $08CB78E8    0      6     5 glyph.image 45.6 68k
 $08008E3C    0      1   179 graphics.library 40.24 68k
 $0885EAF0    0     14    33 icon.library 46.4 68k
 $685B2E70    0      1    12 identify.library 37.1 68k
 $0825D2F0    0      8    45 iffparse.library 40.1 68k
 $08BFCDA0    0      2     5 ilbm.datatype 44.26 68k
 $08011C1C    0      1   138 intuition.library 45.10 68k
 $0800EE38    0      1     8 keymap.library 40.4 68k
 $08F08410    0      1     5 label.image 45.4 68k
 $0800D61C    0      1    42 layers.library 45.27 68k
 $08D37350    0      2    12 layout.gadget 45.9 68k
 $08CB3808    0      3    20 listbrowser.gadget 45.12 68k
 $0825EE28    0      0    36 locale.library 44.6 68k
 $08BFD0E0    0      4    16 mathieeedoubbas.library 45.3 68k
 $08CB1640    0      1    21 mathieeedoubtrans.library 45.5 68k
 $080146D8    0      0    16 mathieeesingbas.library 41.0 68k
 $0824E5FC    0      4    75 mmu.library 46.12 68k
 $08F86F14    0      1    38 muigfx.library 19.9 68k
 $08F87030    0      4    33 muilowlevel.library 19.9 68k
 $08F86DDC    0      3    51 muimaster.library 19.35 68k
 $08FA0468    0      1    13 muirexx.library 19.9 68k
 $08F949B0    0      1     5 NList.mcc 20.138 68k
 $08F955E8    0      1     5 NListview.mcc 19.93 68k
 $08967C90    0      1    28 pci.library 13.8 68k
 $08F132A8    0      1     5 penmap.image 45.4 68k
 $6851702C    0      1     6 picture.datatype 45.17 68k
 $6BF7FA88    0      3    -1 powerpc.library 17.12 68k
 $08D1E5BC    0      1    15 radiobutton.gadget 45.4 68k
 $08CB3708    0      1    12 resource.library 44.103 68k
 $08BFE46C  127      4    79 rexxsyslib.library 44.1 68k
 $0895DA5C  -70      0    59 rtg.library 40.4029 68k
 $08F90D64    0      2    10 screennotify.library 1.2 68k
 $08CB96F0    0      2     5 scroller.gadget 45.9 68k
 $08F033E8    0      1     5 space.gadget 45.1 68k
 $08D1E3C0    0      1     9 speedbar.gadget 45.1 68k
 $08CB9C78    0      2     5 string.gadget 45.16 68k
 $08F10A68    0      1     5 titlebar.image 40.14 68k
 $08000250    0     77    49 utility.library 40.1 68k
 $08967BA4  -30      0    22 vilintuisup.library 2.9 68k
 $0896878C    0      1     6 Voodoo.card 4.35 68k
 $0825D8E0    0      0     4 warp.library 5.1 68k
 $08D372AC    0      1     7 window.class 45.16 68k
 $08CB1560    0      1    44 wizard.library 42.100 68k
 $08A2287C    0      9    22 workbench.library 45.132 68k
 $08C0487C    0      1    26 xfdmaster.library 39.15 68k
Residents:
Code:
  Address  Name                     Pri IdString

 $00FE50D  AmigaOS ROM Update (ver  112 ROMUpdate 44.57 (25.2.2002)  
 $0825295  NoIDE.strap              112 NoIDE 39.36 (10.04.95) 
 $0825295  NoIDE.strap              112 NoIDE 39.36 (10.04.95) 
 $00F9B3D  expansion.library        110 expansion 40.2 (9.3.93)  
 $00FE50A  AmigaOS ROM Update (ear  106 ROMUpdate 44.57 (25.2.2002)  
 $00F9B3F  diag init                105 diag init  
 $00F800A  exec.library             105 exec 45.20b (13.10.2014)  
 $00FE4FE  AmigaOS ROM Update       104 ROMUpdate 44.57 (25.2.2002)  
 $0FFFE08  « LoadModule »           104 LoadModule 45.15 (29.4.2018) © 
 $0FFFE08  « LoadModule »           104 LoadModule 45.15 (29.4.2018) © 
 $00FF296  utility.library          103 utility 40.1 (10.2.93)  
 $00F8A9D  A4000 bonus              101 bonus 40.1 (15.2.93)  
 $00FE122  potgo.resource           100 potgo 38.0 (26.1.2012)  
 $00F8AAD  cia.resource              80 cia 40.0 (9.12.2013)  
 $00FA260  FileSystem.resource       80 filesysres 45.10 (3.8.2001)  
 $00F8531  battclock.resource        70 battclock 39.3 (20.4.92)  
 $00F914D  disk.resource             70 disk 38.0 (1.1.2014)  
 $00FE119  misc.resource             70 misc 38.0 (13.2.2012)  
 $00F85C8  battmem.resource          69 battmem 39.2 (6.3.92)  
 $00FA833  graphics.library          65 graphics 40.24 (18.5.93)  
 $0FFD001  layers.library            64 layers.library 45.27 (12.12.2014)  
 $00FC17C  gameport.device           60 gameport 40.1 (8.3.93)  
 $00FEC38  timer.device              50 timer 39.4 (29.7.92)  
 $00FC17E  keyboard.device           45 keyboard 40.1 (8.3.93)  
 $00FC181  input.device              40 input 40.1 (8.3.93)  
 $00FDC79  keymap.library            40 keymap 40.4 (12.3.93)  
 $00FE36E  ramdrive.device           25 ramdrive 39.35 (21.5.92)  
 $00FF0C5  trackdisk.device          20 trackdisk 40.1 (12.3.93)  
 $0FFD356  intuition.library         10 intuition 45.10 (16.9.2018)  
 $0FFF37F  scsi.device               10 IDE_scsi.device 46.0 (13.5.2013)  
 $00F8D64  console.device             5 console 44.8 (12.6.2001)  
 $00FE097  mathieeesingbas.library    0 mathieeesingbas 41.0 (2.11.2013)  
 $00F85EA  syscheck                 -35 syscheck
 $00FE40C  romboot                  -40 romboot  
 $00F85E6  bootmenu                 -50 bootmenu 44.7 (25.2.2002)  
 $00F841C  alert.hook               -55 alert.hook  
 $00FE40E  strap                    -60 strap 40.1 (8.3.93)  
 $00F9BF2  filesystem               -81 fs 45.13 (3.8.2001)  
 $00FE3CD  ramlib                  -100 ramlib 41.0 (1.1.2014)  
 $00FF331  wbfind 41.0 (17.11.2012 -110 wbfind 41.0 (17.11.2012)  
 $00F8427  audio.device            -120 audio 37.10 (26.4.91)  
 $0FFEB8B  dos.library             -120 dos 42.2 (18.2.2015)  
 $00FA27A  gadtools.library        -120 gadtools 40.4 (24.5.93)  
 $00FE05C  mathffp.library         -120 mathffp 41.0 (1.2.2012)  
 $00FF348  workbench.task          -120 wbtag 39.1 (20.4.92)  
 $00F8AE8  con-handler             -121 con-handler 40.2 (12.5.93)  
 $00FE587  shell                   -122 shell 45.7 (13.01.2002)  
 $00FE138  ram-handler             -123 ram 44.24 (1.12.2004)


Env:mediator/
MMU=No
Warp3D=No
FastEthernet=0
VoodooMem=12
VoodooInt=Yes

Seems stable, ran GearsPPC for about 50 minutes. Though ScummVM 1.8 r15 WOS hung again trying to run COMI, again I blame the author for this, whomever it might be, PPC is still running. Turns out I had AHI Unit 0 pointed at the SB128, which is not currently installed. Pointed AHI Unit 0 at Paula 8-bit DMA and now it works, though COMI is a little too demanding. ScummVM 2.1 "huge" also seems to work fine.
Added an SB128 to slot 4, still working, now this order:
5) 100MB RTL 8100C NIC
4) SB128
3) Voodoo
2) K1
1) Nothing
I did try a USB card in slot one, this is out of my 'questionable' pile, that caused a ramlib error on boot. Don't know what that's about, it might not be making good contact or something else. SB128 on slot 1 was also a no-go, that was not even detected in pciinfo correctly, invalid Vendor/Device readings-so I'm pretty sure it was not making good contact.

Tried another USB card that was marked as being good. Did not work with this configuration, system would crash when Voodoo starts, sometimes made it further to the PPC not starting, or no PCI Bridge Detected:
5) 100MB RTL 8100C NIC
4) SB128
3) Voodoo
2) K1
1) USB
Also did not work as:
5) 100MB RTL 8100C NIC
4) K1
3) Voodoo
2) Nothing
1) USB

This does work now, and seems stable, ran Amigenerator for 1 hour, loaded ScummVM 2.1 and started Comi, then started Diablo, sound was working (ran into program bug):
5) 100MB RTL 8100C NIC
4) K1
3) Voodoo
2) Nothing
1) Nothing

70% Confident the lower two slots instability are due mostly to the Salvador Dali esque Elbox case. It's clearly warped as the PCI slots do not evenly line up with the PCI backplane, slot 5 compared to slot 1, slot five is a lot deeper but the backplane lines up, slot 1 is shallower but further away from backplane on the X and Y axis.

In my other tower, the slots line up quite well with the backplane, maybe only needing minor adjustment. This was the machine I originally tested my K1 in, that order was:
5) 10MB NIC
4) PPC Card, in this case K1, normally Ragnarok @ 950MHz
3) Voodoo 3-3000
2) FM801
1) Spider USB
Which reminds me, whom was it that was assigned the task of upgrading the K1 with the Correct 64MB chips?

Last edited by grelbfarlk; 07 September 2019 at 05:16.
grelbfarlk is offline  
Old 08 September 2019, 15:45   #3339
drluking
Registered User

 
Join Date: Sep 2016
Location: Italy
Posts: 205
Quote:
Originally Posted by Wrangler View Post
@drluking

I've never used a K1/M1 but I have set up Sonnet, Rapture and Ragnarok systems. In my experience, there are only 3 things that make systems unstable with the library now that it's very mature:

1. Incorrect software install or corrupted binaries
2. Bad volts to the cpu card
3. CPU overheating

That's it. There is a slight chance of an issue with PCI termination if the last slot isn't filled but I've never encountered that myself (it's a topic discussed about a 150 pages back in this thread somewhere).

If your system is running software properly for more than about 10 seconds we can almost certainly discount 1.

Sounds like the volts are fine if you have working power injectors near to the card.

So I call out overheating, especially as your failures are after running for a while. Open the case and get a big desk fan blowing on the CPU area at full speed and see if that makes a difference. Should be relatively quick to assess whether heat is an issue.
Hi
two day of work with mediator and ppc and nothing solved, but some news I add later in next post message

No overheating (all with BIG fans, with other PSU used only for these fans) and temperature 20 Celsius ... so no overheating problem

Yes about Volts and done also better (arrived at +5,01V to Mediator oscillator ...) so no Volts problem (Elbox says correct from 4,95V to 5,05V)

Software problem is possibile, but my opinion is there is a problem of stability with pci.library 13.8 and/or powerpc.library about K1 M1 PPC card support or firmware of K1 M1 to be updated

Last edited by drluking; 08 September 2019 at 16:27.
drluking is offline  
Old 08 September 2019, 16:06   #3340
drluking
Registered User

 
Join Date: Sep 2016
Location: Italy
Posts: 205
@grelbfarlk

two days spent only to try to do work this damn PPC K1 M1 and not very good news

Here, only this config works partially:

PCI1 SB128 (address1)
PCI2 Voodoo3 (address2)
PCI3 K1 (address3)
PCI4 ethernet RTL 100 (address4)
PCI5 ---nothing---

Sometimes I can run correctly the ByNight and Sulaco Encore's demos (in screen and window mode), and sometime not (crash/reboot of the OS), same as for "gear ppc" demos in Warp3D software, and same as for "Voxelspace G" RTG in WarpUP software, and same as with QuakeWOS RTG 8bit and same as with BlitzQuakeGL 6.1 and 7.3 Warp3d
All these in completely random moments (initially or after correctly performing a demo ..an so..)

(((not related to stability problems, but only for curiosity, which version of mpega.library should be used with WarpUP PPC software software ? (I use AHI 4.18 with all AHI modes Paula 8bit DMA) there is the 68k one default version in OS3.9 (I use this one), while many others in aminet http://aminet.net/search?query=mpega and one in aminet is WOS specific of 1999)))

tried to use an other third a4000 mainboard recapped and full working ... but always same as problems !
Same as using an other Voodoo (Voodoo3 3000 VS the 2000)
Used other PSU AT and ATX ..and so.. nothing changed

My conclusion is, at the moment:

-or a my mistake with software (but I have again and again reinstalled all and I have only a clean basic OS3.9 bb2, and P96 2.1e + Warp3D); I have also tried all your ENVS and Tooltypes tips, but nothing is changed ...

-or I need to update the K1 M1 firmware, Where can I download these firmware ??? (if It can be useful to solve the problem)

-or K1 and M1 are not yet full supported correctly (They need more testing and fixing) and there are some problems with pci.library 13.8 and or actual powerpc.library versions
If you and Hedeon can help me, I can try to debug something with COP app via nullmodem to identify problems, so that you can correct them for all K1 M1 users

I have sent you (grelbfarlk) now a private message for a for a request, hoping you can help me !!!
thanks

Last edited by drluking; 08 September 2019 at 16:33.
drluking is offline  
 


Currently Active Users Viewing This Thread: 4 (1 members and 3 guests)
fitzsteve
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WANTED: PCI Sound Card VORTEX2 SuperQuard / SQ2500 or Turtlebeach SantaCruz pci card keropi MarketPlace 12 15 March 2017 03:48
Wanted:Sonnet Technologies QuadDoubler 50 (Doubler 4000) kronuz MarketPlace 0 16 June 2013 01:29
eBay : Sonnet Quaddoubler alexh MarketPlace 3 07 May 2013 01:50
Overlay problem on GeForce 7200 Leandro Jardim support.WinUAE 1 10 August 2010 16:50
Prometheus PCI & Voodoo 3 PCI GFX Card Slayer support.Hardware 21 05 September 2006 11:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:58.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.21510 seconds with 16 queries