English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 28 October 2014, 00:23   #1
eva
Registered User

eva's Avatar
 
Join Date: Oct 2014
Location: Constanta / Romania
Posts: 202
DiskImage Guru Meditation

Hi! Does anybody have troubles with DiskImage? I have installed the version by Fredrik Wikstrom: http://aminet.net/package/disk/misc/diskimage.m68k-aos and every time I try either MountDiskImage from CLI or System/DiskImageGUI, when trying to mount an ADF disk it crashes. I am using WB3.1.

The original tools by Thore Böckelmann http://aminet.net/package/disk/misc/diskimage mount the ADF files fine. I guess I could just use Thore's version but I was wondering why Fredrik does not work.

The error is #80000004 - it does not matter whether it's an ISO file or an ADF. I have tested both to see if they mount.

Last edited by eva; 28 October 2014 at 00:52.
eva is offline  
Old 28 October 2014, 01:50   #2
Leffmann
 
Join Date: Jul 2008
Location: Sweden
Posts: 2,248
That's an illegal instruction exception. You typically get this if your software, or some other component it depends on, requires a higher CPU.

It could also be that the program file has been damaged, the usual cause being a bad MaxTransfer value in the hard drive partitioning settings, resulting in files getting damaged when copied to the drive.
Leffmann is offline  
Old 28 October 2014, 02:05   #3
eva
Registered User

eva's Avatar
 
Join Date: Oct 2014
Location: Constanta / Romania
Posts: 202
I have reinstalled it using the installer and now I get #80000006. It is supposed to work on a 68020 CPU and I have one. The same sort of crashes occur both with the GUI and the CLI.
eva is offline  
Old 28 October 2014, 02:07   #4
Leffmann
 
Join Date: Jul 2008
Location: Sweden
Posts: 2,248
That second exception is a clear indication that the file is damaged. Did you set MaxTransfer to 0x1FE00 during partitioning?
Leffmann is offline  
Old 28 October 2014, 02:16   #5
eva
Registered User

eva's Avatar
 
Join Date: Oct 2014
Location: Constanta / Romania
Posts: 202
I have just checked with HDToolBox. Yep, it's set to 0x1fe00.
eva is offline  
Old 28 October 2014, 02:21   #6
Leffmann
 
Join Date: Jul 2008
Location: Sweden
Posts: 2,248
Sorry, no idea what's causing it then.
Leffmann is offline  
Old 28 October 2014, 03:09   #7
eva
Registered User

eva's Avatar
 
Join Date: Oct 2014
Location: Constanta / Romania
Posts: 202
Thank you Leffmann! For completeness:

I have found a workaround by copying the devices from Fredrik Wikstrom's package:

Code:
makedir Devs:DOSDrivers
copy Devs/DOSDrivers/I#? Devs:DOSDrivers/
and then copied the Thore Böckelmann's version tools copied to C:
Code:
copy CreateImage C:
copy DiskImageCtrl C:
and the diskimage.device from Thore Böckelmann's version to DEVS:
Code:
copy diskimage.device DEVS:
along with zlib.library to LIBS:
Code:
copy zlib.library LIBS:
After that, I used DiskImageCtrl to mount the ADF and ISO files as per the documentation.

The result is that both ISO and ADF files can be mounted properly.

Last edited by eva; 28 October 2014 at 03:20.
eva is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Zool 2: Guru meditation TenLeftFingers support.FS-UAE 11 12 October 2013 00:17
Shadow of the Beast 3 - Guru Meditation Grouch support.Games 6 13 March 2011 12:34
Need help with Guru Meditation Ioncannon support.Hardware 15 09 October 2010 03:40
Guru Meditation: no orders possible A500-Danny News 0 05 August 2007 17:38
A3000 and Guru meditation gizmomelb support.Hardware 2 26 August 2006 00:41

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:58.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06647 seconds with 13 queries