English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 17 February 2019, 12:32   #21
waldiamiga
morphos.pl

waldiamiga's Avatar
 
Join Date: Aug 2014
Location: Kraków, Poland
Posts: 59
Thanks Toni!
waldiamiga is offline  
Old 17 February 2019, 13:28   #22
Mclane
Old fart!

Mclane's Avatar
 
Join Date: Apr 2002
Location: Northolt, West London
Age: 57
Posts: 588
I think Toni might start bashing heads with the crystal ball for using a beta thread as a thank you thread
Mclane is offline  
Old 17 February 2019, 18:20   #23
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 22,459
Quote:
Originally Posted by bagpipes View Post
Hi Toni. I've noticed scaling problem with 4.2.0 betas. Title screen of CD32 version of Alfred Chicken is not center (as it should be and as it was) but expanded and for some reason move out to the left.
Fixed. I did some "filter blanking" changes that wasn't fully compatible with old behavior.

Quote:
Originally Posted by Mclane View Post
I think Toni might start bashing heads with the crystal ball for using a beta thread as a thank you thread
It hasn't happened yet but crystal ball is already telling me that it probably is going to happen in the future.
Toni Wilen is online now  
Old 17 February 2019, 18:47   #24
bagpipes
Registered User

bagpipes's Avatar
 
Join Date: Feb 2009
Location: Poland
Posts: 82
Thank you, Toni! Everything is OK now.
bagpipes is offline  
Old 19 February 2019, 07:46   #25
Keatah
Registered User
 
Join Date: Feb 2018
Location: Chicago IL
Posts: 11
Just like some other emulators I follow elsewhere - the work being done here is top notch!
Keatah is offline  
Old 19 February 2019, 13:21   #26
Mclane
Old fart!

Mclane's Avatar
 
Join Date: Apr 2002
Location: Northolt, West London
Age: 57
Posts: 588
Hi ya Keatah, Toni works the same as Avery does on Altirra...Top devs..
Mclane is offline  
Old 23 February 2019, 17:14   #27
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 22,459
http://www.winuae.net/files/b/winuae_4200b3.7z
http://www.winuae.net/files/b/winuae64_4200b3.7z

Beta 3:

- If win32.guikey is set to zero, disable F12 special handling. Normally if win32.guikey equals valid keycode, F12 can't open GUI, even if F12 in Input panel is configured to open GUI. (Another historic reason..)
- Genlock mode didn't always enable fully (was emulated but transparency was not visible).
- HAM + border sprites visible in border areas: in some situations bitplane data was incorrectly visible in borders.
- Filter border "blanking" was not working (b1).
- Selected filter panel mask/overlay was not updated when filter position (-4..0..4) was modified. (410b4)
- Many video port adapters (which includes grayscale mode and genlock) didn't support all doubling modes.
- Genlock and CD32FMV output was in color even if grayscale mode was enabled.
- 68030 MMU emulation now also creates short bus error frames. They are created when bus error is caused by write and write was instruction's last memory access. For some reason documentation mentions that some instruction prefetch faults also generate short frame but it seems to be incorrect.
- 68020/030 MOVES in instruction pipeline emulation (prefetch/more compatible) mode had wrong instruction length.
- 68020 full format extension disassembler fix, some addressing modes didn't print address register ([] instead of [an])
- Added IVS Trumpcard (non-Pro) v4.9 ROM.
- uaedbg ELF executable support. Not much different compared to HUNK support except ELF SHF_WRITE and SHF_EXECINSTR section flags are used to detect invalid writes or instruction fetches from non-code sections. uaedbg changed, old version is not compatible anymore. Separate debug files used in AROS are not yet parsed.
- do not try to validate or canonicalize UNC network paths to reduce unnecessary delays at startup.
Toni Wilen is online now  
Old 02 March 2019, 21:43   #28
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 22,459
http://www.winuae.net/files/b/winuae_4200b4.7z
http://www.winuae.net/files/b/winuae64_4200b4.7z

Beta 4:

- Enabled color burst bit emulation always made display grayscale except if BPLCON0 was not modified during frame.
- Adjusted color burst emulation: if genlock is connected, color burst state is ignored. Grayscale due disabled colorburst when using genlock is impossible because it is connected to RGB port and color burst only affects composite video out.
- 410b7 sprite FMODE=3 to lower FMODE value mid scan line update affected (parts of sprite disappeared) non-FMODE=3 sprites in certain situations.
- UAE RDB hardfile mounting didn't stop partition enumeration if number of partitions in single HDF exceeded max amount UAE HDF/directory partitions.
- Magic mouse change (b2) reverted and correctly fixed now. Only reactive WinUAE when mouse is moved back over WinUAE window with focus still active.
- 68020/030 cycle-exact: CPU to AGA chipset bus write waited full chipset cycle to finish which is not correct. Written data is latched by chipset buffers allowing CPU to continue executing after 68020/030 CPU memory cycle finishes (which is shorter than chipset cycle). This update slightly increases write speed to chipram/custom registers. (and probably fixes some demos and breaks others as usual)
- D3D11 shader viewport coordinate fixes. (pre and post shaders)
- Added Prelude (Zorro II) and Prelude 1200 (clock port) sound card emulation. (Hardware info from Oliver Gantert)

Prelude emulation notes:
- Prelude is similar to Toccata. PIO data transfers, FIFO memory and CS4231a audio codec chip. Toccata uses AD1848, CS4231a is fully compatible with AD1848 and also has some extra features.
- Prelude 1200 driver only initializes if card.resource exists: HW config must be A1200 with A1200 KS ROM. (=hardware with clock port)
- There may be something wrong with AHI (version specific?), test sound plays at 8000Hz instead of 44100Hz.
- I am not sure which AHI version is required. First I tried some 5.x AHI and device was detected but test button did nothing (also no HW accesses whatsoever when button was pressed). Replaced with 6.0 and test sound worked.

-> don't immediately assume problem is in emulation!
Toni Wilen is online now  
Old 03 March 2019, 01:47   #29
LooZee
Registered User

 
Join Date: Nov 2016
Location: Black Forest / Germany
Posts: 4
Quote:
Originally Posted by Toni Wilen View Post
CS4231a audio codec chip

There's the crystal ball


Thank you for doing the work, Toni.


Greetings, Olli
LooZee is offline  
Old 03 March 2019, 11:03   #30
Zilog
Registered User

 
Join Date: May 2014
Location: Italy
Posts: 234
Quote:
Originally Posted by Toni Wilen View Post
.........
Beta 4:
Prelude emulation notes:
- Prelude is similar to Toccata. PIO data transfers, FIFO memory and CS4231a audio codec chip. Toccata uses AD1848, CS4231a is fully compatible with AD1848 and also has some extra features.
- Prelude 1200 driver only initializes if card.resource exists: HW config must be A1200 with A1200 KS ROM. (=hardware with clock port)
- There may be something wrong with AHI (version specific?), test sound plays at 8000Hz instead of 44100Hz.
- I am not sure which AHI version is required. First I tried some 5.x AHI and device was detected but test button did nothing (also no HW accesses whatsoever when button was pressed). Replaced with 6.0 and test sound worked.

Great Work Toni!
Thanks!
Zilog is offline  
Old 08 March 2019, 21:51   #31
Jax
Registered User

Jax's Avatar
 
Join Date: May 2018
Location: Czech Republic
Posts: 4
Thanks. Again
Jax is offline  
Old 10 March 2019, 20:25   #32
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 22,459
http://www.winuae.net/files/b/winuae_4200b5.7z
http://www.winuae.net/files/b/winuae64_4200b5.7z

Because I don't have any plans for anything major anymore: 4.2.0 will be released in 2-4 weeks.

Beta 5:

- Picasso IV Flifi I2C bus responses are now faked. Removes P4Info "I2C Bus disabled" message. Very useless.
- Picasso IV driver polls GD5446 CR3F bit 7 (VREF state) when changing modes, probably to wait until native mode is completely redrawn, bit now toggles quickly to reduce delays when switching modes.
- Disassembler CHK2/CMP2 support was incomplete. Another 68020+ instruction with "non-standard" encoding.
- Added 68030 MMU instruction disassembler support.
- 68030 MMU instructions that have FC field: 11xxx FC field is invalid and generates F-line exception. (Was missed in previous invalid bit update few versions ago)
- Added support for shader (.fx) embedded config entries. Format: "string winuae_config : WINUAE_CONFIG = <uae-configuration compatible string>";. String can be split, for example like this: "param1 value1" <linefeed> " param2 value";. Config data is parsed and enabled when config file is loaded (with shaders selected) or when shader is changed using GUI.
- Added Tandem IDE HD/Mitsumi CD controller emulation. Only IDE is supported (which is identical to AlfaPower IDE controllers), Mitsumi drives are not emulated.
Toni Wilen is online now  
Old 10 March 2019, 20:52   #33
Viceroy
Registered User
 
Join Date: Jul 2006
Location: Sunderland
Posts: 426
Thank you ;-)
Viceroy is offline  
Old 11 March 2019, 06:24   #34
Pentad
Registered User

 
Join Date: Apr 2018
Location: Indiana
Posts: 9
Toni,

The last few builds have caused AMIX to be unstable and crash with the following error message:

Notice: User BUS ERROR at 0, PC:0 FAULT 6 PID: (then the processid and the command I ran)

This error can be triggered by trying to open start the GUI (olinit), change the keymap or a handful of other commands.

Also, it does not load the keymap correctly anymore either. I have had this AMIX install for a long time and it usually runs without issue.

I have included the log files and my config file.

Thank you for all of your hard work!

-P
Attached Files
File Type: uae Amix.uae (11.0 KB, 14 views)
File Type: txt winuaebootlog.txt (11.8 KB, 4 views)
File Type: txt winuaelog.txt (16.3 KB, 4 views)
Pentad is offline  
Old 11 March 2019, 08:40   #35
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 22,459
Quote:
Originally Posted by Pentad View Post
The last few builds have caused AMIX to be unstable and crash with the following error message:
What was last stable beta? (1, 2 and 3 had some 68030 MMU changes)
Also test with last official version, just to confirm install is not corrupted (which can happen far too easily if it is not properly shut down)
Toni Wilen is online now  
Old 12 March 2019, 00:40   #36
HAolL
Registered User

HAolL's Avatar
 
Join Date: Mar 2019
Location: Gold coast Australia
Posts: 4
General comments for Toni

Hello Toni,

Thanks for beta 5 of 4.2 winuae. Sad to hear you have not enough projects
for a new Beta...

Last edited by HAolL; 13 March 2019 at 17:41.
HAolL is offline  
Old 12 March 2019, 19:25   #37
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,127
Great betas. They fixed all issues I collected but didn't report yet since public 4.1.0
hexaae is offline  
Old 12 March 2019, 21:09   #38
Pentad
Registered User

 
Join Date: Apr 2018
Location: Indiana
Posts: 9
Quote:
Originally Posted by Toni Wilen View Post
What was last stable beta? (1, 2 and 3 had some 68030 MMU changes)
Also test with last official version, just to confirm install is not corrupted (which can happen far too easily if it is not properly shut down)


Toni,

I tried 4.1.0 and that seems to work fine. I will try to grab the older betas and see if they work too.

Thanks!
Pentad is offline  
Old 13 March 2019, 19:10   #39
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 22,459
Quote:
Originally Posted by Pentad View Post
This error can be triggered by trying to open start the GUI (olinit), change the keymap or a handful of other commands.
What are those "other commands"? How to change keymap? (Assuming this can be done without X Window). olinit generates too much background activity making debugging impossible..

Last edited by Toni Wilen; 15 March 2019 at 15:50.
Toni Wilen is online now  
Old 14 March 2019, 23:45   #40
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 3,033
There seems to be a problem with order of devices shown in CD & hard drives page. Doesn't happen with 4.1.0, does with 4.2.0b1 and 4.2.0b5.
Config:
hXXps://www.media!fire.com/file/dbjgur4vax9o9uf/AMIX203_A2000A2630A2090A2065_Kick13.uae.zip/file

Load that config, click CD & hard drives. HD is first, tape drive second in list. Start emulation than press F12 after a couple of seconds. Notice that the order in the list has swapped. Double-click on the tape drive entry (now at the top). Hardfile settings window opens. Similarly, click the HD entry (now at the bottom of list) and Tape Drive Settings window opens.
mark_k is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 3.5.0 beta series (was 3.4.1) Toni Wilen support.WinUAE 177 15 June 2017 00:31
WinUAE 3.2.2 beta series Toni Wilen support.WinUAE 21 20 December 2015 18:35
WinUAE 3.2.0 beta series Toni Wilen support.WinUAE 385 09 November 2015 00:06
WinUAE 2.4.0 beta series Toni Wilen support.WinUAE 342 29 March 2012 10:02
WinUAE 2.3.3 beta series Toni Wilen support.WinUAE 124 17 September 2011 16:48

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:27.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.09073 seconds with 16 queries