English Amiga Board


Go Back   English Amiga Board > Requests > request.Apps

 
 
Thread Tools
Old 13 August 2018, 17:15   #1
AlfaRomeo
A1200 040 SAM440EP 667
AlfaRomeo's Avatar
 
Join Date: Jan 2008
Location: Lisbon / Portugal
Posts: 794
AmiDevCpp

I'm looking for AmiDevCpp last version, think that´s v0.98
Can someone help me with this, please?

Home of AmiDevCpp is off-line:
http://amidevcpp.amiga-world.de/download.php
AlfaRomeo is offline  
Old 13 August 2018, 21:20   #2
rygar
Registered User

 
Join Date: Nov 2007
Location: Poland
Posts: 214
https://web.archive.org/web/20160531...v098_Setup.exe
rygar is offline  
Old 13 August 2018, 22:04   #3
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 2,926
I'm sure you can plug the new gcc v6 on it (instead of the cygwin old gcc AmiDevCpp includes). Excellent version. There's even a windows setup.
jotd is offline  
Old 13 August 2018, 23:42   #4
AlfaRomeo
A1200 040 SAM440EP 667
AlfaRomeo's Avatar
 
Join Date: Jan 2008
Location: Lisbon / Portugal
Posts: 794
Quote:
Originally Posted by jotd View Post
I'm sure you can plug the new gcc v6 on it (instead of the cygwin old gcc AmiDevCpp includes). Excellent version. There's even a windows setup.
I will try


Thanks for your help friends
AlfaRomeo is offline  
Old 13 January 2019, 20:42   #5
ferrellsl
Registered User

 
Join Date: May 2017
Location: Mesa
Posts: 26
I've decided to give AmiDevCpp a go and i'm very impressed. It's so easy now to compile, test and debug on Windows. I've been able to successfully compile two of the 3 example projects, the "Hello World" example and the "Draw" example. But I've run into a problem compiling the "Reaction" example. Everything in this example compiles without a problem but during link I get the following errors:

[Linker Error] undefined reference to `_getc'
[Linker Error] undefined reference to `_putc'
[Linker Error] undefined reference to `_fdopen'
ld returned 1 exit status
C:\CrossCompiler\AmiDevCpp\examples\Amiga_OS3(68k)\Reaction\Makefile.win [Build Error] exe: *** [Bitoperation.exe] Error 1

What am I doing wrong?
ferrellsl is online now  
Old 13 January 2019, 21:05   #6
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 525
Libnix is missing that, you can use ixemul or take them from libnix3

https://frontier.innolan.net/github/.../branch/master
arti is offline  
Old 13 January 2019, 21:06   #7
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 525
BTW, anyone have gcc6 for windows but not one with hunk format
?
arti is offline  
Old 13 January 2019, 21:23   #8
ferrellsl
Registered User

 
Join Date: May 2017
Location: Mesa
Posts: 26
Quote:
Originally Posted by arti View Post
Libnix is missing that, you can use ixemul or take them from libnix3

https://frontier.innolan.net/github/.../branch/master

Thanks! Works great now.
ferrellsl is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amidevcpp c++ link errors tolkien Coders. C/C++ 6 01 March 2018 05:10
AmiDevCpp $(GLOBALDEPS) mritter0 Coders. C/C++ 1 29 June 2015 02:30
AmiDevCpp AF2013 Coders. C/C++ 0 14 March 2014 01:23
Problem compiling with AmiDevCpp Franchute13 Coders. C/C++ 2 26 September 2013 16:01
AmiDevCpp and Floats AmigaEd Coders. General 0 18 January 2006 04:16

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06966 seconds with 15 queries