English Amiga Board


Go Back   English Amiga Board > Coders > Coders. General

 
 
Thread Tools
Old 01 September 2006, 06:27   #1
MacTO
Registered User
MacTO's Avatar
 
Join Date: Dec 2004
Location: Hogtown, Canada
Posts: 16
MOUSE(0) and AmigaBASIC ...

So I have AmigaBASIC manual and interpreter (from the Extras 1.3 disk) at hand, and am trying to figure out how to use the mouse. The "MOUSE ON" and "ON MOUSE GOSUB Wherever" bits have been done.

Now the trick is to interpret mouse clicks. The response for clicking and double clicking pretty much work as expected, with one quirk. MOUSE(0) likes returning -1 and -2 even when the mouse button is not being held down (I rarely see 1, almost always on the first click but the first click isn't necessarily a 1, and don't recall seeing 2 at all).

I also see -3 coming up a lot, which is entirely undocumented in revisions 2 and 3 of the manual.

Can anybody helf clarify what's going on here?
MacTO is offline  
Old 01 September 2006, 13:32   #2
thor
Registered User
thor's Avatar
 
Join Date: Mar 2006
Location: Germany
Posts: 898
Quote:
Originally Posted by MacTO
I also see -3 coming up a lot, which is entirely undocumented in revisions 2 and 3 of the manual.
In my (german) manual -3 is explained in the -2 paragraph. The left mouse button was pressed 3 times before holding it down.
thor is offline  
Old 01 September 2006, 17:07   #3
MacTO
Registered User
MacTO's Avatar
 
Join Date: Dec 2004
Location: Hogtown, Canada
Posts: 16
Gee, I really should learn how to read rather than skim -- because the English manual says that too. (Thank-you for pointing it out.)

Which leaves the other problem. Why is behaving like I'm holding the mouse button down when I'm not?
MacTO is offline  
Old 01 September 2006, 17:19   #4
MacTO
Registered User
MacTO's Avatar
 
Join Date: Dec 2004
Location: Hogtown, Canada
Posts: 16
Okay, I figured out that it must be looking at the current status of the mouse button. So it needs some sort of delay in order to figure out if it is a click or a click and hold.
MacTO is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
AmigaBASIC Compilers Leandro Jardim request.Apps 4 22 May 2013 23:59
NZ AmigaBASIC education disks redblade project.TOSEC (amiga only) 2 15 December 2011 11:32
Windows text to AmigaBasic ? Angelsoft New to Emulation or Amiga scene 9 24 October 2011 22:31
looking for AmigaBasic Interpreter phil321 New to Emulation or Amiga scene 41 19 December 2006 15:26
AmigaBASIC unprotector Minuous request.Apps 1 02 June 2005 00:28

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:07.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06122 seconds with 15 queries