English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 20 August 2014, 14:57   #1
Seblington
Amiga Nutter
Seblington's Avatar
 
Join Date: Sep 2005
Location: Paignton, Devon.
Age: 37
Posts: 220
Send a message via AIM to Seblington
GVP A530 service manual wanted

Hi, I was very lucky to find a cheap "untested" A530 last week, it arrived today and well guess what, its dead well it was a gamble and it didn't pay off.

Plugged it in and no power, A500+ booted as it should as if there was nothing there ( plug a series II in with no power and the computer does not boot)

OK, so the A530 is different, it turns on with the Amiga, you can here the relay click inside ( something). quick look in the PSU, there is a black capacitor, blown 3A fuse and a shorted AC to -Ve bridge, the cap seemed OK so replaced the bridge and the fuse, tried again, quickly tripped the mains with blue flash from the cap.

The problem I have is I can not tell what the cap use to be, also once the power supply is working I think there's going to be more problems in the A530 itself.


Now I'm not much of a programmer but I am a good electronic engineer, I could probably struggle for weeks trying to fix this but if anyone can give me a helping hand with a service manual or circuit diagram it would be a huge help

Many thanks in advance.
Seblington is offline  
AdSense AdSense  
Old 20 August 2014, 18:58   #2
clenched
Registered User

 
Join Date: Sep 2008
Location: Gainesville U.S.A.
Posts: 611
No manual but since it was only 2 screws I had a look. The only black cap is the biggest one, Polarized type, 100 µf 400 volts.
clenched is offline  
Old 20 August 2014, 19:49   #3
Seblington
Amiga Nutter
Seblington's Avatar
 
Join Date: Sep 2005
Location: Paignton, Devon.
Age: 37
Posts: 220
Send a message via AIM to Seblington
Thank you, I had a close look, the cap has been burned, it wasn't the fault, could you possibly look at Q1 ? have a look at the picture, all I can see is UZ80A as there is a hole blown out of it, I think it may be BUZ80A but want to be sure




Love my Canon 7D with the Macro flash, nice and crisp close ups :-)


On a good note, I read on the forum the series II PSU works with the CGP, it shouldn't as the A530 has a -12Ve rail, but tried it anyway and the device is recognized by the system but does crash as soon as you get any sort of display (Apart from holding down the two mouse buttons on start-up), it does boot from the HDD as well but as soon as WB starts to pen iot crashes, even if you boot off an FDD.
Seblington is offline  
Old 20 August 2014, 20:09   #4
clenched
Registered User

 
Join Date: Sep 2008
Location: Gainesville U.S.A.
Posts: 611
There is a really stiff steel spring masking some of the numbers and I don't want to push it. However I can see the B directly over the R. (R141) in my case.
clenched is offline  
Old 20 August 2014, 21:06   #5
Seblington
Amiga Nutter
Seblington's Avatar
 
Join Date: Sep 2005
Location: Paignton, Devon.
Age: 37
Posts: 220
Send a message via AIM to Seblington
PERFECT !!! that's all I need to know, I really appreciate you looking,



Well when a switch mode power supply goes pop, they often take more than one component out with them, so far, this transistor, 1 bridge rectifier and a fuse, will check the surrounding components before installing the new transistor,but hopefully, this should get this A530 working again.
Seblington is offline  
Old 27 August 2014, 10:30   #6
Seblington
Amiga Nutter
Seblington's Avatar
 
Join Date: Sep 2005
Location: Paignton, Devon.
Age: 37
Posts: 220
Send a message via AIM to Seblington
Just an update on this one, replaced the blown part and no joy, cant believe I missed a 330uf cap budging ( though it was covered in glue), still no joy, after checking further I found a dead diode and a dead 20V Zenner diode, I don't like working on SPMS as its never one thing wrong with them, they literally destroy themselves :-/
Seblington is offline  
Old 15 September 2014, 11:08   #7
Seblington
Amiga Nutter
Seblington's Avatar
 
Join Date: Sep 2005
Location: Paignton, Devon.
Age: 37
Posts: 220
Send a message via AIM to Seblington
Just wanted to post an amendment comment, the HD8 PSU IS compatible with the A530, mine didn't work as my A500+ had corrosion on the motherboard causing issues ( now fixed)

Also, the standard Amiga PSU's are a good replacement for the GVP's if you cut off the square connector and replace it with the 5 pin DIN, the HD8 PSU struggles with HDD's larger than 2GB to spin up in my experience, after using a small SMPSU that I had spare, the A530 is running very well with a 2GB HDD, now all I need are 2 4MB SIMS for it ( not the same as in the A4000 or the HD8).


I am still repairing the PSU which is a total nightmare without a diagram, so far, I have found there are 2 dead Zener Diodes, 4 blown controller transistors and 1 blown mains chopper transistor, both timing caps, 3 output smoothing caps and a 1 Ohm ballast resistor, awaiting more spares before I try and power it up again, the only issue is, every time the PSU blows, it takes out most of the components listed above :-(
Seblington is offline  
Old 15 September 2014, 12:46   #8
clebin
Registered User
clebin's Avatar
 
Join Date: Apr 2012
Location: Cardiff
Posts: 283
Quote:
Originally Posted by Seblington View Post
Also, the standard Amiga PSU's are a good replacement for the GVP's if you cut off the square connector and replace it with the 5 pin DIN
Definitely - my friend did this for me with a spare A500 PSU when my HD8+ one broke. Worked great for 20 years or so (but sadly stopped working just as I was about to transfer my files off!)

Chris
clebin is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted. GVP A530 PSU Seblington MarketPlace 2 15 September 2014 11:02
GVP A530 manual scanned/upped! Paul_s Nostalgia & memories 15 21 October 2012 16:03
Wanted: GVP A530 Impakt MarketPlace 7 20 March 2008 20:46
WANTED : GVP A530 Turbo THX1138 MarketPlace 33 17 November 2005 19:13
GVP A530 Wanted...... THX1138 MarketPlace 2 12 June 2005 18:53

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06888 seconds with 13 queries