English Amiga Board

Go Back   English Amiga Board > Coders > Coders. Language > Coders. AMOS

Thread Tools
Old 07 March 2018, 22:36   #1
Registered User

Join Date: Mar 2015
Location: Sheffield UK
Posts: 272
WinUAE,AMOS & Fastram

I'm not sure if this is a UAE or a generic problem, but....

If I make a relatively fast but small AMOS program (particularly using AMAL a lot)

WHY does the same program run slower with 4MB fastram than it does with 8MB fastram on an emulated A1200???

The specs of the UAE environment are identical apart from the amount of fastram, and also the same thing occurs after compiling and running from (emulated) floppy.

There is easily enough memory available with 4MB for what I'm doing, I just can't understand why it runs slower with less memory.

Maybe it's an Amiga thing or a UAE thing or an AMOS thing.

Does anyone have any ideas please?
volvo_0ne is offline  
AdSense AdSense  
Old 14 March 2018, 00:38   #2
Registered User

Join Date: Mar 2015
Location: Sheffield UK
Posts: 272
OK answering my own question (again)....

It turned out to be a corrupted WinUAE config (for the 8mb config).

When I replicated the 4MB config & changed the RAM back to 8MB all was well.

I've no idea what happened!
volvo_0ne is offline  
AdSense AdSense  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
How transfer AMOS program on a PC to WINUAE Raphael Coders. AMOS 2 20 August 2017 04:04
2x FastRAM option for A4000 & A3000 models? amigafreak68k support.FS-UAE 1 31 August 2014 22:06
f/s Amiga Amos Programming books / Disks / Easy Amos & other Books *mega collection!* fitzsteve MarketPlace 4 23 May 2012 05:35
A600 4mb Fastram + A1200 Mb Fastram mikele MarketPlace 7 07 May 2012 20:28
Bug with AMOS 3D in WinUAE 2.3.2+ Mequa support.WinUAE 23 10 March 2012 13:43

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 09:31.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Page generated in 0.12163 seconds with 13 queries