English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 11 September 2012, 17:32   #1
kern
 
Posts: n/a
Wacom support in 2.3.3?

Hi

I am trying to use my wacom as a normal mouse inside WUAE 2.3.3 however it is all acting weirdo. I tried the "mouse hack" that was mentioned in one of the posts here however I am not seeing such option at all. What is the tricvk to make it work? I aam not trying to get the pressure sensitivity work etc, I just would like to use it like a mouse without acting crazy all over.

thanks
 
Old 11 September 2012, 18:58   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,283
Mousehack was renamed. Game Ports panel, "Install virtual mouse driver"
Toni Wilen is offline  
Old 11 September 2012, 21:00   #3
kern
 
Posts: n/a
Toni

Thanks for your help. I was starting up my UAE with a config and with that the driver option was always grayed out so I assumed that it was not implemented. After your reply I started it out bare bones and loaded the configs afterwards and that way the option is enabled.

So that is great. Now it works with both full and semi emulation mode. However both options have small quirks if you will.

Full tablet mode is not scaled well. It seems like it it is only covering the lower quadrant. I have a large intuos model. I use 1200x800 screen surface in emulator and the Amiga os.

With the normal mouse driver mode the clicks are somewhat flakey and it takes couple clicks to do it right with the wacom however the surface coverage works well and there is no problem with the scaling.

Thanks again
 
Old 12 September 2012, 12:38   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,283
It is grayed out probably because you tried to adjust when emulation was already running.

Attach both winuaebootlog.txt and winuaelog.txt (enable full tablet mode, tick logging in misc panel before starting emulation), boot to WB, quit emulation.
Toni Wilen is offline  
Old 12 September 2012, 16:21   #5
kern
 
Posts: n/a
Quote:
Originally Posted by Toni Wilen View Post
It is grayed out probably because you tried to adjust when emulation was already running.

Attach both winuaebootlog.txt and winuaelog.txt (enable full tablet mode, tick logging in misc panel before starting emulation), boot to WB, quit emulation.
Hi Toni

Here they are.

http://pastie.org/4707872
http://pastie.org/4707876
 
Old 12 September 2012, 16:53   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,283
Tablet mode problem seems to be caused by signed 16-bit variable overflow. Your tablet has very large range (Xmax=60959,Ymax=45719)

I guess some scaling is needed if range is "too large".
Toni Wilen is offline  
Old 12 September 2012, 18:05   #7
kern
 
Posts: n/a
Toni

Thanks for looking into it. How do you propose the scaling might work? Is it going to be a ui feature?Automatic?

thanks
 
Old 12 September 2012, 19:50   #8
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,283
http://www.winuae.net/files/b/winuae.zip may fix it. Not tested yet

Attach winuaelog.txt if positioning is still wrong (No need for bootlog anymore).
Toni Wilen is offline  
Old 13 September 2012, 00:43   #9
kern
 
Posts: n/a
Hi

Thanks for thwe update. The positioning is wrong but this time it is utilizing the very right side of the screen.

http://pastie.org/4710405
 
Old 14 September 2012, 20:54   #10
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,283
Quote:
Originally Posted by kern View Post
Hi

Thanks for thwe update. The positioning is wrong but this time it is utilizing the very right side of the screen.

http://pastie.org/4710405
You have wrong version, build date is too old. Please redownload.
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can we please have Tapatalk support? Interceptor project.EAB 82 04 May 2013 05:47
WinUAE and Wacom Tablet Tony Landais support.WinUAE 30 23 May 2011 20:14
Portaudio support (was: WinUAE support for ASIO drivers) Akira support.WinUAE 57 28 March 2009 22:15
Close Support Captain_ Kal request.Old Rare Games 2 17 September 2006 13:01
LHA Support ... ferrycorsten request.UAE Wishlist 1 07 October 2004 15:41

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:28.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06820 seconds with 13 queries