English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 23 June 2019, 23:11   #1
Vypr
Registered User

 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 109
Dead A25000 memory card

I've finally managed to coax a dead A2000 back to life. It was initially sold to me as not working with a green screen at boot.

After replacing the PSUinternals with an old ATX PSU, replacing all the memory chips and after several weeks of headscratching getting the right mouse button to work (turned out to be a tiny bit of corrosion near the battery was causing that problem) The system is finally working solidly I am now turning to the two boards that came with it.

The first is a Golem SCSI card with an old MFM drive. I'm not even going to bother with that, the drive is most likely unsalvageable and it's highly unlikely I'll find a replacement drive of this type so I've replaced ti with an A2091 with a SCSI2SD card.

The other card is an old A25000 2Mb card which is non functional.
At the moment it is not being detected at all. On bootup the system Gurus immediately but will then boot into Workbench but the card is not present.
When running DiagROM, the autoconfig goes into a loop, constantly detecting the card and allocating memory space to it before giving up.
I put a scope on the data lines of all the memory chips and there is activity on them.

I don't have high hopes for this card as I think that the onboard memory chips were fried when the PSU went bad and it's likely it has fried this card too but I'd like to at least make the attempt to find out what has gone wrong.

Has anyone here had any experience with these cards?

Last edited by Vypr; 23 June 2019 at 23:12. Reason: spelling
Vypr is offline  
Old 05 July 2019, 14:25   #2
cpiac64
Registered User
cpiac64's Avatar
 
Join Date: Apr 2010
Location: Italy
Posts: 889
test it whit anither diagnostic like Logica's Dialoga
cpiac64 is offline  
Old 05 July 2019, 20:18   #3
TjLaZer
Registered User
TjLaZer's Avatar
 
Join Date: Sep 2004
Location: Tacoma, WA USA
Age: 47
Posts: 1,461
Dead A25000 memory card

Where to find this other Diag ROM?
TjLaZer is offline  
Old 11 July 2019, 00:15   #4
Vypr
Registered User

 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 109
Well, I've recapped it, replaced all the memory chips and now it's not being detected at all. DiagROM no longer finds any card.
Vypr is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Accel Card Memory Lorfarius support.Hardware 3 10 March 2015 14:49
Explansion Card Memory keitha1200 support.Hardware 4 24 June 2012 20:04
WTB: Dead Apollo card 4pLaY MarketPlace 0 23 February 2010 14:16
Microbotics MBX 1200z Ram Card is dead? JackTheKnife support.Hardware 3 06 September 2009 12:52
Accelerator Card Memory pan1k New to Emulation or Amiga scene 1 20 June 2006 16:36

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06127 seconds with 13 queries