English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 28 February 2019, 20:13   #1
xubidoo
Scoobydoo

xubidoo's Avatar
 
Join Date: Jan 2019
Location: Accrington, UK
Posts: 353
Little Advice please

ok . had my cd32 apart today to have a look around ,and im not exactly knowledgeable with electronics so i was hoping someone could cast their eyes on my pics and see if they can tell if the caps etc need doing, to me they look fine lol.
no problems with the cd32 , other than the left mouse button seems to not work sometimes, but other than that everything runs great, plays "backups" no probs , was told when i bought itd had a new lens fitted in 2018.


any help/advice would be appreciated , many thanks
Attached Thumbnails
Click image for larger version

Name:	20190228_171702.jpg
Views:	87
Size:	1.17 MB
ID:	62268   Click image for larger version

Name:	20190228_171719.jpg
Views:	84
Size:	1.27 MB
ID:	62269   Click image for larger version

Name:	20190228_171750.jpg
Views:	74
Size:	1.25 MB
ID:	62270  
xubidoo is offline  
Old 28 February 2019, 20:50   #2
whaka
Registered User

 
Join Date: Jan 2017
Location: France
Posts: 58
Quote:
Originally Posted by xubidoo View Post
to me they look fine lol.
hello

and they're not. some have clearly leaked.
so, it's time.
whaka is offline  
Old 28 February 2019, 21:03   #3
xubidoo
Scoobydoo

xubidoo's Avatar
 
Join Date: Jan 2019
Location: Accrington, UK
Posts: 353
Quote:
Originally Posted by whaka View Post
hello

and they're not. some have clearly leaked.
so, it's time.



as i said im not an electronics person , but thanks for looking , ill look into getting it done.
xubidoo is offline  
Old 01 March 2019, 00:34   #4
Hedeon
PPC Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 1,279
Quote:
Originally Posted by xubidoo View Post
as i said im not an electronics person
Me neither, but maybe one could point to the actual leakages? I can't see them on the photos?

edit: Hmm the one near the expansion slot (photo 1 and 3)? The one under the oscillator (photo 3)?
Hedeon is offline  
Old 01 March 2019, 00:43   #5
arcanist
Registered User
 
Join Date: Dec 2017
Location: Austin, TX
Age: 37
Posts: 255
The bottom-left one in the second photo has a very dry joint, probably from corrosion.

I had one cap in a similar state on an A1200 and it was quite difficult to remove. It took several attempts with flux and new (leaded) solder before the joint reflowed enough to remove the cap. I was using two soldering irons set to 650F but was still really cautious about keeping heat on the pad too long. I have little faith in the glue holding pads to a 25 year old board.
arcanist is offline  
Old 01 March 2019, 01:53   #6
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 2,065
Here are some highlights, it's hard to tell about the large through hole ones, but one certainly looks bulging. There are a couple surface mount ones that definitely look leaking and one that looks to have leaked. If you're having someone do it for you, just have them all done.





grelbfarlk is offline  
Old 01 March 2019, 01:56   #7
Hewitson
Registered User
Hewitson's Avatar
 
Join Date: Feb 2007
Location: Melbourne, Australia
Age: 37
Posts: 3,747
Well spotted.
Hewitson is offline  
Old 01 March 2019, 21:01   #8
xubidoo
Scoobydoo

xubidoo's Avatar
 
Join Date: Jan 2019
Location: Accrington, UK
Posts: 353
thanks guys, shows how much i know lol , i didnt notice any of that , but now u point it out i see , will deff look into having it done asap.
obviously being useless at this stuff , will have to find some1 who can do it for me.

thanks
xubidoo is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi im new here advice please! sneaksby New to Emulation or Amiga scene 7 26 April 2013 02:00
After some advice Mahilu MarketPlace 6 07 September 2011 21:43
Need some advice. CritAnime support.Hardware 6 22 December 2010 11:03
A little advice please !!! synchro Amiga scene 9 17 July 2004 18:24
New CD on the way....Advice please :) synchro Amiga scene 17 17 June 2004 16:01

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:29.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.07145 seconds with 14 queries