English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 20 June 2018, 16:55   #41
fluffkitten
Registered User

 
Join Date: Jun 2018
Location: Nottingham/UK
Posts: 37
Quote:
Originally Posted by DanyPPC View Post
I think an adapter must be compatible with all motherboard revisions. Its logic must adapt and support every amiga.
That's what we'd hope for though given the massive variation even within a revision it is probably never going to happen.

Most 2Bs seem to be fine with adapters but some (including mine) just don't. Mines also unusually got a 40 pin clock port rather than 22, Commodore didn't really seem to care about consistency.
fluffkitten is online now  
Old 21 June 2018, 21:43   #42
crabfists
Registered User
 
Join Date: Feb 2008
Location: warrington UK
Posts: 98
After much persistence I got a reply from Pawel.

“About TOM and problems with right mouse button. We try to find solution, the adapter won't work because we wanted to leave "cd32" option which means we had to controll pin with open colector instead of normal output mode. This week we plan to issue the version with output on and see what's happend - we put on server and ask one of users to check it.”

Promising...
crabfists is online now  
Old 25 June 2018, 12:08   #43
crabfists
Registered User
 
Join Date: Feb 2008
Location: warrington UK
Posts: 98
Pawel just let me know there is an experimental firmware v8 that he hopes fixes the RMB issue.

I am going to try it when I can but I don't have a USB A to USB A cable. Will have to get one first.

Can anybody else give this a go?

Updater is here:

http://electronica4u.com/files/e4you_Updater.exe

youtube vid with instructions here:

[ Show youtube player ]
crabfists is online now  
Old 25 June 2018, 13:29   #44
fluffkitten
Registered User

 
Join Date: Jun 2018
Location: Nottingham/UK
Posts: 37
Thanks crabfists for following this up.

Looking forward to your results.
fluffkitten is online now  
Old 25 June 2018, 18:39   #45
th4t1guy
Registered User
th4t1guy's Avatar
 
Join Date: Mar 2002
Location: Kansas City, MO, USA
Posts: 592
Quote:
Originally Posted by crabfists View Post
I am going to try it when I can but I don't have a USB A to USB A cable. Will have to get one first.
If you have some old spare cables, you can just splice them together and create one. Very simple to do, should only be about 4 wires.
th4t1guy is offline  
Old 25 June 2018, 22:02   #46
crabfists
Registered User
 
Join Date: Feb 2008
Location: warrington UK
Posts: 98
I found a cable and flashed test version 8.

I tried it quickly on my revision 1B A1200 and the right mouse button works... but there is a problem. Every 1 in 20 clicks it retriggers the click, like what would happen if the button was pressed really quickly, then let go and pressed again.

So good.. and bad.
crabfists is online now  
Old 27 June 2018, 14:23   #47
fluffkitten
Registered User

 
Join Date: Jun 2018
Location: Nottingham/UK
Posts: 37
The test version 8 is working very well with both PS2 and HID mice.

I'd definitely recommend the TOM2. Only thing I'd like to see down the track is enabling the mouse wheel but it isn't anything I need in a hurry.
fluffkitten is online now  
Old 27 June 2018, 15:09   #48
crabfists
Registered User
 
Join Date: Feb 2008
Location: warrington UK
Posts: 98
@fluffkitten with test version 8 does the right mouse button work 100%? Have you tried pressing the mouse button on the Workbench menu many times? Does it ever trigger multiple clicks? That is what I am seeing.

I tried it on my A1200 rev 1D4 motherboard and it is really erratic and far worse than my 1B motherboard.

I took a video of it here. I am pressing the right mouse button every second or so but it often detects 2 or 3 right clicks in quick succession. If you turn the sound on and crank the volume up you can hear when I click.

https://i.imgur.com/RiURBm5.mp4

Last edited by crabfists; 27 June 2018 at 15:15.
crabfists is online now  
Old 27 June 2018, 15:37   #49
fluffkitten
Registered User

 
Join Date: Jun 2018
Location: Nottingham/UK
Posts: 37
I'm not having an a problem with that luckily. Did a sequence of 60+ clicks (got bored counting ) and didn't get any extra clicks.

It looks as if the 1D4 problem is slightly different to other boards. Adapters with the 1D4 RMB fix only give me the occasional right click on my 2B.
fluffkitten is online now  
Old 07 July 2018, 00:16   #50
crabfists
Registered User
 
Join Date: Feb 2008
Location: warrington UK
Posts: 98
So, I sent the TOM Rev 2 back in the end.

I just received a Rys MkII from AmigaKit and I am pleased to find out it works great on my 1B motherboard. Right mouse button seems to work 100%.

I haven't quite figured out how to change the sensitivity of it yet. There is a button you have to press and then pressing the left and right mouse buttons is supposed to adjust the speed but holding in the button and pressing the mouse buttons doesn't seem to have any effect.
crabfists is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tom Adapter Wireless Controller scu98rkr support.Hardware 0 05 July 2016 08:40
Tom Kirks PS2 Amiga/Atari adapter kipper2k Hardware mods 38 27 July 2012 17:37
Tom Servo Charlie Nostalgia & memories 5 12 January 2008 18:14
Tom & Jerry 2 turtle request.Old Rare Games 5 21 July 2002 03:02
Tom Tom's Amiga HD spiele cant download AEV Amiga scene 2 25 April 2002 02:11

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07175 seconds with 14 queries