English Amiga Board Amiga Lore


Go Back   English Amiga Board > Other Projects > project.WHDLoad

 
 
Thread Tools
Old 14 May 2012, 18:20   #1
Hedeon
Registered User
 
Join Date: Mar 2012
Location: Leiden
Posts: 25
PPC crashes when WHDload is started

I have the following problem with 17.0 and 17.1 registered:

During the first run of a WHDLoad game (any) I get a WarpOS PPC exception. I can then start it again and it usually then works. When I quit the game I cannot start another (nothing happens).

Is there some WarpOS setting?

Setup:

A4000D in Mirage tower with Mediator 4000D
Cyberstorm 50 MHz 060, 200 MHz PPC 64MB
OS 3.9 with unofficial BB4
WarpOS 16.1
Radeon 9200 256MB using P96
NEC USB card (disabled before WHDLoad use)
100 mbit fast ethernet card
SB128 (i think CT4750, could be ES 1371)

I think only PPC software which is running at the start is WarpDT.

Same software, slightly different hardware (Apollo 040/040 & Voodoo) is working with WHDLoad on my A1200.

Thanks if anyone can help me solve this.
Hedeon is offline  
AdSense AdSense  
Old 14 May 2012, 19:52   #2
Wepl
Moderator
Wepl's Avatar
 
Join Date: Nov 2001
Location: Germany
Posts: 547
Send a message via Skype™ to Wepl
check using SnoopDos which libraries/devices are loaded by the first start of whdload.
Wepl is offline  
Old 15 May 2012, 02:31   #3
Hedeon
Registered User
 
Join Date: Mar 2012
Location: Leiden
Posts: 25
The various libs/devs, in parenthesis the version used:

WHDLoad OpenLib workbench.library Ver 0 OK (45.131)
WHDLoad OpenLib graphics.library Ver 37 OK (40.24)
WHDLoad OpenLib intuition.library Ver 37 OK (40.88)
WHDLoad OpenLib gadtools.library Ver 37 OK (40.4)
WHDLoad OpenLib keymap.library Ver 37 OK (40.4)
WHDLoad OpenLib utility.library Ver 37 OK (40.1)
WHDLoad OpenDev timer.device Unit 0 OK (39.4)
WHDLoad OpenLib expansion.library Ver 37 OK (40.2)
WHDLoad OpenLib lowlevel.library Ver 40 OK (40.35)

WHDLoad Open S:whdload.prefs Read
WHDLoad *Open S:whdload.prefs Read OK
\WHDLoad Open S:whdload.prefs Read OK
WHDLoad ChangeDir GamesZakMcKracken
WHDLoad OpenLib icon.library Ver 34 OK (53.4)

Some CGX stuff? I use p96:

WHDLoad GetVar CyberGraphX/56KHZAUDIO Global
WHDLoad *Lock ENV: Read OK
WHDLoad *Open CyberGraphX/56KHZAUDIO Read Fail
\WHDLoad GetVar CyberGraphX/56KHZAUDIO Global Fail

Loading Key and then fail:

WHDLoad Open S:WHDLoad.key Read
WHDLoad *Open S:WHDLoad.key Read OK
WHDLoad Open S:WHDLoad.key Read OK
[13] Workbench *Lock : Read OK
Defiant Open CON:0/20/400/300/WarpOS - PowerPC Exception/AUTO/CLOSE/WAIT/INACTI Write
Hedeon is offline  
Old 15 May 2012, 03:42   #4
Hedeon
Registered User
 
Join Date: Mar 2012
Location: Leiden
Posts: 25
Took a while, but I found the culprit.... removed Loadlib ppc.library from the user-startup (ppclibemu from Frank Wille).

It all works happily now :-)
Hedeon is offline  
Old 15 May 2012, 12:40   #5
Bamiga2002
bye BlizzardPPC...

Bamiga2002's Avatar
 
Join Date: May 2004
Location: Finland
Age: 36
Posts: 3,154
Send a message via MSN to Bamiga2002
Strange, ppc stuff shouldn't collide with WHDLoad in any way. Never had similar prob on my setup.
Bamiga2002 is offline  
Old 15 May 2012, 14:32   #6
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 35
Posts: 1,511
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
Its the way some version of loadppclib work that causes probems. The only good one that I remember is the one that comes with frogger (installppclibrary). If you dont run ny PowerUP software however, you dont need to worry about it.
Mad-Matt is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Latest WHDLoad crashes Akira support.WinUAE 11 15 October 2012 15:29
All Terrain Racing WHDLoad crashes on CD32 + SX32 BuckoA51 project.WHDLoad 2 21 July 2012 12:16
WHDLoad 17.0.4846 crashes installs? e5frog project.WHDLoad 17 22 July 2010 23:09
n00b guide to getting whdload started please? DoneYone project.ClassicWB 18 06 August 2009 14:40
Aweb: New APL 3.5Beta AOS4 PPC code + Milestone: KHTML porting started Paul News 0 05 November 2004 11:21

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:29.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Page generated in 0.13685 seconds with 13 queries