English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 06 June 2022, 13:41   #1
SID-6581
Registered User
SID-6581's Avatar
 
Join Date: Oct 2017
Location: Oldenburg/Germany
Posts: 82
Question Virus Z - error messages under AmigaOS 3.2.1 with RTG

Hello, I installed the latest VirusZ version with the latest version of the xvs.library and the boot block protection on three systems. On two systems I get error messages when starting VirusZ. AmigaOS 3.2.1 is installed on all systems.


1. Everything works fine on my Amiga 1200 with ACA 1231/41MHz turbo card.


2. On my Raspberry Pi 4 with amiberry 5.2 and activated RTG with the P96 driver V 3.3.0 I get an error message after starting VirusZ (see picture 1). After I clicked OK, an error report comes up (see picture 2).


3. On my Turbo Chameleon 64 with the MinimigAGACore and activated RTG with the P96 driver V 3.3.0 I get an error message after starting VirusZ (see imgage 3). After I click OK, an error report comes up (see picture 4).


Could it be that VirusZ has problems with the P96 driver V3.3.0?


Cheers
SID-6581


P.S: Thank you for your fantastic work Jan-VHT :-)
Attached Thumbnails
Click image for larger version

Name:	amiberry#1.jpg
Views:	70
Size:	131.4 KB
ID:	75740   Click image for larger version

Name:	amiberry#2.jpg
Views:	70
Size:	243.0 KB
ID:	75741   Click image for larger version

Name:	Minimig#1.jpg
Views:	60
Size:	214.3 KB
ID:	75742   Click image for larger version

Name:	Minimig#2.jpg
Views:	64
Size:	355.9 KB
ID:	75743  

Last edited by SID-6581; 06 June 2022 at 23:02.
SID-6581 is offline  
Old 06 June 2022, 14:20   #2
zipper
Registered User
 
Join Date: Mar 2004
Location: finland
Posts: 1,746
Got those with my 3.1 060 RTG system and happily ignored them.
zipper is offline  
Old 06 June 2022, 14:43   #3
StingRay
move.l #$c0ff33,throat

StingRay's Avatar
 
Join Date: Dec 2005
Location: Berlin/Joymoney
Posts: 6,727
Quote:
Originally Posted by SID-6581 View Post
Could it be that VirusZ has problems with the P96 driver V3.3.0?
VirusZ has no problems with P96, it just reports that system vectors have been changed. And these changes were done by the P96 driver as for RTG on Amiga, certain system functions have to be patched.
In short: you don't have to worry about these messages reported by VirusZ, these patches are harmless and required.
StingRay is offline  
Old 07 June 2022, 10:49   #4
SID-6581
Registered User
SID-6581's Avatar
 
Join Date: Oct 2017
Location: Oldenburg/Germany
Posts: 82
Thanks for the information. Thankfully, VirusZ continues to evolve, as does the xvs.library.

https://vht-dk.dk/amiga/xvs/xvs.htm

So wouldn't it make sense for a future VirusZ version to recognize the patch actions of the P96 driver as harmless and no longer issue a warning message?
SID-6581 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Understanding Amiga Test Kit memory error messages (A1000 RAM issues) Turrican_3 support.Hardware 16 31 October 2019 21:54
Getting Relocatability error messages trying to assemble using PhxAss mark_k Coders. Asm / Hardware 3 12 March 2015 15:51
error messages on booting my A1200 Rasputin support.Hardware 3 10 November 2014 15:04
The Thirteen Greatest Error Messages of All Time DamienD Retrogaming General Discussion 22 13 July 2009 13:59
Misleading error messages when registering andreas project.EAB 7 10 April 2004 18:04

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:29.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.09577 seconds with 15 queries