English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 25 April 2018, 14:01   #121
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,447
But then you cannot use JIT, and speed vanish. Is AfA really worth that?
kolla is offline  
Old 25 April 2018, 14:05   #122
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,447
Quote:
Originally Posted by AdvanceFollow View Post
Do I need a 68040.library if running on Amiberry / WinUAE with 68040 emulation?
Depends on what OS and kickstart, and what type of 68040 you configure it to emulate, but in general - yes.
kolla is offline  
Old 25 April 2018, 14:23   #123
AdvanceFollow
Registered User

 
Join Date: Oct 2017
Location: Sweden
Age: 34
Posts: 43
Quote:
Originally Posted by kolla View Post
But then you cannot use JIT, and speed vanish. Is AfA really worth that?
On a powerful desktop PC, it might still be usable without JIT. On my Pi 3B+ it was already a bit on the sluggish side with JIT enabled.
Without MMU, it shouldn't be any less stable than normal OS 3.9 without MMU, though, should it?
AdvanceFollow is offline  
Old 25 April 2018, 14:27   #124
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,447
Quote:
Originally Posted by AdvanceFollow View Post
Without MMU, it shouldn't be any less stable than normal OS 3.9 without MMU, though, should it?
Of course not, but this is software and there are bugs, the more software you add, the more bugs you are likely to suffer from
kolla is offline  
Old 17 May 2018, 12:22   #125
keito
Registered User

 
Join Date: Dec 2013
Location: UK
Posts: 48
With tips from AMIGASYSTEM & Peterk (thanks!) I am now using much cleaner and nicer updated Drawer Icons A few other small tweaks by me too, this is running very fast and nice, still more to do though



keito is offline  
Old 17 May 2018, 16:46   #126
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,319
Well done keito, looks much nicer than my own Workbench.

Why are you running an MMU on UAE? This disables the Jit compiler and is slow. I prefer 68020 + 68882 only. With Jit the emulation is 15-20 times faster. My slow Mini-PC shows a CPU in WhichAmiga with more than 1700 MHz, not just 79 MHz.

And why are you using AGA instead of Picasso96/UAE screenmodes? That's damned slow again. An UAE gfx card is detected, but Picasso96 seems not to be installed (not reported by WhichAmiga). But the quality looks like on a TrueColor screen. Strange?

I just wonder that you say that your system runs fast.

Last edited by PeterK; 17 May 2018 at 17:27.
PeterK is offline  
Old 17 May 2018, 17:16   #127
keito
Registered User

 
Join Date: Dec 2013
Location: UK
Posts: 48
Quote:
Originally Posted by PeterK View Post
Well done keito, looks much nicer than my own Workbench.

Why are you running an MMU on UAE? This disables the Jit compiler and is slow. I prefer 68020 + 68882 only. With Jit the emulation is 15-20 times faster.

And why are you using AGA instead of Picasso96/UAE screenmodes? That's damned slow again.

I just wonder that you say that your system runs fast.

I AM using P96/UAE screenmodes, and it IS really fast...

EDIT: You're right though WhichAmiga would normally report P96 if found, will have a look into that, thanks for the tip!

However ther MMU/JIT Compiler issue, THANK YOU! I'm going to look right into that now and try and achieve some more gains/speed from this setup.... it's always a WIP so just trying things here and there and then comparing data/results, but thank you for the tip

Last edited by keito; 18 May 2018 at 07:23.
keito is offline  
Old 17 May 2018, 17:35   #128
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,319
My previous posting was updated after your quoting.

Yes, I already noticed that the quality looks like on a TrueColor screen, but Picasso96 was not reported in WhichAmiga like on my system.

Of course, you can not use any MMULib stuff on a system with Jit enabled.
PeterK is offline  
Old 17 May 2018, 18:08   #129
keito
Registered User

 
Join Date: Dec 2013
Location: UK
Posts: 48
Quote:
Originally Posted by PeterK View Post
My previous posting was updated after your quoting.

Yes, I already noticed that the quality looks like on a TrueColor screen, but Picasso96 was not reported in WhichAmiga like on my system.

Of course, you can not use any MMULib stuff on a system with Jit enabled.
Just did a quick test without MMU, using 020/030 .... YES! Much quicker, it was already quick though, but Just In Time is much preferred, will be doing some more tweaking for the next update, thanks PeterK! <3
keito is offline  
Old 17 May 2018, 18:55   #130
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,545
Quote:
Originally Posted by PeterK View Post
I prefer 68020 + 68882 only. With Jit the emulation is 15-20 times faster. My slow Mini-PC shows a CPU in WhichAmiga with more than 1700 MHz, not just 79 MHz.
Ciao Peter, I noticed on WinUAE that the power of a 68030/JIT/68882 on WhichAmiga is much more powerful than a 68060/JIT/CPU Internal but this only in theory. Test the two configurations on video or on heavy games as OpenArena (Quake3) and the performances are identical, same speed

Last edited by AMIGASYSTEM; 06 June 2018 at 16:15.
AMIGASYSTEM is offline  
Old 17 May 2018, 19:05   #131
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,319
The difference between the estimated clock speed of a 68020 and a 68060 as shown in WhichAmiga just means that the 060 can do more instructions per cycle than a 020, but the instructions per second are the same, just depending on the emulation speed of the host.
PeterK is offline  
Old 17 May 2018, 19:09   #132
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,545
Thanks for the info Peter
AMIGASYSTEM is offline  
Old 18 May 2018, 08:28   #133
keito
Registered User

 
Join Date: Dec 2013
Location: UK
Posts: 48
Thanks for your help PeterK, using CPU settings as 020 with 882 is much much faster, also WhichAmiga correctly reports no MMU now, though when I took this screenshot just now I forgot to change the "chipset extra" option in Amiberry back to A1200 or Generic as I also forgot to change the kick rom from an A4000 one also. Will continue with my setup this week, but for now, off to work

keito is offline  
Old 18 May 2018, 14:16   #134
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,319
Here comes my boring Workbench now. As you can see I don't care much about eye candy or nice looking icons. It's more a Workbench and not a Showbench. It just shows my laziness, not updating most of my icons for more than 25 years, or since I've installed OS 3.1 on my A2000. My Mini-PC is an ASRock Q2900 (4x2.66GHz), 8 GB, 120 GB SSD with Windows 10. The WhichAmiga FPU clock speed is just a joke, sometimes 3.5 MHz, sometimes 7000 MHz or just everything between.

@keito
From which iconset are these quadratic icons on your screenshot. Do they have two images? I have only a few of these icons in my collection, with one image only. Then my library adds a simple glow effect, but a real glow effect would be nicer. Your CPU clock speed still looks very low. Is this on a Raspberry Pi or is the Jit still off?
Attached Thumbnails
Click image for larger version

Name:	Workbench.png
Views:	89
Size:	873.6 KB
ID:	58278  

Last edited by PeterK; 18 May 2018 at 16:25. Reason: typo
PeterK is offline  
Old 18 May 2018, 16:56   #135
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,545
AMIGASYSTEM is offline  
Old 31 May 2018, 20:21   #136
keito
Registered User

 
Join Date: Dec 2013
Location: UK
Posts: 48
Quote:
@keito
From which iconset are these quadratic icons on your screenshot. Do they have two images? I have only a few of these icons in my collection, with one image only. Then my library adds a simple glow effect, but a real glow effect would be nicer. Your CPU clock speed still looks very low. Is this on a Raspberry Pi or is the Jit still off?
Hi PeterK, first of all thanks for your icon.library and especially the new versions, I've been testing the auto dim/glow for 2nd image versions and they work brilliantly and fast too

So the Icons on my workbench are sortof of a hybrid/chimera. The quadratic ones you refer to as I am using in my dock are all in the "flurry" style which I have collected for many years. I believe they exist both for desktop and for mobile OS's but they are not specifically Amiga at all, but I have used them as I think they look perfect and they work very well on WB. The "DISK" Icons are my own, I have some alternate sets too, which I will display in a few screenshots in a week or two...

They don't have a second image, hence why I am loving your icon library so much If you want me to share some of my icons with you I am happy to do this, just let me know, as I am not sure if they are still downloadable or not.

Your workbench is just that, perfect for working, and tbh my real A1200 with Blizzard/030 was not much different, I scale the visual side down to maintain speed on real hardware. The Raspberry Pi 3b though offers so much power and speed using Amiberry it's almost ridiculous, the screenshots I have posted yes look nice, but are also blazingly fast, especially using your icon.library and using your tip to revert to 020/882 JIT and ditch the unused MMU config, i've never seen a folder open and display 100 png based icons in a split second so fast

@AMIGASTSEM, I <3 your workbench too, this is very close to how I was running mine on original hardware, beautiful!

Last edited by keito; 31 May 2018 at 22:05.
keito is offline  
Old 01 June 2018, 20:49   #137
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,319
Found many of your quadratic icons in the "fAROSenza" set in my collection now, just had to look a little deeper into the subdirs, too. But never heard of "flurry" style yet. http://aminet.net/package/pix/picon/farosenza_v1
PeterK is offline  
Old 01 June 2018, 22:21   #138
keito
Registered User

 
Join Date: Dec 2013
Location: UK
Posts: 48
ah yes farosenza is one of the packs in my flurry folder, i didn't know it was on aminet though i am surprised by that, most of mine i grabbed years ago from deviantart mainly, just looking at the pack from aminet it has amiga specific icons, which my farosenz (from devart) does not, this is really cool, going to have a closer now thanks
keito is offline  
Old 04 June 2018, 16:23   #139
keito
Registered User

 
Join Date: Dec 2013
Location: UK
Posts: 48
Ok good, I now have WhichAmiga correctly reporting Picasso96 as the GFX system. Still a few things to correct/tidy up but this is all coming along nicely now. Just set the SHELL style pos/size/colours also. Man I love Amiga, it your OS, it is what YOU want it to be.

I may make a couple videos showing my setup in a few weeks, peace, 1 <3 - Keito.
keito is offline  
Old 04 June 2018, 16:39   #140
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,319
No, we don't want no war, no matter if 1, 2 or 3 pieces are coming next ... Are you really in the UK ?
PeterK is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I get Workbench running in WinUAE? DashProject support.Apps 1 21 January 2012 23:56
Winuae noob help with workbench mr_durdan support.WinUAE 4 29 December 2011 15:32
WinUAE and Workbench 1.3 galu support.WinUAE 4 17 September 2009 20:40
Bloodwych workbench on winuae synchro project.ClassicWB 14 15 June 2009 20:29
Workbench 3.x OS in WinUAE oneshotdead New to Emulation or Amiga scene 9 29 August 2007 07:01

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:32.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.09827 seconds with 15 queries