English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 24 February 2018, 11:18   #161
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,394
However I tried to put back DirectSound and nothing has changed, the always excellent quality even when listening to two Mp3s at the same time, this means that the miracle does the configuration up WinUAE and AHI.
AMIGASYSTEM is online now  
Old 26 February 2018, 19:28   #162
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,759
http://www.winuae.net/files/b/winuae_3610b7.7z
http://www.winuae.net/files/b/winuae64_3610b7.7z

Beta 7: (Hopefully final beta. Maybe.)

- Added resident struct to UAE boot ROM filesystem, enables c:version <directory filesystem device name>: to report name and version.
- Enabled hardware emulated network card was not fully freed when Restart was pressed, it was still listening for incoming packets.
- Game Ports panel selected Custom input mapping reverted to none in some situations.
- Added PP&S Zeus 040 emulation, SCSI supported, other possible special hardware features not implemented.

PP&S Zeus 040 SCSI:
- 53C710 based which has built-in DMA controller but for some unknown reason driver wastes all CPU time. (but fix is coming, more info later..)
- PPSscsi2.device ("PPS SCSI Device 2.98 (28 Aug 1992)")
Toni Wilen is offline  
Old 26 February 2018, 19:38   #163
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 41
Posts: 12,144
Thanks Toni, of course you also fixed this
DamienD is offline  
Old 26 February 2018, 20:21   #164
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,759
I forgot to mention when it got changed so I also forgot to mention when it got fixed
Toni Wilen is offline  
Old 03 March 2018, 05:41   #165
bladecgn
Registered User

 
Join Date: Nov 2013
Location: Essen / Germany
Posts: 137
If I switch from Direct3D 9 to Direct3D 11 Mode, the Emulated Amiga gets very slow. You can see each icon appearing on the screen. Switching back to Direct3D 9 makes it run fast again.

Starting in Direct3D9 Mode: System is fast.
Attached Files
File Type: txt winuaebootlog.txt (11.0 KB, 19 views)
File Type: uae DEFAULT_CF_intern.UAE (14.2 KB, 14 views)

Last edited by bladecgn; 03 March 2018 at 05:48.
bladecgn is offline  
Old 03 March 2018, 08:49   #166
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,759
Quote:
Originally Posted by bladecgn View Post
If I switch from Direct3D 9 to Direct3D 11 Mode, the Emulated Amiga gets very slow. You can see each icon appearing on the screen. Switching back to Direct3D 9 makes it run fast again.

Starting in Direct3D9 Mode: System is fast.
Probably due to vsync or refresh rate. "Default" refresh rate may not be same as with D3D9 and vsync works very differently in D3D11 and low latency vsync isn't "tuned" yet. Try also normal vsync.
Toni Wilen is offline  
Old 07 March 2018, 22:48   #167
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 327
Hi Toni,
I wanted to report that using a .hdf with 4.1 and initializing the installation with the floppy Grexbootdisk.adf everything works normally and the installation ends well.
But from the moment I make the updates, the xad, xpksksh libraries are not installed in any way.
In the copy purchased by hyperion there is this floppy inside the installation CD, which I have always used to use G-Rex.
Today I tried many times but this error remained.
In the documentation it is said that G-Rex is experimental.
It was a long time since I had used the .hdf files
So changing installation mode and using PCI Mediator Elbox and using the floppy .adf everything works, updates are made without problems.
Then changing the startup-sequence by hand and enabling the G-Rex:
BootLoader COMMANDLINE = "AllowBasepageAccess GREX NoRamPager"
everything works.
But I must initially use PCI Mediator Elbox for everything to work.

This does not happen using a real hard disk, everything works fine with the Grexbootdisk.adf floppy and updates are also working.

Now I do not remember, I'm sorry but some version of winUAE before the 3.6xx series everything worked well also from .hdf
I hope this can be useful.
Indeed if anyone can do some tests I would understand if I'm doing something wrong just me, I tried both the English and Italian version but the error remains.

I hope it is useful.
Sorry again for this report.
Thank you.
Attached Thumbnails
Click image for larger version

Name:	grx-floppy.JPG
Views:	94
Size:	59.2 KB
ID:	57171  

Last edited by White; 07 March 2018 at 23:23. Reason: error
White is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 2.8.0 beta series (Was 2.7.1) Toni Wilen support.WinUAE 214 01 May 2014 11:28
WinUAE 2.4.0 beta series Toni Wilen support.WinUAE 342 29 March 2012 09:02
WinUAE 2.3.0 beta series (was 2.2.1) Toni Wilen support.WinUAE 229 22 September 2010 19:20
WinUAE 2.0.1 beta series Toni Wilen support.WinUAE 14 22 December 2009 18:46
WinUAE 1.5.1 beta series Toni Wilen support.WinUAE 242 12 August 2008 12:42

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:10.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06947 seconds with 15 queries