English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 10 July 2017, 05:51   #1
Knocker
Registered User

 
Join Date: Jan 2016
Location: Santa Cruz/US
Posts: 43
Ctrl keys don't work after upgrade

I just upgraded to Amiga Forever 2017 (WinUAE 3.5.0.1) and the Ctrl keys on my keyboard don't work anymore, they don't do anything. This is in Devpac, where e.g. Ctrl+a assembles. I have a standard Dell USB keyboard and I'm on Win8. Any suggestions? Thanks!
Knocker is offline  
Old 10 July 2017, 08:19   #2
Tomislav
Registered User

 
Join Date: Aug 2014
Location: Zagreb / Croatia
Posts: 131
Look at "Game Ports". Maybe "Keyboard Layout B" for joystick is enabled.
Tomislav is offline  
Old 10 July 2017, 20:28   #3
Knocker
Registered User

 
Join Date: Jan 2016
Location: Santa Cruz/US
Posts: 43
I don't have any game ports enabled. I tried with a different keyboard, same thing happens...
Knocker is offline  
Old 14 July 2017, 10:30   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,773
Input handling works very differently when winuae is running under AF. I can't help with that.
Toni Wilen is online now  
Old 15 July 2017, 17:01   #5
Foebane
Registered User
 
Join Date: Sep 2011
Location: Cardiff, UK
Posts: 1,230
Quote:
Originally Posted by Knocker View Post
I just upgraded to Amiga Forever 2017 (WinUAE 3.5.0.1) and the Ctrl keys on my keyboard don't work anymore, they don't do anything. This is in Devpac, where e.g. Ctrl+a assembles. I have a standard Dell USB keyboard and I'm on Win8. Any suggestions? Thanks!
I shed the AF frontend a long time ago, and I haven't missed it one bit!
Foebane is offline  
Old 16 July 2017, 07:14   #6
Knocker
Registered User

 
Join Date: Jan 2016
Location: Santa Cruz/US
Posts: 43
Thanks Toni & Foebane, it works properly if I run WinUAE 3.5 standalone.
Knocker is offline  
Old 08 August 2017, 13:46   #7
mcb
Registered User

mcb's Avatar
 
Join Date: Oct 2008
Location: - / -
Posts: 47
Quote:
Originally Posted by Knocker View Post
I just upgraded to Amiga Forever 2017 (WinUAE 3.5.0.1) and the Ctrl keys on my keyboard don't work anymore, they don't do anything. This is in Devpac, where e.g. Ctrl+a assembles. I have a standard Dell USB keyboard and I'm on Win8. Any suggestions? Thanks!
Thanks for the feedback. Does it also happen with the current beta (7.1.34.0)?

Please feel free to use this dedicated thread:

http://eab.abime.net/showthread.php?t=87398
mcb is offline  
Old 30 December 2017, 06:05   #8
Knocker
Registered User

 
Join Date: Jan 2016
Location: Santa Cruz/US
Posts: 43
Sorry for the very late response! I just tried 7.2.1.0 (Beta) and the Ctrl keys seems to work fine. Thanks for fixing!
Knocker is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A1200 ctrl+Amiga+Amiga reboot won't work (and low sound) mawrick support.Hardware 10 28 October 2015 19:28
Ctrl + Function Keys no longer working in 2.4.0+? killergorilla support.WinUAE 4 20 September 2012 15:53
Battleships don´t work formater support.WinUAE 3 16 September 2007 14:01
90% of my games don't work dreamkatcha New to Emulation or Amiga scene 38 28 March 2007 15:10
Keys don't work with cd32 emulation ThunderBoltRiot New to Emulation or Amiga scene 6 23 July 2005 17:53

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:19.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06773 seconds with 14 queries