View Single Post
Old 14 December 2016, 18:02   #83
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
i get some freezes with Caligari Broadcast. loading an object, skip through the object
hierarchy and emulation is frozen, right after JIT disable, emulation continues.
those halts do occour on differnt occasion, but this example below, one can easily reproduce.

zoned:CaligariBR-freezes.with.JIT.enabled.lha

- tests done with basic a1200 030/882 wb/kick 3.x - standard jit settings. 2mb chip/128+mb fast z3, fastest possible
winuae 3.4b19 (32 bit & 64bit) , 3.2.0 (32bit) and 3.1.0 (32bit).

- in 3.1.0 you could make it freeze, when using the cursor keys (see below),
using the mouse and move around in workspace, is a bit more stable.

#1) extract anywhere - start Caligari-Assigns. next start Caligari.

#2) at start-screen -> select scene design
#3) select AddObj (buttom-center of screen) - choose folder Objects3 -> B747 -> click LOAD, then DONE

#4) hold left mouse and move around, it should freeze after a moment.
#5) or use the cursor keys - up/down/left/ right - it should jump through the object tree

once frozen - nothing happens when moving mouse/push cursor key -> goto config
and disable JIT -> emulation continues.

this behavior is special to Caligari, happens in older versions too, but cannot remember exactly.
Caligari040 is the 68040 version of Caligari Broadcast,
Caligari372 - is somehow fake version of Caligari24 (just skip this, crashes here- I forgot to delete)

i hope you can reproduce this, since its really annoying, when using the app

Last edited by emufan; 14 December 2016 at 18:27.
emufan is offline  
 
Page generated in 0.04074 seconds with 11 queries