View Single Post
Old 30 August 2009, 22:42   #47
Linux snob

gilgamesh's Avatar
Join Date: Sep 2008
Location: Monkey Island
Posts: 997
Originally Posted by Toni Wilen View Post
For some unknown reason root.bin mounted as ramdisk does not contain /sbin/init (or working filesystem or something)

Someone with more emulated Linux interest than me should do some debugging..
I didn't solve the problem, but came one step closer (using Woody).
You need much more ram than I thought. Install 32MB Z3 at least or more. (I use 128MB.)

root.bin and linux.bin are compressed (gz). Uncompress them in order to save time. You can mount the uncompressed root image under (native) linux. It is ext2.
Edit StartInstall so that it will use the uncompressed images. Something like
amiboot-5.6 -d -k vmlinux.tmp -r root_d.bin root=/dev/ram
The root image contains /sbin/init. I tried to add
but amiboot does not pass init to the kernel as a parameter. I think everything would be fine, if it did.
EDIT: Or it does pass it, and something goes completely wrong at lowlevel.

Last edited by gilgamesh; 30 August 2009 at 22:49.
gilgamesh is offline  
Page generated in 0.05578 seconds with 11 queries