View Single Post
Old 21 June 2006, 17:55   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,328
A1200 Kickstart seems to only access Gayle IDE registers after some kind of Gayle detection code: (log from WinUAE with A1200 KS3.1 ROM, format is address, data, length of access)

45-921 [4 225x011]: GAYLE_WRITE 00DE109A=FFFFBFFF (2) PC=00F80480
45-921 [4 225x011]: GAYLE_WRITE 00DE1000=00000000 (1) PC=00F804AE
45-921 [4 225x011]: GAYLE_READ 00DE1000 PC=00F804CA
45-921 [4 225x011]: GAYLE_READ 00DE1000 PC=00F804CA
45-921 [4 225x011]: GAYLE_READ 00DE1000 PC=00F804CA
45-921 [4 225x011]: GAYLE_READ 00DE1000 PC=00F804CA
45-921 [4 225x011]: GAYLE_READ 00DE1000 PC=00F804CA
45-921 [4 225x011]: GAYLE_READ 00DE1000 PC=00F804CA
45-921 [4 225x011]: GAYLE_READ 00DE1000 PC=00F804CA
45-921 [4 225x011]: GAYLE_READ 00DE1000 PC=00F804CA
45-921 [4 226x035]: GAYLE_WRITE 00DE109A=FFFFBFFF (2) PC=00FB706E
45-921 [4 226x035]: GAYLE_WRITE 00DE1000=00000000 (1) PC=00FB70B0
45-921 [4 226x035]: GAYLE_READ 00DE1000 PC=00FB7042
45-921 [4 226x035]: GAYLE_READ 00DE1000 PC=00FB7042
45-921 [4 226x035]: GAYLE_READ 00DE1000 PC=00FB7042
45-921 [4 226x035]: GAYLE_READ 00DE1000 PC=00FB7042

A4000 ROM does access A4000 IDE registers without testing anything.

19-625 [105 226x006]: GAYLE_WRITE 00DD203A=FFFFFFA0 (1) PC=00F8B0DE
19-625 [105 226x006]: GAYLE_READ 00DD203E PC=00F8AEEE
19-625 [105 184x007]: GAYLE_READ 00DD203A PC=00F8AEEE
19-625 [105 111x008]: GAYLE_READ 00DD2026 PC=00F8AEEE
19-625 [105 038x009]: GAYLE_READ 00DD2032 PC=00F8AEEE
19-890 [118 226x001]: GAYLE_READ 00DD203E PC=00F8AEEE
19-890 [118 141x002]: GAYLE_READ 00DD203A PC=00F8AEEC
19-890 [118 005x003]: GAYLE_READ 00DD2026 PC=00F8AEEC
19-890 [118 096x003]: GAYLE_READ 00DD2032 PC=00F8AEEC

(this interested me because I am going to implement A1200/A4000-compatible IDE emulation soon..)
Toni Wilen is online now  
 
Page generated in 0.04726 seconds with 11 queries