View Single Post
Old 19 February 2021, 22:30   #1
Sembiance
Registered User

Sembiance's Avatar
 
Join Date: May 2020
Location: Asheville / USA
Posts: 3
Floppy disk Floppy boots but can't access in Workbench?

Greetings

I'm new to Amiga and have ran into a problem.

I'm using FS-UAE 3.0.5 to emulate an Amiga 1200 running 3.1 Kickstart and vanilla/stock Workbench v3.1 rev 40.42

I can boot the Amiga with the following floppy: https://telparia.com/fileFormatSampl...FS/voyager.adf

It runs the floppy, a demoscene prog with lots of cool graphics and music. Fun!

My goal is to get a listing of the files on the floppy and copy them off so I can dig into the files.

Problem is, Workbench 3.1 can't access the floppy.
When attempting to get a listing in the Shell with DIR DF0: it tells me: Not a DOS disk in device DF0

From my research, my guess is that this floppy has a non-standard filesystem, maybe even a custom one the author did to squeeze more space for the demo.

Being new to the Amiga, I'm not sure what to do next.

Question 1: Is there additional file system support that I can add to Workbench so it will read this floppy?

Question 2: Are there shell commands or amiga programs I can run that will print more info about the disk, to try and figure out what filesystem it's been formatted with?

Question 3 (edit): Maybe I should use something like WHDLoad? Although this appears to be for a real Amiga and also looks quite daunting.

Thanks!

PS - Really loving working with the Amiga so far! Grew up with a C64, always wanted an Amiga

Last edited by Sembiance; 19 February 2021 at 22:44. Reason: Formatting
Sembiance is offline  
 
Page generated in 0.04335 seconds with 11 queries