View Single Post
Old 21 December 2019, 17:34   #1199
JuanLuis
Registered User
 
Join Date: Dec 2018
Location: Málaga
Posts: 45
Quote:
Originally Posted by bebbo View Post
I'm not sure what the real error is. That's not enough information here.
I attach a couple of files. main.s is the assembler program with an error.

--- main.s ---
...
msg:
.ascii "Calculando numeros primos, espere por favor..."
dc.b LF
msg_end: /* msg_end is defined here */

msg_length = msg_ed - msg /* There is a mistake. It should be msg_end instead of msg_ed */
...
--- end of main.s ---

--- build_msg.txt ---
...
main.s:52 .text:000000000000004c msg
*ABS*:0000000000000000
*ABS*:0000000000000000 msg_length <-- msg_length is zero
*ABS*:0000000000000000
main.s:41 .text:000000000000003e close_AmigaDOS
*ABS*:0000000000000000
*ABS*:0000000000000000
*ABS*:0000000000000000
main.s:47 .text:000000000000004a end
*ABS*:0000000000000000
*ABS*:0000000000000000
main.s:55 .text:000000000000007b msg_end
*ABS*:0000000000000000
*ABS*:0000000000000000
...
UNDEFINED SYMBOLS
msg_ed

mkdir -p dist/Debug/Amiga_Cygwin64_Bebbo-Windows
m68k-amigaos-gcc -o dist/Debug/Amiga_Cygwin64_Bebbo-Windows/primos build/Debug/Amiga_Cygwin64_Bebbo-Windows/main.o -Wl,--error-unresolved-symbols
make[2]: se sale del directorio '/cygdrive/c/Users/Juan Luis/Documents/NetBeansProjects/Primos'
make[1]: se sale del directorio '/cygdrive/c/Users/Juan Luis/Documents/NetBeansProjects/Primos'

BUILD SUCCESSFUL (total time: 1s)
--- end of build_msg.txt ---
Attached Files
File Type: s main.s (1.3 KB, 10 views)
File Type: txt build_msg.txt (7.5 KB, 12 views)
JuanLuis is offline  
 
Page generated in 0.04446 seconds with 12 queries