View Single Post
Old 02 November 2018, 20:27   #19
ross
Per aspera ad astra

ross's Avatar
 
Join Date: Mar 2017
Location: Crossing the Rubicon
Age: 50
Posts: 2,628
Quote:
Originally Posted by Toni Wilen View Post
It is KS 1.3 weirdness. Nothing to do with WinUAE.

Set break point at C0898E and check what it does. (No, I have no idea what it tries to do..)
Sorry, I fail to understand how this can be related to KS1.3.
(i've noticed some strange code in KS1.3 that do a 'copper' search from $0 but sure do not trash all like this and is totally unrelated).

At c0898e i've nothing significative.

And I've something really similar also on Quickstart A600 (KS2.05) config:
Code:
Memwatch 0: break at 00000002.W   I 00000000 PC=80000000 CPUI (000)
Cycles: 81 Chip, 162 CPU. (V=30 H=18 -> V=30 H=99)
  D0 15F600F8   D1 0A2600F8   D2 0A2800F8   D3 0A2A00F8
  D4 0A2C00F8   D5 0A2E00F8   D6 0A3000F8   D7 0B2200F8
  A0 0A3400F8   A1 0A3600F8   A2 0A3800F8   A3 0A3A00F8
  A4 0A3C00F8   A5 0A3E00F8   A6 0A4000F8   A7 00000042
USP  00000042 ISP  00100000
T=00 S=0 M=0 X=0 N=0 Z=0 V=0 C=0 IMASK=0 STP=0
Prefetch 0000 (OR) 8000 (OR) Chip latch 00000000
80000000 8000                     OR.B D0,D0
Next PC: 80000002
>
You used the exact same steps indicated in my previous post?
Surely it's my mistake but I do not understand exactly where it could be..

EDIT: strange output to the H command after the w trap:
Code:
>H
-1 00FC0F94 60e6                     BT .B #$e6 == $00fc0f7c (T)
 0 00000000 8000                     OR.B D0,D0
>

Last edited by ross; 02 November 2018 at 20:36.
ross is offline  
 
Page generated in 0.04386 seconds with 11 queries