View Single Post
Old 03 October 2019, 11:50   #1
sparhawk
Registered User

sparhawk's Avatar
 
Join Date: Sep 2019
Location: Essen/Germany
Age: 50
Posts: 67
Building gcc from source

I'm trying to build gcc from SVN using msys2. I'm using the following configure:

Code:
../gcc-svn/configure --prefix=/opt/gcc-m68k-dev --target=m68k-elf --with-arch=m68k --with-cpu=m68000 --enable-languages=c,c++ --with-newlib --disable-libmudflap --disable-libssp --disable-libgomp --disable-libstdcxx-pch --disable-threads --disable-nls --disable-libquadmath --with-gnu-as --with-gnu-ld --without-headers --build=$MSYSTEM_CHOST --host=$MSYSTEM_CHOST
But it always fails with:
Code:
checking for m68k-elf-gcc... /d/src/gcc/gcc-svn-msys/./gcc/xgcc -B/d/src/gcc/gcc-svn-msys/./gcc/ -B/opt/gcc-m68k-dev/m68k-elf/bin/ -B/opt/gcc-m68k-dev/m68k-elf/lib/ -isystem /opt/gcc-m68k-dev/m68k-elf/include -isystem /opt/gcc-m68k-dev/m68k-elf/sys-include
checking for suffix of object files... configure: error: in `/d/src/gcc/gcc-svn-msys/m68k-elf/libgcc':
configure: error: cannot compute suffix of object files: cannot compile
See `config.log' for more details
I also tried removing the "--with-cpu" option, but that doesn't make a difference.


The problem is that it xgcc passes "-m..." to as which complains that it doesn't support that option.
Code:
/d/src/gcc/gcc-svn-msys/./gcc/xgcc -B/d/src/gcc/gcc-svn-msys/./gcc/ -B/opt/gcc-m68k-dev/m68k-elf/bin/ -B/opt/gcc-m68k-dev/m68k-elf/lib/ -isystem /opt/gcc-m68k-dev/m68k-elf/include -isystem /opt/gcc-m68k-dev/m68k-elf/sys-include /tmp/t.c
/d/src/gcc/gcc-svn-msys/./gcc/as: line 106: exec: -m: invalid option
exec: usage: exec [-cl] [-a name] [command [arguments ...]] [redirection ...]
Any ideas how what I'm doing wrong?
sparhawk is offline  
 
Page generated in 0.04854 seconds with 11 queries