View Single Post
Old 18 January 2015, 02:30   #1
Registered User
Join Date: Feb 2010
Location: Canada
Posts: 65
RTG screens do not stretch to fill entire monitor


I used WinUAE almost exclusively for productivity software (i.e. ImageFX, Aladdin4d, Lightwave, etc.). I had been runing a Windows XP SP3 system with WinUAE 2.5.x for many years and it was just perfect. However, my computer died and I had to reinstall everything on another Windows XP era machine. This time I "upgraded" to WinUAE 2.8.1. To understand the problem, it's important that you know I run the emulation with the Display setting set to "Fullscreen" mode for both native and RTG Amiga screens.

Things are mostly fine, except with this installation when I use an Amiga RTG screenmode that is lower in resolution than the 1920x1080 Windows OS desktop, the Amiga screen appears at actual resolution on the monitor, i.e. smaller than the monitor and surrounded by a black border and NOT scaled to fill the monitor. This means that a 640x480 RTG screen occupies only a 4 inch x 4 inch box in the middle of my monitor. Only the Amiga RTG mode of 1920 x 1080 fills the entire monitor (and this mode of course matches my Windows OS resolution).

Oh - NATIVE (non-RTG) screenmodes DO stretch to fill the monitor.

I'm not sure if this is a WinUAE problem, a Windows OS issue, or hardware/graphics driver issue.


- I'm running WinUAE 2.8.1 in full-screen mode.
- I'm using DirectX9 and my graphics hardware is the Intel 82945G chipset provided on the motherboard. DirectX9 is the last DirectX supported by Windows XP.
- OS is Windows XP SP3
- In WinUAE's Filter settings "RTG" is set to use "Null Filter" and "Default". I've tried setting this to "none" with no improvement.
- Under the WinUAE Miscellaneous settings, Graphics API is set to "DirectDraw". I am unable to use the Direct3D setting as it seems DirectX9 doesn't support it (error message "New DirectX runtime required").
- Under the WinUAE Expansions setting, RTG Graphics Card is set to "UAE Zorro III" and "Scale if smaller than display size setting" is checked.

I've found a work-around the issue by specifying that RTG screenmodes run in FULL WINDOW mode. But would still like to know what has gone wrong with the full screen RTG scaling as that was a very elegant solution.


Last edited by ral-clan; 18 January 2015 at 02:38.
ral-clan is offline  
AdSense AdSense  
Page generated in 0.05476 seconds with 9 queries