View Single Post
Old 19 October 2014, 17:02   #2
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,487
I have uploaded to The Zone!, an unofficial alpha version of my AIAB r10.7 Alpha.

This is an updated version of the last Amiga in a Box package (r10.6). It respects its former philosophy but attempts to upgrade and bugfix what was inside there. This release is just my Alpha test, which means it may contain lots of bugs innacuracies and mistakes, but at least it runs a little bit modernized.

I did not make any radical changes and went conservative about the updates I applied. So no fancy new features unless they come in a new version of some former software which was already included (Some particular exceptions apply though, like including PeterK´s IconLib, for example).

Minimum Requirements remain the same:

Kickstart 3.0 or 3.1
Workbench 3.0 or 3.1 floppy disk
8MB of fastmem
68020 processor
About 25 MB of free HDD space
A Picasso96 compatible graphics card with 2 MB of video ram and capable of 16 bit depth (can work with less video ram if you use small resolutions)

Note: AmigaOS 3.5 and 3.9 have not been tested and should not work straightaway!


BASE SYSTEM:
Amiga in a Box r10.6

NEW:
IconLib 46.4 (46.4.385 supports OS4 icons. So no need for AfAOS)
MCC_TextEditor 15.45 (required by Scalos v41.7)

UPDATES:
ScalOS 41.5 -> 41.7
Picasso96 2.0 -> 2.1d
Mui 3.8 -> 3.9R2
Dopus 4.16 > 4.17pre20
WhdLoad 16.4 -> 17.2
WhichAmiga 1.3.22 -> 1.3.3 with getmhz check enabled to support ACA accelerators
BoardsLib 2.29 -> 3.16

ISSUES, TODO LIST AND MENTAL NOTES:
AmiStart "Run Command..." does not work. Anybody knows a fix for this? It´s been happening since Jaybee´s days
GoldED 5.0 is a restricted DEMO version. There are plenty of free unrestricted text editors to replace it with. Shoul I changed it?
AmiStart should be upgraded to 0.66x
InstallerNG seems a bit incompatible, should I replace it wih CBM stuff or another MUI counterpart?
Format does not support >4GB devices. There are cool 4GB capable replacements, should I use one of those?
The entire system still needs lots of updates that should be pretty easy: datatypes, libraries, some programs, etc
Should AmigaOS 3.9 be supported? and 3.5?
Should 3.1 fixes be applied?
gulliver is offline  
 
Page generated in 0.04999 seconds with 9 queries