View Single Post
Old 01 March 2003, 02:35   #1
ethylene
Registered User
ethylene's Avatar
 
Join Date: Jul 2001
Location: Beaverton, OR, USA
Posts: 87
Send a message via ICQ to ethylene Send a message via AIM to ethylene Send a message via MSN to ethylene Send a message via Yahoo to ethylene
Problems w/ fullscreen 60Hz vsync since v0.8.22R2

In fullscreen NTSC mode with resolution of 720x480, 16bit, 60Hz:

v0.8.22R2: Sound is too slow with vsync activated. Toggling 'Use primary DirectSound buffer' on or off and closing dialog box randomly corrects / reintroduces problem.

v0.8.22R3: Same as R2.

v0.8.22R4: Sound is too fast with vsync activated. Toggling 'Use primary DirectSound buffer' has no effect on sound speed problem.

v0.8.22R5: Sound is too fast with vsync activated. Leaving vsync enabled and setting refresh rate to 50Hz corrects sound speed but introduces regular clicking.

All versions: Disabling vsync corrects problem. Changing 'sound driver lag compensation slider' decreases/increases sound speed, but slider range is not wide enough to reach correct level of compensation. Using different resolutions has no effect. Using WinUAE with/without PowerStrip has no effect. Running in PAL mode works fine.

Using Win98SE, 440BX, PIII550@616MHz, 256MB CL2 SDRAM, Geforce 256 DDR, AWE 64 Gold.
ethylene is offline  
AdSense AdSense  
 
Page generated in 0.08894 seconds with 9 queries