Thread: Hail!
View Single Post
Old 14 April 2014, 13:34   #3
Registered User

TCD's Avatar
Join Date: Sep 2006
Location: Germany
Age: 40
Posts: 24,020
Originally Posted by Galder View Post
C. My kickstarter (firmware) is 2.0. Is there a list somewhere with compatible and non-compatible games for that? Can i run all of the A500 games?
Simple answer: No, you can't run all A500 games.

KS 2.x (and above) does cause problems with games. It's surely more than a few games, but I don't think there's a list around.
TCD is offline  
Page generated in 0.05586 seconds with 9 queries