View Single Post
Old 04 January 2014, 21:50   #3
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
There seems to be an issue in that sometimes when you enable resolution autoswitch then switch to a super-high res mode, that isn't detected so the screen is shown at half width (every other pixel missing).

However, if you first start emulation with resolution set to normal, then set resolution to superhighres then back to normal (clicking OK to resume emulation between each step). Then after doing that, you can enable resolution autoswitch and on changing Workbench screenmode to superhighres it does display correctly (i.e. superhighres resolution is automatically set).

To hopefully clarify that, first try this:
  • Run WinUAE. Load a config which has resolution normal, resolution autoswitch disabled. Start emulation and boot Workbench. (I used an HDF where the Workbench screenmode is PAL:High Res Laced.)
  • Workbench loads with high-res laced screen.
  • Open settings window and enable resolution autoswitch. Click OK to return to emulation.
  • Change Workbench screenmode to PAL:Super-High Res Laced.
  • Screen resolution is still normal, so every other pixel is missing.
Then try this:
  • Run WinUAE. Load a config which has resolution normal, resolution autoswitch disabled. Start emulation and boot Workbench. (I used an HDF where the Workbench screenmode is PAL:High Res Laced.)
  • Workbench loads with high-res laced screen.
  • Open settings window and change resolution to Superhires. Click OK to resume emulation.
  • Open settings window and change resolution back to normal. Click OK.
  • Open settings window and enable resolution autoswitch. Click OK.
  • Workbench appears as it should (resolution automatically set to superhires).
mark_k is offline  
 
Page generated in 0.04855 seconds with 9 queries