View Single Post
Old 28 November 2013, 02:01   #17
Akira
Registered User

Akira's Avatar
 
Join Date: May 2001
Location: New York
Posts: 17,959
OH I see. The first entries were for WHDLoad. You can ignore everything after line 9.

I know where you are getting at. No, the PATH sentence in my startup-sequence is exactly like the one daxb posted. This is a pretty much vanilla Workbench install.

But why does none of that appear on the path? Something else must be erasing it!!! But what?

Here's my startup-sequence:
Code:
acatune -maprom * -maxram >nil:
; $VER: startup-sequence 38.22 (24.4.92)


assign >NIL: t: ram:
assign >NIL: env: ram:

;quickboot sequence -----------------
; Protracker load -------------------

keypressed 64
if warn
   skip ptstart
endif


C:SetPatch QUIET
Version >NIL:
;AddBuffers >NIL: DF0: 15
FailAt 21

MakeDir RAM:T RAM:Clipboards RAM:ENV RAM:ENV/Sys
Copy >NIL: ENVARC: RAM:ENV ALL NOREQ


Assign >NIL: ENV: RAM:ENV
Assign >NIL: T: RAM:T
Assign >NIL: CLIPS: RAM:Clipboards
;Assign >NIL: REXX: S:
;Assign >NIL: PRINTERS: DEVS:Printers
Assign >NIL: KEYMAPS: DEVS:Keymaps
Assign >NIL: LOCALE: SYS:Locale

c:Fblit

IF NOT EXISTS SYS:Fonts
  Assign FONTS:
EndIF

BindDrivers
Mount >NIL: DEVS:DOSDrivers/~(#?.info)

Resident >NIL: C:Execute PURE

IF EXISTS DEVS:Monitors
  List >NIL: DEVS:Monitors/~(#?.info) TO T:M LFORMAT "DEVS:Monitors/%s"
  Execute T:M
  Delete >NIL: T:M
EndIF

mount speak: from devs:speak

SetEnv Workbench $Workbench
SetEnv Kickstart $Kickstart
UnSet Workbench
UnSet Kickstart

IPrefs

Echo "Amiga Release 2.1.  Kickstart $Kickstart, Workbench $Workbench"

ConClip

Path >NIL: RAM: C: SYS:Utilities SYS:Rexxc SYS:System S: SYS:Prefs SYS:WBStartup SYS:Tools SYS:Tools/Commodities

IF EXISTS S:User-Startup
  Execute S:User-Startup
EndIF

Resident Execute REMOVE

GoWB

;--------------------
lab ptstart
mount cf0:
cd cf0:dj/superbyte2013
000pt1210
skip exit


;-------------
lab exit
prompt %s.%n>
And this is my user-startup:
Code:
; This mounts KCON and KRAW
Mount KCON: from DEVS:KingCON-mountlist
Mount KRAW: from DEVS:KingCON-mountlist

mount cf0:
cd cf0:
WBStartup is empty. I have no commodities running either.

I seriously see NO reason why this is happening.
Akira is offline  
 
Page generated in 0.04882 seconds with 9 queries