View Single Post
Old 31 October 2013, 18:08   #292
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,559
Quote:
Originally Posted by amilo3438 View Post
Last A500 (Demo) by Oblivion

A500 OCS/ECS ... glitches on cube rotation part?! (Interesting, it doesnt happens on AGA!)
It is never interesting, most likely caused by some CPU emulation timing problem (possible even same as Anarchy's Madness 2)

Working with AGA config only means it is not badly coded

Quote:
EDIT:
Feel Blue (Intro) by Oblivion

Another scrolling text issue (pic.2)!
Yeah, same problem.

Quote:
Originally Posted by amilo3438 View Post
TRSI Easter Party Demo by Panic & Agnostic Front

A500 ECS ... on the end of demo, while I tried to do reset from WinUAE Propertis, it crashes!
It crashes very badly, stack pointer points to custom registers and CPU keeps generating exceptions = all kinds of garbage gets written to custom registers. (log shows it very clearly). Probably some programmed refresh rate register (ECS only) gets too bad values that are not fully validated.

btw, remember that only dump files from official betas can be used for debugging purposes.

Quote:
Originally Posted by amilo3438 View Post
Megademo by Sargon & Red Sector Inc. & Thrust & Phalanx & Shadow Light

A500 OCS/ECS ... upper row pixels of word "SARGON"?! (pics.1,2,3)
This is OCS only. ECS = single mismatched row. Emulation slightly tweaked to match this behavior.

Probably yet another demo that does not clear/initialize memory it uses and assumes some bootblock/menu etc.. does it. A500 confirmed, shows same garbage.
Toni Wilen is offline  
 
Page generated in 0.06813 seconds with 9 queries