Thread: Beats of Fire
View Single Post
Old 17 November 2012, 19:48   #26
Registered User
Join Date: Nov 2011
Location: Nuernberg
Posts: 386
Originally Posted by Lielo View Post
Thanks to everyone for taking the time to check this and respond! You helped make a rough day @work disappear.

A bit more information I think:

This project was started with the intention of creating a decent side scrolling beat-em-up for the Amiga. There have been some notable attempts but for me there was always something missing! Final Fight was one of my fave arcades of the era and after plugging away in Amos Pro for a couple of weeks I switched to Blitz Basic2. So I'm not an amazing programmer and this is my first attempt using BB2.
I haven't posted before now as I'd hate for this to become another one of those projects that just runs out of steam. I think now that even if Final Fight becomes out of reach there's enough here to begin creating something decent for the Miggy. I'm definitely interested in making another game either after this or as soon as it becomes too much. Bearing this in mind, If someone wants to help with graphics or improving the code then that would be great.
I'm sticking with FF for now... Good learning curve!

Technical stuff that should help explain some of the issues:

Dual playfield display - one for bobs (the baddies) and one for the background. 2 Palettes of 15 colours (minus colour 0 in each case)
Player is a 64px wide sprite sharing its palette with the parallax background.
The parallax layer is made of 3 colour sprites and sits behind both playfields. The player sprite is displayed either in front or below the bobs playfield to add the illusion of depth. The remaining bob priority is controlled by selective blitting - which I've made as fast as I can whilst sacrificing a bit of accuracy.

It aint perfect!

@Boo Boo. If I push the number beyond 6 I get the same thing. It could be the style of blitting I've gone for. I'll check older versions, but of course, there has to be a limit! Could just be the lack of DMA time, or my programming!

@ frikilokooo. The colour in the shadow is due to me messing with the colour of the parallax background layer. I reduced a lovely 16 colour scene to 3 colours but ATM I'm using the wrong registers.
I also get the weird background colours sometimes, it's just something you press on with when your program is 'young' and you're fed up of messing with the graphics! But will be fixed. As to the other bugs, they are numerous and I appreciate them being pointed out.

@s2325. Thanks for posting that! Looks the same as mine albeit a baddy or 2. Is this 020? It's encouraging if that's the case.
Great work. Have just tested it on Aros Vision and it works.

Screenshot here:
OlafSch is offline  
Page generated in 0.06885 seconds with 9 queries