View Single Post
Old 07 August 2012, 13:03   #17
Gilloo
Registered User
 
Join Date: Nov 2010
Location: Grenoble, Isère, Rhône-Alpes, France, Europe, Earth
Posts: 159
Quote:
Originally Posted by Toni Wilen View Post
I said in non-JIT mode it is only supported in latest betas..
where is the latest beta? please, I will do the test..

Quote:
Originally Posted by Toni Wilen View Post
What Amiga address?
anything in fastmem, or local variable on stack (amiga emulated I mean)

Quote:
Originally Posted by Toni Wilen View Post
What did 105 return?
Not got the time to see if 105 returns something, the emulator was crashing... (Windows is collecting data... ... ...)

Quote:
Originally Posted by Toni Wilen View Post
Why do you need "Z3 offset"?
Not my own use, but Wazp3D use it!

Quote:
Originally Posted by Toni Wilen View Post
Any Amiga address (chip or fast or whatever RAM) + 105 function return value = correct address. Everything is linear mapped (except IO or some other non-RAM special regions).
If you say that amiga memory is linear mapped in the emulator, I thrust you. But inside the source code I got (1.4.4.0) it's not the case.

Quote:
Originally Posted by Toni Wilen View Post
btw, make sure you use unsigned address variables because returned address can be very high in 32-bit address space if using 64-bit Windows. (like 0x7fxxxxxx or larger) to prevent negative results and crashes..
ok, all in ULONG 32bits

something outside WinUAE, but related with ANAIIS.
Toni, have you fix something for PFS3 WB1.3 ? It guruhize when unmounting...
Gilloo is offline  
 
Page generated in 0.05151 seconds with 9 queries