View Single Post
Old 03 January 2011, 02:42   #2
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,570
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by d0pefish View Post
Hi!

Has anyone tried using Doobrey's patch of scsi.device, version v44.2 on a real A600?

On my A600, I am using a CF card, and I have been trying scsi 44.2 under various Kickstart (2.05/3.1), filesystem (PFS3/SFS) and CPU (68000/68030) configurations - both as a cooked-in Kickstart modification, and more simply with LoadModule.

What happens is that as soon as the machine reboots with either the modified Kickstart or scsi 44.2 LoadModule'd, the HD light blinks, and then I get "Not a DOS disk in device DH0:". If I try to load HDToolbox, it hangs on scanning the scsi.device.

*Something* is recognised, because the Early Startup menu shows the DH0 partition in the list, and correctly identifies its partition type.

Reboot without v44.2, and the drive works perfectly.

Weirdly enough, scsi 44.2 works perfectly under WinUAE (A600 chipset configuration) on the same drive I am using on the real machine, by way of the CF reader, set as IDE0. I can LoadModule scsi 44.2, the emulated A600 resets, and the CF card boots fine. In a Shell, "version scsi.device" reports back v44.2, and HDToolbox shows my card correctly under scsi.device.

All other versions of scsi.device I have tried have been fine, namely 43.43, 43.45, and obviously the built-in KS2.x and 3.1 versions.

I'm certain that the patch process was alright (otherwise it wouldn't work in UAE, surely?) and I definitely used the A600 .pch file.

It's not the end of the world obviously, but I wondered if anyone else can recreate the problem at their end. If so, what's wrong with the patch?

I've just been trying to compare various device versions and filesystems to find the best speed.

Cheers
Download, BB3 or was it BB4.
One of them will patch it for you.

I normally do a fresh install, BB1, then BB2, then BB3, then BB4.
I then back it up, once all working, .
FOL is offline  
 
Page generated in 0.06073 seconds with 9 queries