Thread: X-Copy shrine
View Single Post
Old 26 November 2010, 14:40   #47
AMR / HOL Contributor

niobyte's Avatar
Join Date: May 2007
Location: Perth Western Australia
Posts: 146
I found X-Copy Maraude It Professional v1.2 (13/09/88 | 01/10/88) amongst my disks.

I decided to dump it considering it is not in TOSEC (also renamed it accordingly). I noticed no versions prior to version 2.x are in TOSEC or on the XCopy Shrine.

This 1.2 version appears to only work with Chip RAM & Fast RAM allocated (Slow RAM intermittently works?).

256/512k/1MB Chip RAM Allocated (Memory Map: 000000->0FFFFF) - XCopy appears to be in a monochrome appearance (Grayscale + 4 colours; Cyan, Green, Light Purple & Red) - Left Screenshot (Weird the date is different; 13/09/88)

2 MB Chip RAM Allocated (Memory Map: 1FFFFF) - XCopy appears in full colour - Right Screenshot (Weird the date is different; 01/10/88).

Note: Slow RAM must not be allocated otherwise it crashes (seems to be intermittent - when it does work it uses Grayscale+4 colours in 512k slow & full colour with 1MB slow)

This version possibly contains a memory check/map bug (weird since it is intermittent)?

The issues experienced could be emulation related. As I haven't tested this on real A500 hardware in years.

You can find the ADF image in the zone (ZIP Archived).
Attached Thumbnails
Click image for larger version

Name:	xcopy1_2-512KB.png
Views:	305
Size:	7.3 KB
ID:	27177   Click image for larger version

Name:	xcopy1_2-1MB.png
Views:	301
Size:	8.9 KB
ID:	27178  

Last edited by niobyte; 26 November 2010 at 15:57. Reason: Additional info
niobyte is offline  
Page generated in 0.05892 seconds with 10 queries