View Single Post
Old 17 February 2010, 23:21   #1
Ebster
Registered User
Ebster's Avatar
 
Join Date: Oct 2004
Location: Frankfurt / Germany
Age: 42
Posts: 303
Problem with very low Chipmem... (Startup-Sequence?!)

Can someone tell me what eats my chipmem, please?

I am using Amigasys4 with OS3.9 BB3 in HighGFX mode, 32 colors, and currently have 1.019 MB of Chipram after Booting. I think it should be about 500KB more. You can see the few tweaks/patches i use below. When i reboot without Startup-sequence and enter "avail" i see about 500KB of Chipram being used even without the WB. Turning the machine off for some seconds and then on again, i get about 2MB with the "avail" command before the WB is booted. So the RAM must be taken away during the first boot process and stays away permanently when i reset the machine. Clearing WBStartup didn't help. And this is not due to the HighGFX, lowering the resolution and colors gains only very little memory...

Here is my Startup-sequence:
(Specs in my Signature)


; $VER: AmigaSYS 4 AGA
; Startup-Sequence for hard drive systems
; AmigaSYS 4 AGA.



If Exists C:IDEFix
C:IDEFix
EndIf

;mod7
SYS:C/LoadModule L:FastFileSystem L:RAM-Handler L:Shell-Seg DEVS:scsi.device LIBS:icon.library LIBS:workbench.library NOREBOOT REVERSE
;mod7end





SYS:C/SetPatch SKIPROMMODULES fastfilesystem,icon.library,ram-handler,scsi.device,shell,workbench.library QUIET
C:FastExec FASTEXP FASTSSP FASTVBR PATCH REBOOT

;failat 21



;mod3
C:BlazeWCP
;mod3end

;mod6
C:TagLIFE
;mod6end

;mod5
C:VBRcontrol ON QUIET
;mod5end

echo "dh0:idefix97/cd32/gamestore" >envarc:sys/nv_location

assign Env: ram:
GetMouseInput
if $MouseInput eq 2
execute System:S/NoStartup
else

delete >NIL: ram:MouseInput

C:Version >NIL:
C:AddBuffers >NIL: DF0: 15
FailAt 21

run >NIL: C:Play16 System:Boot/BootSample
run >NIL: C:Picboot l=s:PicBoot fi 1 fo 1

C:MakeDir RAM:T RAM:Clipboards RAM:ENV RAM:ENV/Sys
C:Copy >NIL: ENVARC: RAM:ENV ALL NOREQ

Resident >NIL: C:Assign PURE
Resident >NIL: C:Execute PURE

Assign >NIL: ENV: RAM:ENV
Assign >NIL: T: RAM:T
Assign >NIL: CLIPS: RAM:Clipboards
Assign >NIL: REXX: S:
Assign >NIL: PRINTERS: DEVS:Printers
Assign >NIL: KEYMAPS: DEVS:Keymaps
Assign >NIL: LOCALE: SYS:Locale
Assign >NIL: LIBS: SYS:Classes ADD
Assign >NIL: HELP: LOCALE:Help DEFER

;mod1
FBlit
WBCtrl IMT=ICONFAST MCM=1048576
FText

;mod1end

C:MCP

BindDrivers
C:Mount >NIL: DEVSOSDrivers/~(#?.info)

C:LoadMonDrvs

;IF EXISTS DEVS:Monitors
; IF EXISTS DEVS:Monitors/VGAOnly
; DEVS:Monitors/VGAOnly
; EndIF

; C:List >NIL: DEVS:Monitors/~(#?.info|VGAOnly) TO T:M LFORMAT "DEVS:Monitors/%s"
; Execute T:M
; Celete >NIL: T:M
;EndIF

SetEnv Language "english"
SetEnv Workbench $Workbench
SetEnv Kickstart $Kickstart
UnSet Workbench
UnSet Kickstart

C:AddDataTypes REFRESH QUIET
Run > NIL: "System:C/VisualPrefs"
C:IPrefs
C:ConClip

Path >NIL: RAM: C: SYS:Utilities SYS:Rexxc SYS:System S: SYS:Prefs SYS:WBStartup SYS:Tools SYS:Tools/Commodities

SYS:System/REXXMast >NIL:

IF EXISTS S:User-Startup
Execute S:User-Startup
EndIF

Resident Execute REMOVE
Resident Assign REMOVE

run >nil: System:c/arq
C:LoadWB SIMPLEGELS

;mod2
WbCtrl MNL=100
;mod2end

Assign TXT: DH1:ANWENDUNG_Office/BT-II/Text
Assign PIC: DH1:ANWENDUNG_Office/BT-II/Bilder
Assign BT-II-2: DH1:ANWENDUNG_Office/BT-II
EndCLI >NIL:

Last edited by Ebster; 17 February 2010 at 23:26.
Ebster is offline  
AdSense AdSense  
 
Page generated in 0.06711 seconds with 9 queries