View Single Post
Old 02 August 2002, 15:51   #45
LUKas007
Registered User
LUKas007's Avatar
 
Join Date: May 2002
Location: England
Age: 39
Posts: 159
Yes, Skick 3.44 requires that you have at least 68020 and ks2.04 ... anything better should be fine...
LUKas007 is offline  
 
Page generated in 0.05343 seconds with 9 queries