Thread: Ambermoon
View Single Post
Old 03 July 2009, 17:04   #197
st-th
Bad Taste Development
st-th's Avatar
 
Join Date: Jul 2008
Location: Bonn / Germany
Age: 46
Posts: 48
Quote:
Originally Posted by meynaf View Post
Why keeping the 4 versions ? I think it would be much cleaner to make only one. In addition, a patching system would no longer be required if you ReSource the game. If you can give me all patches you have done, I can even do that for you (after all it wouldn't be the first game I re-source !).
I already did all the necessary resourcing months ago when I started this project.

You can't sensibly use only one binary for all CPUs unless you ditch 68000/010 support (which I don't intend to do).

Part of my effort is a complete localization of the game (most of the strings need to be re-translated anyway). Once done, any version will be able to use the English v1.07 executables.

BTW, the patching mechanism supports all 6 executables, not just the two Am2_#? ones.

The way I do this is quite sensible if you look at the big picture. And it even works. Just wait and see...

Quote:
Originally Posted by meynaf View Post
Well, you have your own way of playing, and some weird bugs probably aren't triggered by it. Someone else would play differently and perhaps have them.
All the stuff I've done so far is thoroughly tested. Once released, you can send me your bug reports if you find something wrong with it.

Or were you talking about the game's original bugs?

Quote:
Originally Posted by meynaf View Post
The rune alphabet in your game box isn't supposed to be used until you find it in the game. Same for the global map.
Sure. But people can use them anyway, if they want. The auto de-runer is off by default and if people turn it on prematurely, it's their decision, like using the items from the box prematurely. And it's not that you run across many runes before visiting Spannenberg anyway, so no big deal even if it's turned on rightaway from the start. This is a total non-issue IMHO.

Quote:
Originally Posted by meynaf View Post
Strangely enough, I never equipped it. Before I equip with anything, I have a look to see if it's indeed better than my actual equipment. It wasn't...
If you don't know that cursed items exist, equipping is quite the normal way to check out an item's damage and protection values.

Quote:
Originally Posted by meynaf View Post
About new players, they're no longer new if they reach that item
New as in "playing Ambermoon for the first time" not "time spent playing Ambermoon" obviously.

Quote:
Originally Posted by meynaf View Post
Anyway the game is never totally ruined. Just reload...
That doesn't necessarily work reliably on German v1.01 due to its save/restore bug. And while v1.01 is "old", it's the only version put onto actual disks, AFAIK, so you might run into this problem if you have an original copy of the game and play it without updating to v1.05 first.

Quote:
Originally Posted by meynaf View Post
How do you manage the thieves having bows, then ? And the first orcs ? Must be painful without that spell.
Nelvin's initial set of spells is enough to deal with the bandits and orcs. Careful use of items (Fire Brand's fireballs) helps, too. But it's much easier with the lame spell, of course.

Quote:
Originally Posted by meynaf View Post
Here, new players would certainly try to learn new spells as soon as they find some. And lose precious SLP if they fail...
After which they hopefully look at their character's stats, check out the "reading magic" value and realize it's better to wait with learning new spells until the character is better at it.

Last edited by st-th; 03 July 2009 at 17:10.
st-th is offline  
 
Page generated in 0.06036 seconds with 9 queries