View Single Post
Old 14 April 2002, 11:12   #11
ethylene
Registered User
ethylene's Avatar
 
Join Date: Jul 2001
Location: Beaverton, OR, USA
Posts: 87
Send a message via ICQ to ethylene Send a message via AIM to ethylene Send a message via MSN to ethylene Send a message via Yahoo to ethylene
I just spent about twenty minutes tooling with the new executable...

First I reinstalled 0.8.21R3 and copied the new executable over that (I had already reverted to 0.8.21R1).

I started with my usual PAL A500 config. I watched the cracktro scroller (Backlash) for Alien Breed 92SE. Just as with the earlier 0.8.21R3, it didn't scroll as smoothly as 0.8.21R1.

I tried altering the PAL A500 config. Tried using different fullscreen modes to see if they would let me use VSYNC, but none did. I'm not a very good debugger, but I tried turning things like Immediate Blits on and off, and changing the sound buffering. None of this seemed to affect the choppiness in a positive manner.

So, I went into the nVidia driver options and changed the VSYNC settings there to Always On, and to Auto Select when Always On didn't help the smoothness. Neither one helped.

Finally, I tried unselecting my gamepad from within WinUAE (I know you wanted a physical disconnect, Toni), but this didn't help either.

Operating system is Windows 98 with all current updates. I have no options in my nVidia drivers to change system-wide refresh rates. I have to either edit the registry keys for the resolutions for which I want to set the refresh rates, or use a third-party utility like Powerstrip.

In 0.8.21R1 it was possible to get a VERY nice VSYNC by manually editing the registry to include "RefreshRate" "50" string in the "720,576" key under the "16" "MODES", and then setting DirectX's VSYNC setting to Always On. I don't know if these manual settings are 'fighting' with the new 0.8.21R3 in my case, or what...

I know you're working hard, Toni, and thank you very much. Good luck!
ethylene is offline  
 
Page generated in 0.05191 seconds with 9 queries