View Single Post
Old 26 October 2007, 20:45   #7
Join Date: Aug 2006
Location: Argentina
Age: 45
Posts: 648
Originally Posted by Retro-Nerd View Post
This is not too hard. Try DeluxeGalaga. This one needs at least KS 2.04.
ah....but that's another thing....also I know that turbotrax and dracula requires kick 2.0+

the thing here is between kick 1.2 & 1.3
laser is offline  
Page generated in 0.09876 seconds with 9 queries