View Single Post
Old 10 January 2007, 02:11   #43
thor
Registered User
thor's Avatar
 
Join Date: Mar 2006
Location: Germany
Posts: 898
But there's still one problem if you would want to compile 1.3.3 with project files (of whatever IDE) as CVS version includes "xdmsconfig.h" in "xdms.c" and that is made by ./configure. So you would have to make one yourself. Easy to do, it just defines VERSION and for MinGW NO_MKSTEMP, but you can't just load the project into the IDE and compile.

I think the best solution is that the "xdmsconfig.h" would be omitted. The version number can be added as a compiler flag as it was in version up to 1.3.2. And that MinGW check is not done with that check in ./configure and defining NO_MKSTEMPS, but by using #ifdef __MINGW32__ in xdms.c.

Last edited by thor; 10 January 2007 at 02:50.
thor is offline  
 
Page generated in 0.06064 seconds with 9 queries