View Single Post
Old 11 January 2006, 19:49   #2
DrBong
HOL / AMR Team Member

DrBong's Avatar
 
Join Date: Dec 2001
Location: Australia
Posts: 2,193
I've been trying to do exactly the same thing this week on and off without any success whatsoever. However, I've just had a real concerted crack at getting SimpleMail and YAM working with Gmail and I have to say that this is one of the few times I've solved the problem without getting to the point of wanting to throw my A4000 out the window first!

Anyway, here's the long and short of it:

(1) Login to Gmail via the web and adjust your settings as detailed here:

http://mail.google.com/support/bin/a...y?answer=13273

Unfortunately you won't be able to do it with any of the Amiga browsers coz the Gmail website will identify your browser as not a "fully supported browser". I got the same message even when logging in using a URL where Gmail doesn't check your browser:

http://mail.google.com/gmail?nocheckbrowser

Maybe if I mucked around with spoofing I might have got lucky with AWeb, which has the best javascript support of any of the Ami browsers. In any case, much quicker changing your settings using Firefox (or similar) on a PC.

(2) Install AmiSSL V1.x and 2.x. They can be found here:

http://www.heightanxiety.com/AmiSSL/

They will happily co-exist in the same directory. Don't know which one solved my problem because I was using MiamiSSL instead of AmiSSL. However, everything magically came together with SimpleMail and YAM once I installed both versions of AmiSSL. I gather this is because the Gmail servers require a modern SSL implementation (which MiamiSSL isn't because it hasn't been in development for quite some time now).

(3) Simply configure SimpleMail or YAM as detailed here:

http://mail.google.com/support/bin/a...y?answer=13287


I can confirm that I was able to send and receive via Gmail perfectly with SimpleMail V0.28. Also, I was able to receive email with YAM 2.4p1 without any problems. Didn't try sending anything with YAM as I didn't want to mess with the email settings for my ISP, but I'm guessing it will work fine.

Hope that helps! Let me know how you get on......

Last edited by DrBong; 11 January 2006 at 20:14.
DrBong is offline  
 
Page generated in 0.05407 seconds with 9 queries