View Single Post
Old 18 February 2005, 03:01   #30
The Ancient One
Join Date: Feb 2002
Location: Kansas City/USA
Age: 61
Posts: 685
Ok, I've now had a chance to look at your Celtic Legends config and compare it to mine, which works great with no sound problems. There are quite a few settings that simply don't make much sense, and could be causing your problems.

Here is a summary of the changes I would suggest you make to your config:

CPU tab:
Advanced JIT settings:
Move Cache size slider to 0 MB
Uncheck "Hard Flush"
Uncheck "Force Settings"
Select "Direct"
CPU Emulation Speed:
Move CPU Idle setting all the way to the left
Select "Match A500 speed"
CPU Type:
Uncheck the JIT checkbox
Select the 68000 CPU type

Chipset tab:
Chipset type:
Select "ECS Agnus"
Collision level:
Select "Sprites and Sprites vs. Playfield"
Misc chipset options:
Uncheck "Immediate Blitter"

RAM tab:
Chip: 1 MB
Fast: 2 MB should be more than enough, and probably don't need any
Slow: 0 MB
Z3-Fast: 0 MB

Misc tab:
Uncheck "BSDsocket.library emulation"
Uncheck "Syncronize clock"

Some of the changes I'm suggesting (such as the 2 on the misc tab) are being suggested simply because they do nothing they do nothing to in any way help you play the game, but they do add a bit to the work that WinUAE has to do. If you're playing a game, whether the emulated Amiga's clock is in sync with the PC's clock is irrelevant, right?

Other changes are being suggested because they could either directly or indirectly be causing a slowdown that affects the sound. For example, you allocated about 50 MB of ram to WinUAE's use, between the nearly 42 MB on the RAM tab and another 8 MB of JIT cache. Given that the game will probably run fine on a real A500 with 1 MB of chip ram, that's an awful lot of wasted ram.

You may be asking what difference that might make, but you have to remember that although you're running WinUAE and not paying attention to anything else, Win XP is still doing work in the background. If you've taken away 50 MB of ram that it might need for various reasons, that can cause it to be short on resources, and that can cause slowdowns that affect you while you're running WinUAE. Your best bet is to always set up your configs so they don't use up any more resources than you really need.

As for turning off JIT, selecting A500 speed, etc., those changes should make the game behave more like it would on the real target platform. If you tell it to run as fast as it can and it can exceed A500 speed, it's just not going to feel right.

Try those settings and see how it works then. If that clears up the problems then you might try the same thing with your config for Space Marines. It just might make a lot of difference.
Chuckles is offline  
Page generated in 0.05464 seconds with 9 queries