View Single Post
Old 26 August 2019, 21:59   #358
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 210
HstWB Installer v1.4.1 is now released at https://hstwb.firstrealize.com with following new downloads available:

HstWB Installer with packages:
  • HstWB Installer v1.4.1 Portable with packages

HstWB Installer without packages:
  • HstWB Installer v1.4.1 Portable without packages

HstWB package and user package installation:
  • HstWB Package Installation v1.4.1
  • HstWB User Package Installation v1.4.1

Prebuild self install images for Amiga's, WinUAE and FS-UAE emulators supporting RDB:
  • 4GB HstWB self install HDF image v1.4.1
  • 8GB HstWB self install HDF image v1.4.1
  • 16GB HstWB self install HDF image v1.4.1
  • 32GB HstWB self install HDF image v1.4.1
  • 64GB HstWB self install HDF image v1.4.1
  • 128GB HstWB self install HDF image v1.4.1

Prebuild self install images for Amiberry, UAE4ARM, UAE4ALL, UAE4ALL2 emulators that doesn't support RDB:
  • UAE4ALL HstWB self install HDF image v1.4.1 (HDF files DH1, DH2, DH3 and DH4 requires surfaces is set to 2. Some Amiga emulators doesn't support this!)
  • UAE4ARM HstWB self install HDF image v1.4.1

v1.4.1 includes following changes compared to v1.4.0:
  • Fixed hstwb image setup patch only, reduced output and updated readme's.
  • Fixed self install amiga os menu selecting default amiga os and files.
  • Added supported amiga os versions check for packages.
  • Updated run script to build all amiga os versions menus for package installation. This fixes detect amiga os issues not showing correct filtering as it's menu didn't exist.
  • Updated install amiga os to write installed version in prefs.
  • Improved amiga os detection with added version.library check.
  • Added classic gaae to hstwb repositories json for updating packages.
  • Updated self install amiga os installation menu to prevent amiga os 3.9 and 3.1 from being installed when using kickstart 3.1.4 due to issues mixing amiga os and kickstart.
  • Updated detect amiga os to not allow mixed kickstart 3.1.4 and amiga os 3.1.
  • Updated run and setup scripts to ensure kickstart 3.1.4 can only be used to install amiga os 3.1.4.
  • Improved amiga os and kickstart installation n/a options with descriptions.
  • Updated hstwb packages json for updating packages.

This release fixes the issues with installing BestWB 1.2 using Kickstart rom 3.1.4. It's also fixes the "Run" menus for ClassicWB OS39 installed with Amiga OS 3.1.4, which was missing WBRun.

Again a lot of testing delayed the release, but it's released now and should finally enable ClassicWB with Amiga OS 3.1.4 and 3.1.4.1.

Have fun with the release and please report any issues
cyberhead97 is offline  
 
Page generated in 0.04103 seconds with 10 queries